Results 1 to 2 of 2
  1. Thread Author  Thread Author    #1  

    Default 4g Sim Card Error

    Good morning AndroidCentral crew --

    Just curious if anyone else is seeing the "Red" Sim Card error on their MotoX? I got mine on 9/6/13, activated and had no issues for 2 days with the Moto. But starting yesterday... all day and again today, Im getting the red flashing icon that means Sim Card is not present or readable according to the user guide.

    As result the phone starts to heat up quickly and I it wont connect to any of the networks. So I had to switch to wireless only.

    Ive tried all the normal troubleshooting: Remove the sim, clean it with, reinsert, etc... restarting, factory reset, etc etc.

    I read a lot of the HTC One phones had issues with the 4g Sim Cards failing, and it appears to be a mix of the chip itself failing in some cases...but just as many cases with the little slider socket not pressing the chip tightly against the reader inside the phone (so some folks were placing tape on the back of their sim card to force a tighter fit).

    Ive not seen a thread on this for Moto X yet... (unless I missed it). Ill head to Verizon to swap out the sim card today and hope that resolves it.

    Any others having same issue?
  2. #2  

    Default Re: 4g Sim Card Error

    I have this constantly (no sim card detected icon, then emergency call only, then back to service when it had good signal to start) - it will drop when asked to do something data intensive like a speed test. Have you solved your issue yet? Moto X developer edition with an ATT go phone sim card. Tried a new SIM card, which did not fix the problem. Great signal when I have it, but I seem to get this several times daily.

Similar Threads

  1. Help find videos randomly lost from SD card!!!
    By TRD0810 in forum Samsung Galaxy S3
    Replies: 7
    Last Post: 09-10-2013, 01:05 AM
  2. Micro SD card problem
    By Amb666 in forum General Help and How To
    Replies: 7
    Last Post: 09-09-2013, 10:15 AM
  3. Samsung Galaxy Attain 4G in Boot Loop
    By Laurkin in forum General Help and How To
    Replies: 3
    Last Post: 09-09-2013, 12:24 AM
  4. Replies: 1
    Last Post: 09-08-2013, 11:55 PM
  5. Error message on lg optimus pro e975 - urgent help required
    By gantswood in forum General News & Discussion
    Replies: 0
    Last Post: 09-08-2013, 02:50 PM

Posting Permissions

B