Results 1 to 2 of 2
  1. Thread Author  Thread Author    #1  

    Default Bought unlocked (T-Mobile) version, no LTE on AT&T

    I just got an unlocked version of the Moto X through the sale earlier this week and when I put my sim card in, I only register HSPA.

    The card was just in my iPhone 5 and got LTE no problem.

    I called AT&T, two reps made me turn the phone on and off about a dozen times, checked SIM and IMEI numbers, etc., it still doesn't work.

    Anyone have any advice?

    [UPDATE: Just checked on another forum, found the fix: Settings->Wireless& Networks>More->Mobile Networks>Network Mode: AUTOMATIC-- nothing was checked on mine previously. All good.]
    Last edited by mehbehdeh; 01-30-2014 at 06:57 PM.
  2. #2  
    UJ95x's Avatar

    Posts
    5,449 Posts
    Global Posts
    5,528 Global Posts
    ROM
    Slim Kat 4.4.2 Build 3

    Default Re: Bought unlocked (T-Mobile) version, no LTE on AT&T

    Quote Originally Posted by mehbehdeh View Post
    I just got an unlocked version of the Moto X through the sale earlier this week and when I put my sim card in, I only register HSPA.

    The card was just in my iPhone 5 and got LTE no problem.

    I called AT&T, two reps made me turn the phone on and off about a dozen times, checked SIM and IMEI numbers, etc., it still doesn't work.

    Anyone have any advice?

    [UPDATE: Just checked on another forum, found the fix: Settings->Wireless& Networks>More->Mobile Networks>Network Mode: AUTOMATIC-- nothing was checked on mine previously. All good.]
    Cool. Glad you got it fixed
    Welcome to Android Central btw
    Everything in this post is 100% accurate...I think

    R.I.P. Motorola...and what could have been the best smartphone line ever

Similar Threads

  1. Replies: 10
    Last Post: 02-01-2014, 07:00 PM
  2. No Google Hangouts notifications after 4.4 update
    By princesultan in forum Moto X
    Replies: 7
    Last Post: 01-31-2014, 10:18 PM
  3. Replies: 4
    Last Post: 01-31-2014, 10:56 AM
  4. LTE won't switch back.
    By joselito76 in forum Google Nexus 5
    Replies: 5
    Last Post: 01-31-2014, 05:04 AM
  5. 4G LTE In Columbus Ohio?
    By JoeyStyles in forum Sprint
    Replies: 1
    Last Post: 01-30-2014, 05:38 PM

Posting Permissions

B