Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 4 of 4
  1. Thread Author  Thread Author    #1  

    Default Moto X: 4.4.2 signal issues

    I was just wondering if the update included a change to the radios. My phone is having trouble holding on to 4G much more frequently.

    Sent from my XT1060 using AC Forums mobile app
    Last edited by NotJustAPhone; 03-05-2014 at 09:32 AM.
  2. #2  

    Default Re: 4.4.2 signal issues

    I'm totally the opposite. I had massive wifi and signal loss prior to 4.4.2 but my signals 100% better now.

    Sent from my SM-N9005 using Tapatalk
    Thanked by:
  3. Thread Author  Thread Author    #3  

    Default Re: 4.4.2 signal issues

    Quote Originally Posted by steve short View Post
    I'm totally the opposite. I had massive wifi and signal loss prior to 4.4.2 but my signals 100% better now.

    Sent from my SM-N9005 using Tapatalk
    A factory reset may be in order

    Sent from my XT1060 using AC Forums mobile app
  4. #4  

    Default Re: Moto X: 4.4.2 signal issues

    Mine is having trouble... At least in my mind... Holding onto wifi more with the 4.4.2 update... Network connectivity seems the same to me

    Posted via my Moto X DE

Similar Threads

  1. Replies: 20
    Last Post: 03-10-2014, 08:16 AM
  2. Google Play store issues
    By Aurelien Brandt in forum Samsung Galaxy S3
    Replies: 6
    Last Post: 03-06-2014, 12:26 AM
  3. Replies: 3
    Last Post: 03-05-2014, 09:30 AM
  4. Quick Glance Issue
    By erasat in forum Samsung Galaxy S4
    Replies: 1
    Last Post: 03-05-2014, 02:45 AM
  5. Galaxy S3 Docking Issue
    By Brightbull in forum Samsung Galaxy S3 I9300
    Replies: 0
    Last Post: 03-04-2014, 06:52 PM

Posting Permissions