Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 24 of 24
Like Tree1Likes
  • 1 Post By Puzzlegal
  1. Thread Author  Thread Author    #1  

    Default Lost "navigate home" on Moto X with update to 4.4.2

    Until I updated to 4.4.2 (Sprint) I could say, "Okay Google Now, Navigate Home", and it would start up voice navigation to get me home. Now it just does a google search of the words "navigate home", and brings up a few shops with "home" in their name, and a bunch of links to discussion forums and blogs with people complaining that "navigate home" (and similarly, "navigate to work") don't work. But I haven't found any solutions in those links, so I thought I would start a new discussion forum post.

    Anyhow, does anyone have any advice on what went wrong, and how I might fix it?

    I may also have 4G connectivity problems with the update. There are places along my commute where it says "4G", but if I try to access the internet it doesn't load stuff.
    Last edited by NotJustAPhone; 03-09-2014 at 11:46 AM.
  2. #2  

    Default Re: lost "navigate home" on Moto X with update to 4.4.2

    I just tested and navigation and turn by turn voice directions started right up as it should. You might try rebooting phone, cache partition wipe and settings, all apps, Google Search and wipe data and cache, maybe do the same for Touchless Control. Also, I'm seeing a lot of posts about bugs since the last Touchless Control update, so there may be some other issues going on. I've noticed that my phone isn't as reliable at responding at all to the OK Google Now command and that I have to repeat the command multiple times sometimes before it responds.
    Thanked by:
  3. Thread Author  Thread Author    #3  

    Default Re: lost "navigate home" on Moto X with update to 4.4.2

    Quote Originally Posted by ETPhoneHomeT View Post
    I just tested and navigation and turn by turn voice directions started right up as it should. You might try rebooting phone
    done several times. (The phone has been a little unstable since the update, and has rebooted itself twice.)

    Quote Originally Posted by ETPhoneHomeT View Post
    cache partition wipe and settings, all apps, Google Search and wipe data and cache, maybe do the same for Touchless Control.
    Thanks. How do I do these?

    Quote Originally Posted by ETPhoneHomeT View Post
    Also, I'm seeing a lot of posts about bugs since the last Touchless Control update, so there may be some other issues going on. I've noticed that my phone isn't as reliable at responding at all to the OK Google Now command and that I have to repeat the command multiple times sometimes before it responds.
    I'm not having any trouble with that. It responds to "okay google now" very reliably, and thinks a bit, and types exactly what I said. It just isn't reacting appropriately to those words, for instance, doing a google search on the phrase "navigate home" instead of starting up navigation
  4. #4  

    Default Re: lost "navigate home" on Moto X with update to 4.4.2

    One thing that I might add is that sometimes, I don't know why, but these things kind of have a way of fixing themselves on Android. So, you might want to wait a day or two and see if the problem goes away on its own.

    Cache partition wipe process: https://motorola-global-portal.custh...he/action/auth
    This doesn't hurt anything and I'll usually do this process once a week or so and it seems to help keep the phone in top running condition.

    The second process suggested was to go into the individual apps for Touchless Control and Google Search in your main settings and to clear the cache and data.
    - Settings
    - Apps
    - Swipe right until you see All Apps
    - Scroll down and find Google Search app and tap on it (same thing for Touchless Control)
    - Click on the clear data and clear cache buttons

    I don't know for sure if these will resolve your issue. These are just some tried and true troubleshooting steps whenever you encounter bugs in the operation of the phone.

    Other things you can try if the above processes don't fix things:
    - Boot into Safe Mode: https://motorola-global-portal.custh...61/action/auth
    If this resolves your problem, this will indicate that you likely have a conflict with a third party app on your phone that is causing the issue.
    - Last resort is a Factory Data Reset:
    Keep in mind that doing a FDR wipes all of your data, so you should backup your data somewhere so you can recover it later.

    Good luck!
    Thanked by 2:
  5. Thread Author  Thread Author    #5  

    Default Re: lost "navigate home" on Moto X with update to 4.4.2

    Thank you. Neither wiping the cache partition nor clearing the cache and data for the relevant apps seems to have fixed the problem, but I'm glad I tried them. I guess trying safe boot is next up.
  6. Thread Author  Thread Author    #6  

    Default Re: lost "navigate home" on Moto X with update to 4.4.2

    I just wanted to add
    Quote Originally Posted by ETPhoneHomeT View Post
    The second process suggested was to go into the individual apps for Touchless Control and Google Search in your main settings and to clear the cache and data.
    - Settings
    - Apps
    - Swipe right until you see All Apps
    - Scroll down and find Google Search app and tap on it (same thing for Touchless Control)
    - Click on the clear data and clear cache buttons
    I was able to find and clear cache/data from "downloaded apps" But when I looked at "all apps", I found a ton of mysterious stuff.
    com.motorola.thermalservice?
    com.qualcom.privinit?
    Motorola Slpc Service?
    Literally dozens of things that I don't understand. Is there any resource to look up what those are?
  7. Thread Author  Thread Author    #7  

    Default Re: lost "navigate home" on Moto X with update to 4.4.2

    !! Safe boot doesn't work. I tried it, and now I am stuck in a loop where it says "unfortunately, Launcher has stopped." When I click "okay", (the only option) it briefly flashes my background screen, and then pops up the same message.

    I was able to exit the loop by pressing and holding the power button, turning it off, and then turning it on normally. But now my folders (from Folder Organizer) are gone, as is my weather widget from "Beatiful Widgets". I was able to add them back to my home screens in the usual way, but this seems very odd.

    "Okay Google now.... Navigate to work" is still bringing up a google search with the entries all being other people complaining about "navigate to work" not being recognized, though. :s
    Last edited by Puzzlegal; 03-09-2014 at 11:45 AM.
  8. #8  

    Default Re: lost "navigate home" on Moto X with update to 4.4.2

    i feel your pain. i had similar issues, i did everything but the hard reset to no avail. i ended up doing a hard reset (i know, i just saw you squirm) and it ended up fixing all the issues. my only beef is with assist being wishy washy.
    Thanked by:
  9. Thread Author  Thread Author    #9  

    Default Re: Lost "navigate home" on Moto X with update to 4.4.2

    Thanks. That's actually sort of hopeful. It leads me to think that if I do a factory reset, it might clean stuff up.

    I had hardware problems with my first Moto X, and had to replace it, so I am sort of set up to do yet another factory reset. I have "mirror" directories on my computer with photos, music, ringtones, etc. I've moved most of my contacts to Google. I've gotten fairly fast at resetting k-9 with my three email accounts, and and at creating and deploying widgets and folders.

    Maybe the biggest downside is the forced update of apps. Right now I have several apps I'd prefer not to update, due to downgrades or bugs (downgrades like more ads or fewer free levels). But I don't think any are dealbreakers.
  10. Thread Author  Thread Author    #10  

    Default Re: Lost "navigate home" on Moto X with update to 4.4.2

    Gah. I made the mistake of asking Motorola. I am now talking to a technical support person who doesn't seem very bright, and who seems extremely reluctant to tell me what she wants to do before trying to do it.

    I have not had good luck with Motorola technical support!
  11. #11  

    Default Re: lost "navigate home" on Moto X with update to 4.4.2

    Quote Originally Posted by Puzzlegal View Post
    !! Safe boot doesn't work. I tried it, and now I am stuck in a loop where it says "unfortunately, Launcher has stopped." When I click "okay", (the only option) it briefly flashes my background screen, and then pops up the same message.

    I was able to exit the loop by pressing and holding the power button, turning it off, and then turning it on normally. But now my folders (from Folder Organizer) are gone, as is my weather widget from "Beatiful Widgets". I was able to add them back to my home screens in the usual way, but this seems very odd.

    "Okay Google now.... Navigate to work" is still bringing up a google search with the entries all being other people complaining about "navigate to work" not being recognized, though. :s
    Weird. I just tried booting into safe mode and it worked without any problem. Sorry, but I'm out of ideas outside of a full factory data reset. Even with that, there is no guarantee it'll resolve the issue and although it can be a pain doing one, when I've done them before after an OS update, it usually has resolved my issues. I've done them frequently after OS updates, but so far with 4.4.2., I haven't had to. Like I said before, sometimes problems like these (especially with Google and Motorola software it seems) have a way of correcting themselves after a temporary period. So, you might want to wait a couple of days to see if the issue resolves itself.
    Thanked by:
  12. Thread Author  Thread Author    #12  

    Default Re: Lost "navigate home" on Moto X with update to 4.4.2

    Yeah, I see a factory reset in my future. Probably next weekend. Thanks for all your help.
  13. #13  

    Default Re: Lost "navigate home" on Moto X with update to 4.4.2

    I had the same issue with my Nexus 5. Navigate home would give me 3 random locations with "home" in description. The fix... When you sign into chrome, allow its access to your location. In setting allow Google to track you. That worked for me.
    Thanked by:
  14. Thread Author  Thread Author    #14  

    Default Re: Lost "navigate home" on Moto X with update to 4.4.2

    Well, a factory reset didn't fix the issue. After I get through all the more important parts of re-setting-up my phone, I will try cbarnhil's recommendation. Sigh. What a pain.

    re-load apps
    re-select key settings (like using swype)
    re-set-up folder organizer
    re-set-up K9 mail (three accounts, a couple of names within some accounts)
    re-load photos and music and other sounds
    re-set background picture
    That's probably it. I'm done with 1, part way through 2 and 3.
  15. #15  

    Default Re: Lost "navigate home" on Moto X with update to 4.4.2

    Yeah its a pain to do a factory reset. That's exactly what I ended up doing. In fact, its because of the factory reset that I notice "precise location" at the bottom of the main Google search page. Since I basically had to setup everything from scratch. Good luck, hope it works out.

    Posted via Android Central App
  16. Thread Author  Thread Author    #16  

    Default Re: Lost "navigate home" on Moto X with update to 4.4.2

    Quote Originally Posted by cbarnhil View Post
    I had the same issue with my Nexus 5. Navigate home would give me 3 random locations with "home" in description. The fix... When you sign into chrome, allow its access to your location. In setting allow Google to track you. That worked for me.
    Hmm, I don't think that has worked, either. I
    told Settings that Google could track me
    logged onto chrome, and let it talk to my google account
    went through the tutorial, and typed in search term ("navigate to work", just for kicks)
    It said it wanted access to my location, and I said "yes".
    I rebooted the phone, just for good measure.

    but "okay google now, navigate to work" still doesn't work.

    On the plus side, I can now boot into "safe mode" at least. (and "navigate to work" doesn't work in Safe mode, either. But at least "safe mode" works, which makes me feel the factory reset may have been a good thing to do for general maintenance reasons.)
  17. #17  

    Default Re: Lost "navigate home" on Moto X with update to 4.4.2

    I have finally found out the problem. Open your Google maps app. Go to settings. Where it has "set home/work", delete them. Do not put you addresses back into Google maps. Close the app after erasing home and work address. Now go to your home screen and say " OK Google, navigate home". You'll be prompted to input your home address (same way with work as well). Then you'll be back to enjoying Google now again.

    Posted via Android Central App
  18. Thread Author  Thread Author    #18  

    Default Re: Lost "navigate home" on Moto X with update to 4.4.2

    I got it back yesterday in a slightly different way. Since posting above, I have given Google every permission I could think of. Even so, from time to time it asked me for another permission. Yesterday it asked me for permission to store map history (I think) and now "navigate home" works again.

    My plan is to slowly remove permissions, and see how much I can remove without breaking anything.

    While playing with the map, I got a weird glitch. I tried to navigate home from an area where I didn't have data service, but did have a view of the GPS satellites. When I tried using voice commands, it correctly translated my request into text, and then said "google isn't available". When I touched the screen to tell it where to go, it stated navigating, but although the screen showed me what street I was on, the voice instructions didn't have that info. They said "turn left" "turn right ahead", without ever saying the name of the street (or the distance, I think) until I got back into cell coverage. Isn't that weird?
    Last edited by Puzzlegal; 03-23-2014 at 08:28 AM.
  19. #19  

    Default

    As far as telling your navigation directions, it may be that maps were pre-cached. My old Galaxy s2 still gave directions as long as I had GPS signal. And some parts of Google now are pre-installed for offline use.

    Posted via Android Central App
  20. Thread Author  Thread Author    #20  

    Default Re: Lost "navigate home" on Moto X with update to 4.4.2

    It actually wasn't, at least, not intentionally by me. I had recently cleared a lot of google data in an attempt to get "navigate home" to work.

    The funny thing is, I have since re-cached a lot of map data, turned off "Google now" and location tracking, and undone most of what I did to get it too work, and it's still working. The "lost navigate home" is cheeky a bug that gets triggered in some unintuitive way, and not the direct result of any if the settings I have twiddled.
  21. #21  

    Default

    It may be slight differences in devices too. Moto X vs Nexus 5. I haven't spent much time with the moto x but from what I've seen its a pretty awesome device. Every device has its "quirks" I suppose. Like Google now, hands free, only works on the home screen(Nexus 5). I think the Moto X is always listening... I think.

    Posted via Android Central App
    Last edited by cbarnhil; 03-25-2014 at 03:20 PM.
  22. #22  
    Ry
    Ry is offline
    Ry's Avatar

    Posts
    7,831 Posts
    Global Posts
    7,838 Global Posts

    Default Re: Lost "navigate home" on Moto X with update to 4.4.2

    Still working fine for me.
    a.k.a. RyZR from HoFo
    Motorola Moto X (164.55.2.ghost_verizon.Verizon.en.US, KitKat 4.4.2)
    Motorola Moto G (173.44.20.falcon_cdma.Verizon.en.US, KitKat 4.4.2)
    Motorola DROID Bionic (98.72.22.XT865.Verizon.en.US, Jelly Bean 4.1.2)
    Google Nexus 7 2012 (KTU84P, KitKat 4.4.4)
    What other devices have I had? Here's my phone timeline.
    Support your favorite Android app and game developers. Pay for apps! And don't block ads!

    Community Rules & Guidelines - Mobile Nations Forums
  23. #23  

    Default

    Mine had some strange bug that didn't recognize my home unless I spelled it out word for word... It fixed itself once I deleted my home and work addresses from Google maps app. Then saying "OK Google navigate home", gave me an option to put in home address for Google now.

    Other than that one incident, I've had no problems whatsoever.

    Posted via Android Central App
  24. Thread Author  Thread Author    #24  

    Default Re: Lost "navigate home" on Moto X with update to 4.4.2

    Quote Originally Posted by cbarnhil View Post
    It may be slight differences in devices too. Moto X vs Nexus 5. I haven't spent much time with the moto x but from what I've seen its a pretty awesome device. Every device has its "quirks" I suppose. Like Google now, hands free, only works on the home screen(Nexus 5). I think the Moto X is always listening... I think.

    Posted via Android Central App
    Yup, always listening.

    I'm pretty sure it is a bug, and not some obscure feature. And bugs almost always hinge on slight differences in devices, and other quirks. I'm happy the problem seems to have cleared up. And I do like the device, but I'm a pretty easy audience. I don't really push it that much. I like that it fits in my pocket and feels good in my hand. And I like that it's usually pretty responsive. and I'd like more battery life, but this is good enough. But I mostly use it for email, on-line forums (like this one) some light navigation, and a few simple games. I would probably be happy with any other smaller device that had the cell service I need.
    cbarnhil likes this.

Similar Threads

  1. Excellent Condition AT&T Black 32GB HTC One with UAG Case
    By garyf33 in forum Marketplace Archive
    Replies: 8
    Last Post: 03-10-2014, 04:56 PM
  2. Note 3: couldn't charge after 4.4.2 update
    By Liar Xp in forum Samsung Galaxy Note 3
    Replies: 5
    Last Post: 03-09-2014, 01:37 PM
  3. Replies: 3
    Last Post: 03-09-2014, 11:01 AM
  4. Replies: 1
    Last Post: 03-09-2014, 10:10 AM
  5. Lost my phone S4
    By Sameer Dawood in forum Samsung Galaxy S4
    Replies: 2
    Last Post: 03-09-2014, 07:35 AM

Posting Permissions