1. Masheen's Avatar
    So I ran into a bit of a qualm, my Phone Data is not syncing properly and is causing a ton of CPU wakelocks from Google+, over 9,000 wakelocks in a 5m period. The last time the people app successfully synced was 12/25 and I tried to remedy the issue by wiping data for google play services. This did nothing to help the sync problem. I am going to go over my disabled app list and check to see if anything is interfering, but I doubt that it would have an effect because I haven't disabled anything new since a month of so after I got the phone in August last year. Has anybody else ran into this issue and/or can help with the resolution. I greatly appreciate your insights.
    01-07-2014 08:31 PM
  2. doogald's Avatar
    If Google+ is giving the wakelocks, I think I'd wipe data on that app and see if that helps.
    01-07-2014 10:02 PM
  3. Masheen's Avatar
    Wiped Google+, still sync error for people app. Thanks though.

    Posted via Android Central App
    01-07-2014 11:37 PM
  4. doogald's Avatar
    As long as you have no contacts that aren't synced, try wiping data for contacts storage (you'll find it in the all tab in settings / apps.) If you then start having sync issues with calendars, it would be calendar storage. If you keep having issues after that, it might be time to try a factory data reset...
    01-08-2014 06:13 AM
  5. Unobtanium's Avatar
    I don't use G+, so just a SWAG: Have you changed your password (or has someone else - can you access your account across devices)? Have you added or dropped 2-factor authentication?

    Posted from my XT1080M
    01-08-2014 07:45 AM
  6. kkhanmd's Avatar
    Is your Wi-Fi working OK? Do you have data on your chrome browser?

    Posted via Android Central App
    01-08-2014 10:34 AM
  7. B. Diddy's Avatar
    How's your mobile data signal? If you have lousy signal, it might be causing problems with the sync.

    You could try completely removing your Google account, then adding it back again.
    01-08-2014 12:42 PM
  8. Masheen's Avatar
    I don't use G+, so just a SWAG: Have you changed your password (or has someone else - can you access your account across devices)? Have you added or dropped 2-factor authentication?

    Posted from my XT1080M
    Haven't changed PW lately and never messed with 2 layer pw protection.
    Is your Wi-Fi working OK? Do you have data on your chrome browser?

    Posted via Android Central App
    WiFi working perfect. Data good on Chrome, however, on Google's main page at the bottom it says location cannot be determined. All my location settings are checked. I read on Google's help section to clear cache for Chrome and restart the browser, this usually works for a few hours, then back to location not being used when I search for nearby shops, restaurants, etc.
    How's your mobile data signal? If you have lousy signal, it might be causing problems with the sync.

    You could try completely removing your Google account, then adding it back again.
    Data signal is strong 4G. Interestingly enough, this sync problem only started occurring on 12/25/13, I can't think of anything that I have disabled or changed since then to cause the issue. I'm debating adding and removing my Google account, or syncing everything over to my other added account and mix and match syncs from the both to have a complete phone again, haha.

    Thanks for your replies guys, sorry I haven't been checking up on this regularly lately.
    01-11-2014 09:13 PM
  9. kkhanmd's Avatar
    Under you location is everything checked? GPS, WiFi and mobile networks? Plus does this happen w Wi-Fi turned off?

    Posted via Android Central App
    01-13-2014 09:23 AM
  10. Masheen's Avatar
    Under you location is everything checked? GPS, WiFi and mobile networks? Plus does this happen w Wi-Fi turned off?

    Posted via Android Central App
    Yes, everything is checked under regular location settings and google. WiFi and mobile networks as well. It happens with WiFi on and off.
    01-14-2014 08:26 AM
  11. Masheen's Avatar
    Btw, 4.4 fixed this entire issue. Sorry for the scramble, and thank you for all the help.
    01-15-2014 01:47 PM

Similar Threads

  1. Where to buy unlocked phone? GSMNation Ok?
    By IEatKitKats in forum General Help and How To
    Replies: 9
    Last Post: 08-18-2015, 03:23 AM
  2. Replies: 6
    Last Post: 02-06-2014, 07:51 AM
  3. Replies: 12
    Last Post: 01-12-2014, 11:14 PM
  4. Swype not working right since update.
    By LIncolnpondlover in forum Verizon Galaxy Note 2
    Replies: 0
    Last Post: 01-07-2014, 08:19 PM
  5. Data is being used while using wifi
    By xonq in forum Samsung Galaxy S4
    Replies: 1
    Last Post: 01-07-2014, 06:48 PM
LINK TO POST COPIED TO CLIPBOARD