Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 23 of 23
Like Tree2Likes
  • 1 Post By aapold
  • 1 Post By shamefulzero
  1. Thread Author  Thread Author    #1  

    Default SMS shows date of 1969 and can't be deleted. Seriously?

    so i didn't see a thread on this when i searched but im running rooted gingerbread (.596) and i thought this bug was resolved in froyo already?

    i'm using handcent and i cannot force delete the messages. basically anyone in my privacy box shows up on the main inbox as a blank message dated 1969, and when i delete new messages they just drop to the bottom as 1969. i wiped my phone this morning and reinstalled all my programs and that's when it started.

    this is a bit disconcerting that this problem is still around. does anyone have any idea how to resolve it?
  2. #2  

    Default Re: SMS shows date of 1969 and can't be deleted. Seriously?

    Quote Originally Posted by RemmyZero View Post
    so i didn't see a thread on this when i searched but im running rooted gingerbread (.596) and i thought this bug was resolved in froyo already?

    i'm using handcent and i cannot force delete the messages. basically anyone in my privacy box shows up on the main inbox as a blank message dated 1969, and when i delete new messages they just drop to the bottom as 1969. i wiped my phone this morning and reinstalled all my programs and that's when it started.

    this is a bit disconcerting that this problem is still around. does anyone have any idea how to resolve it?
    I had this problem on Froyo but with Emails... All my emails would show: December 31st, 1969.. When i updated to GB it fixed itself...Maybe .596 still has some Froyo still in it? maybe just the FRO....
  3. Thread Author  Thread Author    #3  

    Default Re: SMS shows date of 1969 and can't be deleted. Seriously?

    just another reason to hate on android i guess. this is truly disappointing.
  4. #4  
    aapold's Avatar

    Posts
    415 Posts
    Global Posts
    728 Global Posts

    Default Re: SMS shows date of 1969 and can't be deleted. Seriously?

    Far out, man
    Jonneh likes this.
  5. #5  
    Penny.For.A.Name's Avatar

    Posts
    21 Posts
    ROM
    JellyBean AOSP

    Default Re: SMS shows date of 1969 and can't be deleted. Seriously?

    Have you tried running a different messaging app?
  6. Thread Author  Thread Author    #6  

    Default Re: SMS shows date of 1969 and can't be deleted. Seriously?

    Quote Originally Posted by Penny.For.A.Name View Post
    Have you tried running a different messaging app?
    well the problem is in my stock inbox as well as handcent and it remains when i delete handcent so it's definitely something android OS related.
  7. #7  
    wabyrd's Avatar

    Posts
    337 Posts
    Global Posts
    438 Global Posts

    Default

    Quote Originally Posted by RemmyZero View Post
    just another reason to hate on android i guess. this is truly disappointing.
    I had the same problem with my Blackberry 9700 once. Had to do a factory reset.
  8. #8  
    shamefulzero's Avatar

    Posts
    259 Posts
    ROM
    ICS

    Default Re: SMS shows date of 1969 and can't be deleted. Seriously?

    i remember those when i had my DX! lol i was smoking a bowl that day in the woods and then i got it! i was also watching lost at that point in my life. lol it was a strange trip. freaked me out for a while. good times
    rohdawgeleven likes this.
  9. #9  

    Default Re: SMS shows date of 1969 and can't be deleted. Seriously?

    I've seen it on an HTC Desire before, and I found that the "sync clock with network" option was off. As soon as I enabled that, it seemed to resync and I was able to delete the 1969 sms messages. Don;t know if this will help out but I figure I'd toss it out.
  10. #10  

    Default Re: SMS shows date of 1969 and can't be deleted. Seriously?

    Quote Originally Posted by SouthernSaltine View Post
    I had this problem on Froyo but with Emails... All my emails would show: December 31st, 1969.. When i updated to GB it fixed itself...Maybe .596 still has some Froyo still in it? maybe just the FRO....
    my husband's droid x, on the ota gingerbread has started doing this in e-mails
  11. #11  

    Default Re: SMS shows date of 1969 and can't be deleted. Seriously?

    Most of you probably aren't interested in why that particular date is coming up, but for those that are, it's because Unix/Linux treats that date as if it were the beginning of time (time zero). I've occasionally received emails with the same date coming from badly configured email servers.
  12. #12  

    Default

    That is actually a bug that occurs in all *nix systems, including Android... for more info on the actual bug, look here: Year 2038 problem - Wikipedia, the free encyclopedia
    tl;dr All unix system dates default to 00:00 AM on January 1st 1970 UTC... but because the US time is a couple of hours before that, it displays as December 31st 1969.
    It sounds like this problem was server side (Verizon's fault) when sending the message to your phone... you can't really do anything about it unless your phone re-downloads the message (if the problem is actually server side)
  13. #13  

    Default Re: SMS shows date of 1969 and can't be deleted. Seriously?

    Quote Originally Posted by trsohmers View Post
    That is actually a bug that occurs in all *nix systems, including Android... for more info on the actual bug, look here: Year 2038 problem - Wikipedia, the free encyclopedia
    tl;dr All unix system dates default to 00:00 AM on January 1st 1970 UTC... but because the US time is a couple of hours before that, it displays as December 31st 1969.
    It sounds like this problem was server side (Verizon's fault) when sending the message to your phone... you can't really do anything about it unless your phone re-downloads the message (if the problem is actually server side)
    Well I've had a problem where the system time showed December 31st and this was what caused my problems; I don't think it was server side. What fixed me was to manually reset the time. After that, everything was normal and I could then sync the time w/ the network (weird, huh?)
  14. Thread Author  Thread Author    #14  

    Default Re: SMS shows date of 1969 and can't be deleted. Seriously?

    well im also have a problem where the phone syncs nonstop and my battery dropped frmo 85 to 50% in a matter of 30 minutes so i have to re-wipe anyway so i just won't restore any of my sms messages to make sure this doesnt happen. my emails have been doing it too though which is also disappointing. i've said it before and i'll say it again, android OS developers simply aren't addressing the issues out there.
  15. #15  
    Jalarm's Avatar

    Posts
    808 Posts
    Global Posts
    810 Global Posts
    ROM
    Stock

    Default Re: SMS shows date of 1969 and can't be deleted. Seriously?

    It sucks that you have that problem, but I find things like that hilarious. Don't know what to do though.
    Devices Past to Present
    • Blackberry Bold 9000
    • HTC Aria
    • Samsung Captivate
    • Google Nexus S
    • Moto Xoom
  16. #16  

    Thumbs down Re: SMS shows date of 1969 and can't be deleted. Seriously?

    I'm using DX and have had this problem with my VM. It shows that I have a VM dated 12/31/1969. Had to do a manual wipe to get the icon to go away. This has happened several times. I've just learned to ignore it.
  17. #17  
    rey_1178's Avatar

    Posts
    16 Posts
    Global Posts
    115 Global Posts

    Default Re: SMS shows date of 1969 and can't be deleted. Seriously?

    i get this problem too on my EVO 4g from sprint. it happens with the emails. i'm running cm7
  18. #18  

    Default Re: SMS shows date of 1969 and can't be deleted. Seriously?

    Oh no another y2k in in 31 years.... I better start preparations for yet another end of the world
  19. #19  
    jdbower's Avatar

    Posts
    750 Posts
    ROM
    CM9,Tablet Mode,Nova

    Default Re: SMS shows date of 1969 and can't be deleted. Seriously?

    Quote Originally Posted by maricopa1963 View Post
    Oh no another y2k in in 31 years.... I better start preparations for yet another end of the world
    Hopefully by then we'll have 64-bit systems (new PCs already have a 64-bit version of Win7 in most cases, just have to finish purging the XP scourge). They're working on 64-bit ARMs as well, but these are just stop-gap solutions that postpone the end of time a little while:
    https://www.ebower.com/time/
    Galaxy Nexus (VZW)
    Motorola Droid X (WiFi)/Motorola Droid 2 Global (VZW)
    Motorola 9505A (Iridium)/HP Zeen (WiFi)
  20. #20  

    Default Re: SMS shows date of 1969 and can't be deleted. Seriously?

    I had this same issue with my text messages. I downloaded SMS Backup and Restore, deleted all of the messages from inside the app, and then all of the stupid undeleteable messages were gone!

    SMS Backup & Restore - Android Stuff

    Hope this helps.
  21. #21  

    Default Re: SMS shows date of 1969 and can't be deleted. Seriously?

    I had this problem. I was using Go SMS. Even on my factory installed text app had the date 12/31/1969 7:00pm. I went to several forums, I tried everything. Then someone said go the the Go SMS app open the "more" tab and select "delete all". It worked and cleared out all my factory installed app "ghosts" as well.
  22. #22  

    Default Re: SMS shows date of 1969 and can't be deleted. Seriously?

    What can i do to fix this? Is it a bug?
  23. #23  

    Default Re: SMS shows date of 1969 and can't be deleted. Seriously?

    this is the correct answer to solve this issue for text messages showing 12/31/1969 after deletion. just go in to the main settings for whatever text app you are using even if its the native app and do a delete all.

    ------

    I had this problem. I was using Go SMS. Even on my factory installed text app had the date 12/31/1969 7:00pm. I went to several forums, I tried everything. Then someone said go the the Go SMS app open the "more" tab and select "delete all". It worked and cleared out all my factory installed app "ghosts" as well.

Posting Permissions