Results 1 to 3 of 3
  1. Thread Author  Thread Author    #1  

    Default Weak Wifi Signal

    long story short. my original dx wifi was fine from day 1. even upgrading from froyo to gb. i could be almost 2 house lengths away from the router and still get a signal. i bricked the phone and was given a replacement which is certified preowned. it came with gb preloaded so i figured maybe it was the radio. ive sbf back to froyo. rooted to gb and even tried the official gb. i literally have to be within 5-8 feet of my router to get a "poor" signal connection. Is there anything else i can try. really dont want to be w/o a phone for 4-5 days again for another pre owned phone.

    p.s ive also changed the router settings as people have mentioned that has worked for them. it hasnt for me.
  2. #2  
    jerseyboy357's Avatar

    Posts
    1,465 Posts
    ROM
    Liquid Smooth JB Beta 2

    Default Re: Weak Wifi Signal

    In those router settings did you do a reset/power cycle to the modem too? Not insulting you by explaining but try this if you haven't already.

    Unplug the power from the wall to both the modem and router. Unplug the router from the modem. Hard reset the modem(stick something in that tiny hole) and hold that reset button in for about 10 seconds. Do the same w the router. Then plug in the power to your modem until its signal is back, then plug in the power for your router and then to the modem and let it all cycle til your signal is back broadcasting as per normal. Then power off your X, battery pull, and then after a min put it back in and power on and see how the signal picks up. Sounds like alot typed out but it really isnt. I had to do that one time and now I can go further and keep the signal.
    Yea, I'm still rockin' a Gnex. The signal strength/quality sucks, but hey, it's not two years old yet.
  3. #3  

    Default Re: Weak Wifi Signal

    Same problem on my X. I will give this fix a try. Thanks.

Posting Permissions

B