Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 9 of 9
  1. Thread Author  Thread Author    #1  
    mhans311's Avatar

    Posts
    478 Posts
    Global Posts
    595 Global Posts
    ROM
    All stock for now.

    Default How do I stop music from autostarting?

    I have searched around the net and it seems this is a problem for a lot of people. Sometimes when I plug in my headphones (doesn't matter which headphones, it does this for all of them) a music app will just start playing wherever it left off. It did this first with Ubermusic, so I uninstalled it. Then it did it with PlayerPro. It has done it with Zimly and Songbird as well. Also sometimes with the stock app. Seems to be whichever player I was using last. This doesn't happen every time, but pretty often. It is very annoying because my media volume is usually set to max because I listen to a lot of podcasts and they are usually pretty soft. Every once in a while the music app will just start out of nowhere while I'm listening to a podcast even after the headphones have been plugged in for a few minutes.

    Anyone else having this problem? Solutions?

    I am running Shuji 2.2, but I have had this issue with Apex and stock as well.

    Oh and I should add I have gone through all music apps and made sure "autostart when headphones plugged in" option is disabled. Still does it.
  2. #2  

    Default Re: How do I stop music from autostarting?

    I have this exact problem on my 2.3.3 DroidX and this is the only thread I could locate on the issue. The behavior seems bug-driven whereas settings seem to be properly configured on my device to prevent auto-start of Android music player when headphones put in. I've discovered the problem when using regular listening headphones and headphones with mic for phone conversations. And while not all calls get disconnected in favor of the Android music player auto-starting, many calls do get lost due to this issue.

    Sometimes the auto-start of the Android music player begins without a known trigger (meaning, in the middle of a conversation when the mic/earbuds have already been in use on the phone). Weird. It just randomly seems to ditch the call and start the player. PowerAmp is my primary music app but its odd that the default Android music player Trumps everything I'm doing randomly. Anyone have a clue as to what's happening and how to fix it?
  3. #3  
    Ricky Babalu's Avatar
    BEACH BUM

    Posts
    2,007 Posts
    ROM
    Stock : Rooted, Unlocked

    Default Re: How do I stop music from autostarting?

    Quote Originally Posted by mhans311 View Post
    I have searched around the net and it seems this is a problem for a lot of people. Sometimes when I plug in my headphones (doesn't matter which headphones, it does this for all of them) a music app will just start playing wherever it left off. It did this first with Ubermusic, so I uninstalled it. Then it did it with PlayerPro. It has done it with Zimly and Songbird as well. Also sometimes with the stock app. Seems to be whichever player I was using last. This doesn't happen every time, but pretty often. It is very annoying because my media volume is usually set to max because I listen to a lot of podcasts and they are usually pretty soft. Every once in a while the music app will just start out of nowhere while I'm listening to a podcast even after the headphones have been plugged in for a few minutes.

    Anyone else having this problem? Solutions?

    I am running Shuji 2.2, but I have had this issue with Apex and stock as well.

    Oh and I should add I have gone through all music apps and made sure "autostart when headphones plugged in" option is disabled. Still does it.
    While I have never had this issue, I would do the following if you have not done so already:

    * Clear the associated players app cache.
    ** Clear the phones cache.
    *** Since it seems like you ROM, try clearing the "Dalvik Cache"

    Hope one of these helps.
  4. #4  

    Default Re: How do I stop music from autostarting?

    I've found a possible app solution to the problem. Apparently, this has affected many more users then I thought. I've been trialing "Headset Blocker" for the past couple hours including making phone calls with the wired headset, using multiple media players, listening to podcasts, TunedIn, audiobooks and I am no longer experiencing the problems that I had before. Work in progress still but good progress thus far. Link here Headset Blocker | AppBrain Android Market
  5. Thread Author  Thread Author    #5  
    mhans311's Avatar

    Posts
    478 Posts
    Global Posts
    595 Global Posts
    ROM
    All stock for now.

    Default Re: How do I stop music from autostarting?

    I always clear my dalvic cache when I flash a new rom. I also tried clearing cache and data from all music apps. Didn't help.

    Thanks for the tip on the app. I downloaded it so I will see how it goes over the next few days. I hope it works.
  6. #6  
    gordol's Avatar

    Posts
    329 Posts
    Global Posts
    809 Global Posts
    ROM
    Stock GB 2.3.4

    Default Re: How do I stop music from autostarting?

    I can't speak for anything else, but PlayerPro has a setting to control this.

    On another note, do you get any background noise/static with wired headsets on the X?
  7. Thread Author  Thread Author    #7  
    mhans311's Avatar

    Posts
    478 Posts
    Global Posts
    595 Global Posts
    ROM
    All stock for now.

    Default Re: How do I stop music from autostarting?

    I have disabled that option in PlayerPro and it still does it. Music apps that don't have that option do it too.

    I tried headset blocker and it doesn't seem to work. Today I was listening to a podcast with Google Listen and when I unplugged the cord PlayerPro started up playing through the external speaker.
  8. #8  
    gordol's Avatar

    Posts
    329 Posts
    Global Posts
    809 Global Posts
    ROM
    Stock GB 2.3.4

    Default Re: How do I stop music from autostarting?

    Quote Originally Posted by mhans311 View Post
    I have disabled that option in PlayerPro and it still does it. Music apps that don't have that option do it too.

    I tried headset blocker and it doesn't seem to work. Today I was listening to a podcast with Google Listen and when I unplugged the cord PlayerPro started up playing through the external speaker.
    If PlayerPro is set to be the default and it's still failing, then something must be gummed up in the cache or preferences. With that setting off, it works properly for me. Using stock Gingerbread 2.3.3, not rooted.
    --
    PDA/Smartphone path: Palm IIIx -> various Sony Clies -> Kyocera 7135 -> Treo 650 -> Treo 680 -> iPhone 3G -> Crapberry Storm2 / iPod Touch -> Droid X -> iPhone 5
  9. Thread Author  Thread Author    #9  
    mhans311's Avatar

    Posts
    478 Posts
    Global Posts
    595 Global Posts
    ROM
    All stock for now.

    Default Re: How do I stop music from autostarting?

    I may just go back to stock GB and see if it helps.

Posting Permissions