1. drewmg's Avatar
    I noticed something this morning - my podcatcher app (DoggCatcher) was not downloading new podcasts because it didn't believe that WiFi was connected. WiFi was connected, but the 3G icon was still there as well. I know the WiFi was connected because I could get to my routers setup webpage... but I did a speed test in another app and it seemed to be using 3G speeds, not WiFi speeds.

    I've seen a similar issue here: Wifi and 3G at the same time?? - Droid Forum - Verizon Droid & the Motorola Droid Forum

    Just curious if this is a bug, or a missed setting somewhere? I was under the distinct impression that it's either WiFi, or 3G... never both.

    I rebooted my phone, and the 3G icon went away, so we'll see if the issue comes back.
    07-29-2010 07:17 AM
  2. Blaksmyth's Avatar
    Thats just the notification bar not refreshing doesnt mean there both on, cool thing if your connected to wifi you can take calls and still be on the net
    07-29-2010 08:31 AM
  3. drewmg's Avatar
    Well it's more than just the notification bar, because I'm fairly certain several of my applications were using the 3G signal, not the WiFi signal, or had trouble knowing that the WiFi was connection. As I said, my podcatcher wasn't updating because it thought I was on 3G.
    07-29-2010 08:33 AM
  4. geekpimpfx's Avatar
    Ive run into the same issue. I was trying to upload videos to YouTube and it kept telling me I needed to be connected to wifi (even though I already was). I noticed in the notification bar that both 3G and wifi were showing, but it still wouldn't upload. I powered the phone off and back on and that seemed to resolve it. I will keep my eyes open to see if it continues to happen.
    07-29-2010 10:03 AM
  5. trogdor3222's Avatar
    I have noticed the same exact thing. Also, whenever this happens, a brief check of Spare Parts confirms that my phone NEVER sleeps (100% "running") and when I check out the "partial wake usage" tab, the culprit is unfortunately "Android system". Has serious impacts on battery life...even though Wi-Fi should technically use less power.
    07-29-2010 10:46 AM
  6. miamifin33's Avatar
    I have the same issue and would love an explanation or fix.
    07-29-2010 10:49 AM
  7. RayStinkle's Avatar
    its definitely a bug. when wifi connects the 3g icon is supposed to disappear and all data should go thru wifi. this is the way all android devices work, so it seems to be some bug with the droid x i guess..
    07-29-2010 01:22 PM
  8. nedqadams's Avatar
    Yeah, have the same issue. I called VZW tech support on the issue and was told that "3G might or might not stay on depending on the signal" which I believe was a pretty big lie. I just don't think they know what they're talking.

    Powering off/on the phone usually fixes it but it has required a batt pull once.
    07-29-2010 01:49 PM
  9. sniffs's Avatar
    From my understanding on CDMA phones, 3G and WIFI use the same radio antenna, so it's not possible to have both at the same time.

    It's either or..
    07-29-2010 03:24 PM
  10. trogdor3222's Avatar
    I'm gunna label this as a bug. I've never heard of any other Android device behaving like this. Let's just hope that it gets resolved in the Froyo update, if not, then we start raising hell.

    Sent from my DROIDX using Tapatalk
    07-29-2010 09:29 PM
  11. powermanaf's Avatar
    I also have this problem. It went away when I first started using my phone, but now it stays on while I'm connected to the WiFi.
    07-29-2010 11:01 PM
  12. condr67's Avatar
    I went into the Verizon store with a WIFI connection problem and the tech changed a setting in mobile connection from "Automatic" to "Home". Seemed to resolve the problem and WIFI started to work properly again. Does not show both at same time anymore.
    schizrade and NewBDroid like this.
    07-30-2010 06:53 AM
  13. myst8ry0_mn_dd's Avatar
    Hi,

    I've noticed since I got my Droid X that when I'm on Wifi the 3g icon remains in the status bar. Normally there's no data usage over the 3g network when I'm on Wifi but today I saw the 3g icon indicating that there was data usage...

    Also, what's strange is that yesterday when I was on Wifi, the 3g icon disappeared for some reason...AND my battery lasted for a whopping 27 hours (and counting)..

    So my questions are..how do I turn off 3g completely when I'm on wifi? And why is my phone using both wifi and 3g today??

    Thanks in advance

    P.S. If it's any help I turned off contacts refresh (4th button from the left) using the power control widget.
    08-03-2010 04:08 PM
  14. typo's Avatar
    I'm having the same problem but it seems its only when my phone is not in use for a period of time i did a factory reset. And now i notice that when my phone connects to wifi the 3G icon goes away faster then it use to before. it use to linger for minutes before going away.
    08-03-2010 04:12 PM
  15. greydarrah's Avatar
    There is a free app called JuiceDefender that if left to it's default settings, will prevent 3G from running if your WiFi connected.
    08-03-2010 04:16 PM
  16. doctorlove316's Avatar
    I merged this with a similar thread.

    Don't forget to search...

    08-03-2010 04:17 PM
  17. g1toevo678's Avatar
    I went into the Verizon store with a WIFI connection problem and the tech changed a setting in mobile connection from "Automatic" to "Home". Seemed to resolve the problem and WIFI started to work properly again. Does not show both at same time anymore.
    Sorry to revive an old thread, but I too am having this issue of both 3G and Wifi staying active when I enable wifi. And it seems the system is still seeing 3G as the active data connection instead of wifi because it wont upload youtube videos with a notification stating "waiting for wifi".

    Has anyone tried the suggestion noted above to see if this fixes the problem?

    And what does changing Mobile Network Setting from "Automatic" to "Home only" do? Does it prevent roaming for data?
    08-17-2010 10:27 AM
  18. schizrade's Avatar
    I cannot even use Wifi. The damn cell connection will not shut off/hand off.
    08-17-2010 10:44 AM
  19. Nub2Droid's Avatar
    I realize this forum is for the Motorola Droid X but I stumbled upon it in researching the same problem for my Samsung Captivate (AT&T's Galaxy S). As others mentioned earlier the phone was connected to my router's wifi and the symbol indicating signal strength appeared in the status bar but the 3g symbol remained on and showed data being used via 3g.

    After reading through this thread I attempted turning the phone off and back on as suggested and it seemed to fix the problem. I just thought it was interesting that I encountered the same issue on the Captivate which means that it might be a bug within the Android system and not necessarily the Droid X.
    08-21-2010 08:13 PM
  20. Bond32's Avatar
    In the little time we have had 2.2, I believe this may have been fixed. I noticed it as well but 2.2 seems to have cleared it up.
    08-21-2010 08:58 PM
  21. leggy's Avatar
    Same problem here and the phone uses the 3G connection and not WiFi. What I do is I turn the phone on plane mode then turn on the WiFi. Sometimes having both on internet access stops working until turning one of them off
    08-22-2010 08:56 PM
  22. Iceman0803's Avatar
    In the little time we have had 2.2, I believe this may have been fixed. I noticed it as well but 2.2 seems to have cleared it up.
    Agreed, Froyo seems to have fixed this for me as well.
    08-23-2010 12:18 AM
  23. digtheberry#AC's Avatar
    So I'm on my second day with My X.. coming over from about 7 years or more on BB's, My last was the storm 2 . so once you set up your wifi for lets say your house... does the phone automatically change to wifi from 3g if your in range and wifi on? I used to have to toggle hotspot browser on the BB.. what a joke that was, if you forgot to toggle on way or the other your browser wouldnt work.
    11-05-2010 08:01 PM
  24. davidnc's Avatar
    Once you have wifi setup and remembered, then yes it should toggle to wifi once you are within range.

    Sent Using TaPaTalk
    11-06-2010 05:47 AM
LINK TO POST COPIED TO CLIPBOARD