1. bugler's Avatar
    So, I have had this phone for a couple of weeks. Normally when I got an email on my gmail, It would be pushed right to my account, i would get a notification. Bam. Now, I have to click the gmail icon, and then click "refresh" then all my new emails will pop up and the ringer and vibrate will go on. What is going on. I am so tired of all the android email problems. I love this phone, but seriously, the email is giving me nothing but problems.
    08-08-2010 01:01 AM
  2. bigboss's Avatar
    Are you sure you have background data enabled and your email setting as PUSH in the data settings?

    Sent from my DROIDX using Tapatalk
    08-08-2010 01:09 AM
  3. doctorlove316's Avatar
    Are you using a task killer or anything like that or shutting down any "running services"?
    08-08-2010 01:12 AM
  4. bugler's Avatar
    Nope. No task killer, and yes, i have background data enabled. Please I need some help, I basically have to keep manually refreshing my email...it's getting insanely frustrating.
    08-08-2010 12:29 PM
  5. ottscay's Avatar
    Is autosync turned on? I know one time I turned mine off accidently and it took me a while to figure out what had happened.

    Sent from my DROIDX using Tapatalk
    08-08-2010 01:41 PM
  6. bugler's Avatar
    Yes. I have data push turned on and data services on while roaming even. I have full 3g right now, and still the email isn't being pushed to my phone. no task killer.
    08-08-2010 05:05 PM
  7. doctorlove316's Avatar
    Have you tried to reset your phone? Have you tried a factory reset?
    08-08-2010 05:19 PM
  8. bugler's Avatar
    I have soft reset it a number of times, and still nothing. I just rooted my phone today to see if that would help at all, nothing.
    08-08-2010 05:30 PM
  9. Incrediboy's Avatar
    How about the setting notify on bar on arrival?

    Sent from my ADR6300 using Tapatalk
    08-08-2010 05:35 PM
  10. bugler's Avatar
    Notify on bar on arrival is on.
    08-08-2010 06:11 PM
  11. ottscay's Avatar
    Yes. I have data push turned on and data services on while roaming even. I have full 3g right now, and still the email isn't being pushed to my phone. no task killer.
    Not push, but rather 1st hard button -> Accounts -> Gmail -> make sure "Sync Gmail" is checked.
    bugler likes this.
    08-08-2010 07:40 PM
  12. bugler's Avatar
    There is no sync check box. all it says is sync calendar, sync contacct sync gmail. When i push sync gmail it syncs...but it dosn't automatically give me my emails. I have to keep pushing "sync gmail" to get new emails.
    08-09-2010 08:46 PM
  13. SBC44's Avatar
    Go to settings > applications > manage applications. Change filter to all apps. In both gmail and gmail storage, clear cache. That worked for me.

    Also, make sure the auto sync isn't turned off on the "power control" widget.
    08-09-2010 08:59 PM
  14. bugler's Avatar
    Go to settings > applications > manage applications. Change filter to all apps. In both gmail and gmail storage, clear cache. That worked for me.

    Also, make sure the auto sync isn't turned off on the "power control" widget.
    You just fixed my gmail. I have never put that Power control widget on the home screen ever. I just added it, and the circle sync was inactive. Now my gmail works. Thank you so much man. I owe you one.
    08-09-2010 11:25 PM
  15. doctorlove316's Avatar
    Thats great to hear! You had me pretty stumped since it seemed like everything was turned on.
    08-09-2010 11:41 PM
  16. acfarrey's Avatar
    Also, make sure the auto sync isn't turned off on the "power control" widget.
    This worked for me as well. I didn't know what the circle meant of the Power Control widget and turned it off. It took me until the next morning to realize that I wasn't getting e-mails so it was difficult to connect the two until I read your post. Thank YOU!
    08-11-2010 09:53 AM
  17. Droidxnh's Avatar
    Where is the power control widget?
    08-20-2010 07:11 AM
  18. TechWhore's Avatar
    Thanks! I did the same thing and just figured it out due to this thread!
    08-24-2010 09:26 AM
  19. JustJerry#AC's Avatar
    Also, make sure the auto sync isn't turned off on the "power control" widget.
    Thanks so much for pointing out something so obvious, but I could not see it.
    08-24-2010 11:29 AM
  20. ParadigmUSA's Avatar
    Thanks so much for pointing out something so obvious, but I could not see it.
    That was my problem too. Really frustrated me that Gmail would not sync, searched all over AC for an answer and this lead me to the issue.
    10-26-2010 08:26 PM
  21. Clemsonpablo's Avatar
    I've been having this problem for a couple days now out of the blue.
    10-27-2010 07:15 AM
LINK TO POST COPIED TO CLIPBOARD