Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 10 of 10
  1. Thread Author  Thread Author    #1  
    pivaska's Avatar

    Posts
    3 Posts
    Global Posts
    4 Global Posts

    Default Droid X, 2.2 and Exchange Server

    I don't see anyone on the forums that have actually connected a Droid X using 2.2 (froyo) to their Enterprise Exchange server. Is there anyone that is using a Droid X (froyo) in a business environment without any problems? We have a 2003 server but we are upgrading it to 2010.
    Thanks in advance
  2. #2  
    quic's Avatar

    Posts
    95 Posts
    Global Posts
    178 Global Posts

    Default

    works fine for me.
  3. #3  
    zep
    zep is offline
    zep's Avatar

    Posts
    8 Posts

    Default

    I had issues when I first got my phone but it is working great now.

    I had to make sure the "Include Inheritable Permissions..." check box was checked within AD for my account.
  4. #4  

    Default

    I downloaded Touchdown from the Market. Works perfectly and adds enhanced features like task synching.
  5. #5  

    Default

    I have to use Touchdown or else Exchange does not work for me. I find it ridiculous that it's necessary to use a 3rd party app in order to have Exchange support, but what do I know...
    Storm 1 ----> Droid X
  6. #6  
    chrisb3's Avatar

    Posts
    111 Posts
    Global Posts
    608 Global Posts

    Default

    Works fine for me. Have several users on both 2.1 & 2.2 (including my X on 2.2) with no issues. We're using Exchange 2007 in the office.

    As long as the ActiveSync for Exchange is on (that's an add-on through a patch in 2003) you should be ok.
  7. #7  

    Default

    I have mailboxes on both exchange 2003 and 2010. Both work great. There were problems with 2003 not showing in the notification bar on 2.1 but that is now fixed.
    Verizon iPHone
    DROIDX
  8. #8  

    Default

    I finally updated to 2.2 this past weekend and our corporate exchange works fine with touchdown and the corporate sync application.
  9. #9  

    Default

    I have both but I don't use touchdown anymore, the UI looks way too like a windows 98 app.
  10. #10  

    Default

    Works fine for me...Exchange 2007. Try unchecking the option that makes you use https....might help with older exchange servers

Posting Permissions