1. EpicInUtah's Avatar
    So I updated to gb and since then my X2 will not connect to by wifi network. Had the exact same problem when I had my X and updated to gb. Anyone know of this issue and a fix for it?

    Sent from my DROID X2 using Tapatalk
    07-31-2011 11:39 AM
  2. tammyflint75's Avatar
    I am having the same issue with my droid X2, wifi was working perfect and now it won't connect. Did you ever find a fix for this issue? If I can not get my wifi to work I will be returning my cell.
    12-04-2011 08:02 PM
  3. EpicInUtah's Avatar
    Never got it working right. I sold the droid x2 and got an iPhone 4 and will never go back to android. The iPhone is so stable and incredibly fast. No more droid for me.
    12-04-2011 08:48 PM
  4. Devinator's Avatar
    I am having the same issue with my droid X2, wifi was working perfect and now it won't connect. Did you ever find a fix for this issue? If I can not get my wifi to work I will be returning my cell.
    Have you tried removing the saved wifi connections and adding them again? Or, connecting to a network you never have before?

    This is really strange. I connect to three different wifi networks, and, have no problems pre and post GB. I just took a look at my phone for anything I could think of other than the above to help, and, came up blank.
    12-13-2011 07:10 AM
  5. TheGiraffe78's Avatar
    As it turns out it is not the phone you have to make changes to. My father-in-law had the same problem and had to update his wifi. The secuirty requirements changed and the phone will not let u change it so u have to modify you wifi router. I will have find out what exactly he had to change it to because I cannot remember off the top of my head.
    12-15-2011 02:25 PM
  6. whossler's Avatar
    I just bought 2 Droids x2 and cannot get either to work on the Internet. Both will hook up to my dlink with WIFI, but my computer network can not find them and I can not get out to the internet. Talked to Motorola twice and no one so far has any idea why. It has bumped up to a higher level and expect a call tomorrow. I evened took out all security from the router and still can not get out or be recognized. I tried to go to My Accounts and it said I needed a MDN number and password. Apparently that has something to do with using s number as my old cell phone?

    I have also been using Network Magic (now Cisco, it hasn't failed me in the past, but sure failing me now.

    Android is at Ver 2.2.4 I see their is a Ver 2.2.3?

    Very frustrating.
    01-15-2012 08:04 PM
  7. Devinator's Avatar
    Both will hook up to my dlink with WIFI, but my computer network can not find them and I can not get out to the internet.
    What do you mean by this? Is your router a D-Link? Or is this some other device.

    Your computer network doesn't need to find your phones, your phone needs to find your network. Are you able to see your network in the Wireless & Network Settings menu?

    Have you tried connecting to another router? If you can connect to someone else's WiFi, then, you can assume there is a problem with your router. If not, then there is an issue with your phone. Might be good to rule that out first.
    01-17-2012 11:56 AM
  8. Ricky Babalu's Avatar
    A few things to try in this order:

    1. Remove the saved wifi accounts and add them again.
    2. If you are on WPA2, change it to WEP and see if you can connect.
    3. Disconnect Power to router for 10 sec.
    4. Change the Router channel to 1 (by default most routers are set to 6).
    5. Reset the Router (there should be a reset button on the back).
    01-17-2012 12:22 PM
  9. ndreher's Avatar
    This may sound really weird but pull your battery cover off and see if it works without the cover on.

    My OG DX was that way and they replaced it with a DX2.
    01-19-2012 08:52 AM
  10. AndieKawaii's Avatar
    I have the same issue. But mine is slightly different. When I got my first Android device it wasn't activated so I connected to my house's wifi. It is secure. I was connected for about a couple weeks, and then I was get little connection, so I pressed "Forget Network" Now, even if I press scan, it will not scan at all and I can't get my wifi back. Does anyone know how to fix this problem?
    02-21-2012 03:51 PM
  11. Devinator's Avatar
    I have the same issue. But mine is slightly different. When I got my first Android device it wasn't activated so I connected to my house's wifi. It is secure. I was connected for about a couple weeks, and then I was get little connection, so I pressed "Forget Network" Now, even if I press scan, it will not scan at all and I can't get my wifi back. Does anyone know how to fix this problem?
    Are you able to connect to your network with any other devices?

    Additionally, have you tried connecting your phone to a different network?
    02-24-2012 07:03 AM
  12. Robert Barber's Avatar
    Change the DHCP setting on your router to something other than forever.
    01-09-2014 08:40 AM
LINK TO POST COPIED TO CLIPBOARD