1. mikey95gt's Avatar
    I cannot seem to get SMS text messaging to work on my Droid X2. When I go into the Google Voice app, I don't have a compose button when I go into the menu. Anyone else get this to work? If so can you help me.
    08-18-2011 10:05 PM
  2. Devinator's Avatar
    Are you hitting the menu button from within a text? What does it say in the blue bar right below your notification bar? When I am within a text message, and, it says Text below the bar, I cannot compose a new text using the menu button. However, if I hit back and it says Inbox, then when I hit the menu button, I get Compose.

    Also, you can set Google Voice to be your default for texting, and, new text messages created will be through Google Voice. You can tell it's working because it'll have the Google Voice icon to the left of Compose in your text message when you go to send one.

    I created Shortcuts to all the people I text and dumped them into a folder for easy texting. You just hold your desktop, select Shortcuts, then Direct Message. Much quicker that way.
    08-19-2011 07:37 AM
  3. mikey95gt's Avatar
    Also, you can set Google Voice to be your default for texting, and, new text messages created will be through Google Voice. You can tell it's working because it'll have the Google Voice icon to the left of Compose in your text message when you go to send one.
    .
    I get all of the same buttons you do. And I can text thru Verizon, but I cannot set my Google Voice to be my default for texting. I cannot get any texts to send or receive thru Google Voice. Also when I go into the Google Voice app, all I every see or have the option to do it play voicemails. Maybe I just don't know how it is suppose to work, but I cannot get it to look like all of the Google Voice help screens for texting.
    08-19-2011 09:17 PM
  4. adaam_93's Avatar
    Be sure to go through all of the settings in the webapp of Google Voice, somewhere deep inside the webapp is a check box to send your text messages to certain devices. That solved a lot of my problems with it.
    08-19-2011 09:42 PM
  5. mikey95gt's Avatar
    I get all of the same buttons you do. And I can text thru Verizon, but I cannot set my Google Voice to be my default for texting. I cannot get any texts to send or receive thru Google Voice. Also when I go into the Google Voice app, all I every see or have the option to do it play voicemails. Maybe I just don't know how it is suppose to work, but I cannot get it to look like all of the Google Voice help screens for texting.
    Nevermind, I figured it out. I set up google voice for voicemail, but never picked out a google number. Works now.
    08-19-2011 09:55 PM
  6. dacp283's Avatar
    Nevermind, I figured it out. I set up google voice for voicemail, but never picked out a google number. Works now.
    and this is why we always advise to read the help sections for the product in question and go step by step before asking others : p just giving you hell glad you got it.
    08-20-2011 02:34 AM
  7. texrands's Avatar
    Wondering if this could be part of my problem...using google voice, drivesafe.ly or text'nspeech and can't seem to get texts to read on motorola bluetooth headset.

    Any Help?
    02-25-2012 06:44 AM
  8. Devinator's Avatar
    Wondering if this could be part of my problem...using google voice, drivesafe.ly or text'nspeech and can't seem to get texts to read on motorola bluetooth headset.

    Any Help?
    I'm not sure what those apps are, but, do they behave properly with default text messaging? Then you can at least rule out it being a Google Voice issue. Test that first.
    02-25-2012 06:17 PM
LINK TO POST COPIED TO CLIPBOARD