1. zachs's Avatar
    I cannot get any attachment to even try to open on the droid from my corporate account. When I click the open button on the attachment it says fetching attachment but never does anything else. i have tried several file types and sizes. None will work. Any ideas? I can get in and out emails to work as well as contacts and calendar with no problems right out of the box. It took about 10 minutes to activate the device and get the exchange account setup.
    11-08-2009 12:55 PM
  2. jdaly's Avatar
    You're not alone. I'm getting the same results here. Anyone have this working?
    11-09-2009 09:13 PM
  3. chuckthepilot's Avatar
    I thought I read somewhere about going into the email, account settings, incoming messages, and looking at the security type. Supposedly changing it from SSL to SSL (Accept all certificates) did something. However I can't find the thread now, and none of that makes any real sense to me. Hopefully you can get it going soon!
    11-09-2009 09:31 PM
  4. sunlifexxx's Avatar
    this is what I had to do, I am running a program called Touchdown. it will open the attachments. with out any problems there is a 5 day free sample. Also I find the email, calendar, contacts and tasks all in one place for my corporate email to be nice. Also it shows the emails in HTML and looks good. Like it better than the default that came with my phone
    11-09-2009 10:45 PM
  5. jdaly's Avatar
    Thanks, you pointed me in the right direction. I already had "Accept all SSL certificates" checked. So I unchecked it and I can now view attachments. Go figure. Works great though.

    I have the 5 day trial of touchdown installed, but for some reason I can only see my Inbox, not all my other folders.
    11-10-2009 10:34 AM
  6. tdawgui's Avatar
    I don't use touchdown... I only use the standard came-with-the-phone app and it works fine

    What type of attachments are you talking about? I can't open documents, but that's cause I haven't gotten Docs2Go yet, but pictures work fine.
    11-10-2009 10:40 AM
  7. Mitch R.'s Avatar
    This may help.

    I can’t download attachments.
    Uncheck “Accept All SSL Certificates” and/or “Use secure connection (SSL)”. You may need to have your IT guys remove the SSL requirement from your phone.
    11-10-2009 11:47 AM
  8. Mike Gulf Breeze's Avatar
    Uncheck Accept All SSL Certificates and/or Use secure connection (SSL). You may need to have your IT guys remove the SSL requirement from your phone.[/QUOTE]

    This works. Just uncheck both boxes. I did it and attachments all open easily.
    11-11-2009 07:13 PM
  9. GammaRay#AC's Avatar
    I have to leave Use secure connection (SSL) checked because SSL is required for our Exchange server but unchecking Accept All SSL Certificates made attachments start working.
    11-14-2009 10:49 AM
LINK TO POST COPIED TO CLIPBOARD