1. alextodd16's Avatar
    Im trying to connect my DROID to my PC (windows vista) - it shows up as 'Removable Disk' - but when i click on it - it says "Please insert a Disk into the Removable Disk". I have - on the phone - pulled down the USB notification and hit the "mount" button - no change. I've shut both the phone and computer down and restarted - no change. I've removed the SD card and re-installed - no change. Im using the supplied motorola usb cable. I dont know what else to try. Any help is much appreciated!
    11-08-2009 03:37 PM
  2. blackmannx#AC's Avatar
    I believe you have to "unmount" the card in order for it to show up.. I would reboot the pc and try it again with the "unmount" command.. I cant test it as Im not near a pc..
    11-08-2009 03:43 PM
  3. Snaz's Avatar
    That's exactly the steps I took and it worked....maybe try a different USB slot?
    kj11 likes this.
    11-08-2009 03:46 PM
  4. alextodd16's Avatar
    Thanks...I did that to...i feel like I tried everything...i've been working on this all day....I was hoping someone else may have the same issue.
    11-08-2009 03:48 PM
  5. Fatasaurus's Avatar
    i am... still working on trying to get it to work...
    11-08-2009 03:52 PM
  6. alextodd16's Avatar
    I tried all the slots to - same thing
    11-08-2009 03:53 PM
  7. Fatasaurus's Avatar
    yep reboot and changed ports and still not working
    11-08-2009 04:00 PM
  8. Snaz's Avatar
    When you pull down the notification screen on your droid....AFTER choosing Mount....does it say Turn off USB storage...under "Ongoing"?
    11-08-2009 04:00 PM
  9. alextodd16's Avatar
    yes - but I cant figure out how to do that or even if im supposed to
    11-08-2009 04:03 PM
  10. Fatasaurus's Avatar
    figured it out! make sure usb debugging is on. its under settings > applications > development
    11-08-2009 04:03 PM
  11. Snaz's Avatar
    yes - but I cant figure out how to do that or even if im supposed to
    you only do that when you want to disconnect. I just wanted to know if your phone acknowledged your choosing mount.
    11-08-2009 04:16 PM
  12. CrackberryMike's Avatar
    figured it out! make sure usb debugging is on. its under settings > applications > development
    Good catch...didnt see that myself.
    11-08-2009 04:36 PM
  13. alextodd16's Avatar
    ok - i did that - and still same thing - it seemed to be working at first asking me to install new drivers - which i did - restarted my computer - and still the same thing. grrrrrrrrrrr
    11-08-2009 04:46 PM
  14. iminent's Avatar
    Hello,

    for me all i have to do is pull down hit ongoing > disk drives > Done

    HTC Incredible
    05-08-2010 10:39 AM
  15. Jeffrey Hubbart's Avatar
    download the drivers for that phone that's why its not seeing it as another drive
    05-08-2013 07:52 AM
LINK TO POST COPIED TO CLIPBOARD