Results 1 to 14 of 14
  1. Thread Author  Thread Author    #1  
    j7469's Avatar

    Posts
    214 Posts
    Global Posts
    758 Global Posts

    Default Pdanet for droid on a mac

    Has anyone had any success using Pdanet with their Droid on a Mac? Specifically using bluetooth. I've tried several times and it appears that it is about to work where a screen pops up showing data usage but that disappears quickly. After that I get nothing. I did a search on the internet suggesting to use the dialup option and 123 for the phone number but that didn't work for me.

    Anyway, if anyone has had success, I'd love to know how you did it.

    Thanks
  2. #2  

    Default

    http://forum.androidcentral.com/htc-...html#post22527

    Not PDA Net, but a free solution that works well for Mac/*nix
    ಠ_ಠ
    제리
  3. #3  

    Default

    Yes, I just setup my droid as a bluetooth DUN using PDAnet. The mac connects to it with no issues and Im online within seconds. I haven't tried the USB method though.
  4. Thread Author  Thread Author    #4  
    j7469's Avatar

    Posts
    214 Posts
    Global Posts
    758 Global Posts

    Default

    Quote Originally Posted by ridavid81 View Post
    Yes, I just setup my droid as a bluetooth DUN using PDAnet. The mac connects to it with no issues and Im online within seconds. I haven't tried the USB method though.
    Great! What specifically did you have to do on your Mac to get it to work?
  5. #5  

    Default

    When I get home let me take a look at my Mac Bluetooth settings and I will post here. Based on what I remember now I setup a new bluetooth device and told the mac I will be using it to access the internet. I will post those settings tonight.
  6. #6  

    Default

    I am curious to know as well. On the mac I am prompted to complete the Mobile Phone Setup is this information detailed somewhere? I have no idea.

    Help is very much appreciated.

    Thanks,
    Tobias
  7. #7  

    Default

    on pdanet websites they now support mac and have instructions to tether usb. I would check this out for now while I get those bluetooth DUN settings:

    PdaNet Desktop for Mac

    --------------------------------------------------------------------------------


    Download PdaNet for Android 2.15 Mac OS destop client.

    The current version supports Mac OS X 10.5 or above (32 bit Leopard/Snow Leopard). Here are the setup instructions:

    1. Download and run the installer on Mac. At the end of the installation you will be asked to reboot your Mac. After rebooting you should see the PdaNet icon on the menu bar. (figure 1)

    2. During installation PdaNet will add an ethernet interface ("en2" in most cases) to your network list. If the network preferences window pops up, just selected "Apply" with the default DHCP settings. If it doesn't, please bring up network perferences manually to make sure it uses DHCP. (figure 2)

    3. Now setup on the phone side. First make sure you have installed PdaNet from Android Market. Launch it and enable USB Tether.

    4. On your phone go to Settings->Applications->Development and check "USB Debugging". (figure 3)

    5. Now when you connect your phone to the computer, you should see the menu icon changes state, click on it to connect.


    Network traffics on the Mac will go through PdaNet only if your system does not have other connectivities.

    If you ever need to uninstall or before you reinstall PdaNet, please run ~/PdaNetUninstall.sh in your home directory and reboot.
  8. #8  

    Default

    Pair the droid with your mac, then open bluetooth preference and select the droid. You must have PDAnet running on the droid when paired so the mac sees that the droid can be used as a modem. So on the mac the droid should be setup as so "DUN - Dial Up NetWorking.

    Then you need to go to Network preference and select the bluetooth DUN. Now you need to enter DEFAULT as the configuration and then enter 123 as the telephone #.

    At this point on your droid within PDAnet click enable bluetooth DUN. Then on your MAC click Connect within the Network preferences for Bluetooth DUN. It should connect at that point.
  9. Thread Author  Thread Author    #9  
    j7469's Avatar

    Posts
    214 Posts
    Global Posts
    758 Global Posts

    Default

    Quote Originally Posted by ridavid81 View Post
    Pair the droid with your mac, then open bluetooth preference and select the droid. You must have PDAnet running on the droid when paired so the mac sees that the droid can be used as a modem. So on the mac the droid should be setup as so "DUN - Dial Up NetWorking.

    Then you need to go to Network preference and select the bluetooth DUN. Now you need to enter DEFAULT as the configuration and then enter 123 as the telephone #.

    At this point on your droid within PDAnet click enable bluetooth DUN. Then on your MAC click Connect within the Network preferences for Bluetooth DUN. It should connect at that point.
    Awesome and thanks!

    **** Well it appears I'm out of luck. I get an error " A bluetooth serial failure has occurred. Failed to open an RFCOMM serial channel. Check if authentication needs to be enabled in your device. It appears that it's going to work then I get this error. I don't know what that means but anyone does please let me know.****

    When I get home tonight I'll give it a try. Thanks again for taking the time to post this. I'll let you know if it works for me.
    Last edited by j7469; 12-22-2009 at 10:14 PM. Reason: Added info
  10. #10  

    Default

    For some reason my macbook only pairs with the droid, but doesn't connect.
  11. Thread Author  Thread Author    #11  
    j7469's Avatar

    Posts
    214 Posts
    Global Posts
    758 Global Posts

    Default

    Quote Originally Posted by ridavid81 View Post
    Pair the droid with your mac, then open bluetooth preference and select the droid. You must have PDAnet running on the droid when paired so the mac sees that the droid can be used as a modem. So on the mac the droid should be setup as so "DUN - Dial Up NetWorking.

    Then you need to go to Network preference and select the bluetooth DUN. Now you need to enter DEFAULT as the configuration and then enter 123 as the telephone #.

    At this point on your droid within PDAnet click enable bluetooth DUN. Then on your MAC click Connect within the Network preferences for Bluetooth DUN. It should connect at that point.
    What do you have for settings under the advance tab in the network preferences for the bluetooth DUN?

    Thanks
  12. #12  

    Default OSX 10.6 w/bluetooth worked...

    Here is what I did... did not see these instructions anywhere else so I will post them here.

    First of all, not sure if everyone has this experience but I find bluetooth with android to be super flaky... things pair, connect, then disconnect... then don't pair so then you just remove and start over. Stupid, anyway.

    The trick for me was that after I had paired the two. I went to the bluetooth preferences in OSX. There is a little gear/settings drop down. I clicked on that and selected 'Edit Serial Ports' ...at this point I think I had to click plus to add which it automatically used my bluetooth name (I think) which was 'Droid' to create a dial up networking port... 'Droid-Dial-upnetworking' I set 'Protocol' to 'Modem' and 'Service' to 'Dial-up networking (DUN)' ... then the super helpful thing was to check 'Show in Network Preferences' and hit apply. Whew!

    After that going into Networking Preferences... all I had to do was turn off my wifi (which is what I was using now not required but wanted to prove it worked)... and then click 'connect' ... it connected and worked!
  13. Thread Author  Thread Author    #13  
    j7469's Avatar

    Posts
    214 Posts
    Global Posts
    758 Global Posts

    Default

    Quote Originally Posted by kurtfm View Post
    Here is what I did... did not see these instructions anywhere else so I will post them here.

    First of all, not sure if everyone has this experience but I find bluetooth with android to be super flaky... things pair, connect, then disconnect... then don't pair so then you just remove and start over. Stupid, anyway.

    The trick for me was that after I had paired the two. I went to the bluetooth preferences in OSX. There is a little gear/settings drop down. I clicked on that and selected 'Edit Serial Ports' ...at this point I think I had to click plus to add which it automatically used my bluetooth name (I think) which was 'Droid' to create a dial up networking port... 'Droid-Dial-upnetworking' I set 'Protocol' to 'Modem' and 'Service' to 'Dial-up networking (DUN)' ... then the super helpful thing was to check 'Show in Network Preferences' and hit apply. Whew!

    After that going into Networking Preferences... all I had to do was turn off my wifi (which is what I was using now not required but wanted to prove it worked)... and then click 'connect' ... it connected and worked!
    Thanks for the input, I'll give it a try when I get home.

    As far as your statement that I put in bold, I couldn't agree more. I have intermittent connections when paired to my Acura. I also noticed that if you go from one paired item to another (for example your car then to a stereo headset) there is usually a long lag if it pairs at all. I sometimes have to shutoff bluetooth on the phone and then turn it back on to get it to work.
  14. #14  

    Post Enable Bluetooth DUN on Macbook to Android

    I tried it again with these steps and it worked, btw.

    I'm assuming that you've already downloaded and installed PDANet on your phone.

    Step 0: Pair computer with phone. Go to Macbook's Bluetooth Setup Assistant and pair the computer to the phone. After pairing, keep bluetooth on both on computer and phone.

    NOTE: If during the setup, you're given the option to "Access the Internet with your phone's data connection," uncheck the box and click Continue.

    Step 1: Open bluetooth preferences on the Mac, select (i.e. highlight your phone), then click on the little gears/setting drop down menu and select Edit Serial Ports.

    Step 2: Click the plus button to add a serial port. In my case, it automatically named the port using my phone's name. For the protocol, select Modem. For service, select Unknown Service. Lastly, check the box for "Show in Network Preferences." Click Apply.

    Step 3: Turn off Airport (or whatever internet connection your computer usually uses). Open the computer's Network Preferences and select the new serial port you created in Step 2. Keep this window open for now.

    Note: When I selected the new serial port, I had options to choose a configuration and then provide a telephone number, account name, and password. I kept the configuration at Default. I entered the telephone number as 123. The account name and password were kept blank.

    Step 4: On your phone, go to PDANet and press Enable Bluetooth DUN. When PDANet requests permission to turn on you phone's bluetooth, click Yes.

    Step 5: Go to the Network Preferences on your computer, which should still be open. Make sure the new serial port is still selected/highlighted on the left menu. Then, click Connect.

    NOTE: When closing Network Preferences on the mac, it may ask you whether or not you want to apply changes. Choose apply.

    For the Geeks:
    -I didn't need to change the vendor, model, or dial mode for the new serial port (located in the Advanced option in Network Preferences).
    -The "Show modem status in menu bar" box in Network Preferences made it quicker to connect to PDANet.
    -If you remove/delete the new serial port from Network Preferences, just click the plus button and you'll see the new serial port listed so you can add it back again.

    Thanks: kurtfm, ridavid81,

    Phone: Droid Incredible Android 2.1
    Computer: MacBook OSX 10.5.8


    Quote Originally Posted by j7469 View Post

    **** Well it appears I'm out of luck. I get an error " A bluetooth serial failure has occurred. Failed to open an RFCOMM serial channel. Check if authentication needs to be enabled in your device. It appears that it's going to work then I get this error. I don't know what that means but anyone does please let me know.****

    When I get home tonight I'll give it a try. Thanks again for taking the time to post this. I'll let you know if it works for me.

Posting Permissions

B