Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 6 of 6
  1. Thread Author  Thread Author    #1  

    Default What do i do to help this problem?

    Well, just today my phone wouldnt charge.. for the past 2-3 months i would always have to plug it in and leave it still or it wouldnt charge, and when i would take out the charger it would automatically restart my phone.. but today i go to charge it and leave it alone but nothing happens.. so i had to switch batteries with my brother ( because we have the same phone..) and i guess we are going to switch batteries often.. what do i do?
  2. #2  
    MrSmith317's Avatar
    Mr Fix-It

    Posts
    2,214 Posts
    ROM
    Stock Rooted

    Default

    If you have tech assurance or phone insurance get the phone replaced. Seems like your only option.
  3. #3  

    Default

    My Droid did the same thing. It has a 1 year manufacturers warranty. I called my carriers customer service and they sent me a new refurb'd one the next day.
    Still working with my DINC2
  4. #4  

    Default

    My MicroUSB port is getting loose. It has a tough time staying connected when I have the phone landscape in my car holder. May need to do an insurance claim before I upgrade my device to get a clean device if it gets any worse.
    Thanks,

    Mark
    Kyo7135 - Treo600 - Treo650 - Treo 700 - BlackBerry 8800 - Blackberry 9000 - Droid - Storm 2 (failed Experiment) - Droid - Droid X - iPhone4S (waiting to come back to Android with HTC One or Samsung Galaxy S4)
  5. #5  
    MowDownJoe's Avatar
    Regular lawnmower man...

    Posts
    439 Posts
    Global Posts
    440 Global Posts
    ROM
    Stock

    Default

    Quote Originally Posted by mdlissner View Post
    My MicroUSB port is getting loose. It has a tough time staying connected when I have the phone landscape in my car holder. May need to do an insurance claim before I upgrade my device to get a clean device if it gets any worse.
    When that started happening to me, I just got a tighter-fitting cable. That did it. Moto's cables seem like crap compared to the ones I've actually paid for.
  6. #6  
    Sploinkin's Avatar

    Posts
    351 Posts
    ROM
    AOKP + Franco's

    Default

    Quote Originally Posted by MowDownJoe View Post
    When that started happening to me, I just got a tighter-fitting cable. That did it. Moto's cables seem like crap compared to the ones I've actually paid for.
    That's the opposite of my experience.

Posting Permissions