Results 1 to 3 of 3
  1. Thread Author  Thread Author    #1  

    Default Need help, MT4G 2.2.1 cannot root using Visionary method

    Hi there,

    I bought a used MT4G, perfectly working condition. I have not put a SIM card in yet, just using WIFI for now. Everything works fine.I can access Market and install apps. The phone was working fine with a working SIM as I tried it before buying it.

    Android version is 2.2.1.
    Baseband: 12.28b.60.140eU_26.03.02.26_M
    Kernel: 2.6.32.21-g899d047 htc-kernel@and18-2#1

    The problem is, I followed the sticky to root this phone, the Visionary method. Everything seemed OK until the last step, I cannot get S-OFF (remained ON) and in Terminal Simulator SU is denied, permission denied.

    Now I have tried various Visionary, v11, v14, still cannot make it root.

    In Visionary, I tried all combinations of "R/W after root" , "Run Visionary.sh after root" checked and not-checked. No difference.

    Please someone share some insights as to what is going on? I am happy with temproot provided by Visionary, but I want to install custom ROMs.

    Maybe there is another way to root it?

    Many thanks to this forum, and look forward to some new ideas,
  2. #2  
    mjneid's Avatar

    Posts
    101 Posts
    ROM
    CyanogenMod N252

    Default Re: Need help, MT4G 2.2.1 cannot root using Visionary method

    Sounds like you have a bad eMMC chipset. Which means you can only root with the ./gfree method.

    with that being said i would highly advise against you rooting as that chip has been known to fail for no reason at all leaving you stranded. And since the device will be s-off HTC and T-Mobile do not have to honor any warranty.
    Samsung Galaxy S3 Verizon | Cyanogen(mod) 10.1
    Asus Transformer TF101 | Cyanogen(mod)
    Nook Color | Cyanogen(mod)
    Logitech Revue
    Past : HTC Glacier / HTC Sapphire / HTC Dream / Blackberry 8100, 8310, 8700, 8900, 9700
  3. #3  

    Default Re: Need help, MT4G 2.2.1 cannot root using Visionary method

    That's it, no more options, I'm also in same position.
    i tryed everything, maybe now have some options to root in this state.

Posting Permissions

B