Results 1 to 20 of 20
Like Tree4Likes
  • 1 Post By badbrad17
  • 3 Post By badbrad17
  1. Thread Author  Thread Author    #1  
    badbrad17's Avatar

    Posts
    3,284 Posts
    ROM
    Stock JB 4.4 Rooted

    Default Problem with USB debugging using Nexus 4 toolkit

    I upgraded to JB 4.2.2 and my root was removed so I went back to using the Nexus 4 toolkit like I had in the past to re-root, but for some reason I am unable to get past the "Waiting for USB debugging" screen. I have debugging turned on but it just can't recognize it. have tried to unplug and replug the usb cable and I have rebooted everything numerous times.

    Anyone have any other options? I'm pretty much a noob with the extent of my rooting skills so any advice would have to be dumbed down a bit ;-)
    Android Evangelist
    HTC Desire + Samsung Galaxy SIIx + Transformer TF101 and Prime + Nexus 4
    Thanked by:
  2. #2  
    2defmouze's Avatar

    Posts
    5,825 Posts
    Global Posts
    5,846 Global Posts
    ROM
    AOKP

    Default Re: Problem with USB debugging using Nexus 4 toolkit

    With 4.2.2 there is a new security check to enable usb debugging. The device should display a security token that you then enter into the computer... Something like that, I'm not positive on how it works as I haven't bothered updating yet, lol.. But I'm sure a quick search of Android Central or Google will find an explanation.

    Sent from my Nexus 4 using Tapatalk 2
  3. #3  

    Default Re: Problem with USB debugging using Nexus 4 toolkit

    Here some info about this new security feature:
  4. Thread Author  Thread Author    #4  
    badbrad17's Avatar

    Posts
    3,284 Posts
    ROM
    Stock JB 4.4 Rooted

    Default Re: Problem with USB debugging using Nexus 4 toolkit

    Thanks guys. That makes sense. I will check this out and try it again today.

    Sent from my Nexus 4 using Android Central Forums
    Android Evangelist
    HTC Desire + Samsung Galaxy SIIx + Transformer TF101 and Prime + Nexus 4
  5. Thread Author  Thread Author    #5  
    badbrad17's Avatar

    Posts
    3,284 Posts
    ROM
    Stock JB 4.4 Rooted

    Default Re: Problem with USB debugging using Nexus 4 toolkit

    Quote Originally Posted by cryofy View Post
    Here some info about this new security feature:
    Okay I read over this and I do remember yesterday that I got the pop up to allow the USB debugging, but I don't think I selected to always allow for this computer. So now I can;t get that to come back up. I even tried on a second computer and I am unable to get this to pop up again. Arggh. This appears to be a problem for a lot of people as I am searching. Any other suggestions?
    Android Evangelist
    HTC Desire + Samsung Galaxy SIIx + Transformer TF101 and Prime + Nexus 4
    Thanked by:
    aeiltz likes this.
  6. Thread Author  Thread Author    #6  
    badbrad17's Avatar

    Posts
    3,284 Posts
    ROM
    Stock JB 4.4 Rooted

    Default Re: Problem with USB debugging using Nexus 4 toolkit

    Okay I finally managed to sort it out.
    There needs to be an update to files in the original Nexus 4 toolkit to activate the USB debugging.

    Originally Posted by mskip on XDA here: (post 993)
    As many people have found out the older versions of my Toolkits (or adb) won't work with the 4.2.2 update. The device shows as offline as will not connect for any adb operations. The older adb server doesn't include the new authentification method needed to connect. Fortunately the fix is as easy as updating 4 files which I have zipped up and uploaded to my server to make everything easy.

    NOTE: The latest Auto Updates for the Toolkits include the new google files so this shouldnt be a problem for anyone who has Auto Updated their Toolkit recently.

    1. Download
    2. Make sure your Toolkit has been closed correctly with the "x" option in the Main Menu or the adb server will still be running
    3. Extract the contents of the zip file above to your Toolkit folder (overwriting the original files)
    4. Double click on fastboot-toolkit.exe and adb-toolkit.exe files (a small command box will appear then disappear)
    5. Run the Toolkit and when you get to the Main Menu a popup will appear on your device asking to allow USB debugging for your pc
    6. Tick 'allways allow from this computer' and click ok to add your pc to the whitelist
    7. Select the 'Refresh Main Menu' option in the Toolkit and your device will now show as 'device' and not 'offline'

    Hope this helps anyone else that had the issue I had.
    Android Evangelist
    HTC Desire + Samsung Galaxy SIIx + Transformer TF101 and Prime + Nexus 4
    Thanked by 18:
    + Show/Hide list of the thanked
    imeem, ze3rax and Mark Zhuk like this.
  7. #7  

    Default Re: Problem with USB debugging using Nexus 4 toolkit

    Thanks a lot for taking the time and looking into this. I've tried to root the device after 4.2.2 update and nada. As if the debugging mode was not recognized by the toolkit.
    After I've downloaded files you posted, everything worked as before.
    Thanks again, and cheers.
  8. Thread Author  Thread Author    #8  
    badbrad17's Avatar

    Posts
    3,284 Posts
    ROM
    Stock JB 4.4 Rooted

    Default Re: Problem with USB debugging using Nexus 4 toolkit

    Quote Originally Posted by matic pipan View Post
    Thanks a lot for taking the time and looking into this. I've tried to root the device after 4.2.2 update and nada. As if the debugging mode was not recognized by the toolkit.
    After I've downloaded files you posted, everything worked as before.
    Thanks again, and cheers.
    Glad to help. I spent a good number of hours on this and almost gave up. There wasn't as much info. available as I would have thought considering how many people were having problems. I did a little happy dance when it finally worked.

    Sent from my Nexus 4 using Android Central Forums
    Android Evangelist
    HTC Desire + Samsung Galaxy SIIx + Transformer TF101 and Prime + Nexus 4
    Thanked by 3:
  9. #9  

    Default Re: Problem with USB debugging using Nexus 4 toolkit

    Quote Originally Posted by badbrad17 View Post
    Glad to help. I spent a good number of hours on this and almost gave up. There wasn't as much info. available as I would have thought considering how many people were having problems. I did a little happy dance when it finally worked.

    Thank you very much for takint the time to explain everythin in detail, you're the best!

    Sent from my Nexus 4 using Android Central Forums
    Thanked by:
  10. #10  

    Default Re: Problem with USB debugging using Nexus 4 toolkit

    Wow, thanks alot for this, It helped me finally get past the "Waiting for USB Debug" message. Thanks for taking the time!
    Thanked by:
  11. #11  

    Default Re: Problem with USB debugging using Nexus 4 toolkit

    thanks for help badbrad17
    Thanked by:
  12. #12  

    Default Re: Problem with USB debugging using Nexus 4 toolkit

    You perfect due, I have fixed my problem Thanks a lot
    Thanked by:
  13. #13  

    Default Re: Problem with USB debugging using Nexus 4 toolkit

    Cheers buddy was doing my head in worked a treat.
    Thanked by:
  14. #14  

    Default Re: Problem with USB debugging using Nexus 4 toolkit

    thanks!!!
    Thanked by:
  15. #15  

    Default Re: Problem with USB debugging using Nexus 4 toolkit

    I have the same problem. I have a nexus 7 tablet and after the update the root is gone and I have tried to root it again but I just can't. I will try this. Thank you so much for your info.
    Thanked by:
  16. #16  

    Default Re: Problem with USB debugging using Nexus 4 toolkit

    thanks it workss
    Thanked by:
  17. #17  

    Default Re: Problem with USB debugging using Nexus 4 toolkit

    Thank you bro...
    for your great help
    Thanked by:
  18. #18  

    Default Re: Problem with USB debugging using Nexus 4 toolkit

    Quote Originally Posted by badbrad17 View Post
    have thought considering how many people were having problems. I did a little happy dance when it finally worked.
    Thanked by:
  19. #19  

    Default Re: Problem with USB debugging using Nexus 4 toolkit

    I can't get it to work.

    I download the update in the toolkit, close the toolkit via "X", copy and paste over new files, run tool kit again, go to backup device but still "waiting on adb"

    Any suggestions? I've tried uninstalling drivers, rebooting. Nothing has worked.

    Hmm now it worked, and I have no idea why. At least the adb mode part did. Ok Thanks!!

    edit:
    Oh dirty. I'm almost positive it had something to do with my laptop entering low power mode and turning off power to the USB port.
    Last edited by chinesewhite; 06-20-2013 at 11:33 PM.
    Thanked by:
  20. #20  

    Default Re: Problem with USB debugging using Nexus 4 toolkit

    Thank you!
    Thanked by:

Similar Threads

  1. problem with internet access using wi-fi
    By hamsteak62 in forum Samsung Galaxy S II Skyrocket
    Replies: 18
    Last Post: 12-03-2012, 08:41 PM
  2. Problem with Google search using UC BROWSER
    By twister98 in forum Android Applications
    Replies: 0
    Last Post: 08-28-2012, 10:56 PM
  3. Problem with USB
    By mike52599 in forum AT&T Galaxy S II
    Replies: 1
    Last Post: 06-27-2012, 09:58 PM
  4. Problem with vlingo on the nexus
    By boe in forum Verizon Galaxy Nexus
    Replies: 0
    Last Post: 04-08-2012, 07:56 AM
  5. Problems with USB Mass Storage
    By FILIPINOY79 in forum Samsung Galaxy S II Skyrocket
    Replies: 4
    Last Post: 01-15-2012, 11:52 PM

Posting Permissions

B