1. Alex Karim's Avatar
    Hey guys,
    I bought a charger on eBay for 10$ and it looks like the nexus 5 official charger except it doesn't contain the magnets. I was super excited to use it right out of the box but I noticed the light changes from red to blue on the charger as well as my phone indicates its charging but my battery does not increase its charge. I tried to restart my phone and find new cables. No luck. Any suggestions ?

    Posted via Android Central App
    07-23-2014 02:11 AM
  2. warn joe's Avatar
    Hey guys,
    I bought a charger on eBay for 10$ and it looks like the nexus 5 official charger except it doesn't contain the magnets. I was super excited to use it right out of the box but I noticed the light changes from red to blue on the charger as well as my phone indicates its charging but my battery does not increase its charge. I tried to restart my phone and find new cables. No luck. Any suggestions ?

    Posted via Android Central App
    Well, i would say in this case we ran out of suggestion i think you may need to contact the Google Nexus support seeking the answer why it doesn't charge. Can't really guide you on this much !
    07-23-2014 02:21 AM
  3. Alex Karim's Avatar
    Somehow it miraculously started working. Thanks for your help

    Posted via Android Central App
    07-23-2014 11:58 AM
  4. LimperGrunt's Avatar
    I've noticed an issue with mine from time to time and I use a tylt. Before charging now I always close out all apps and turn off WiFi if it's at night. Phone uses less power and charges faster
    07-29-2014 10:31 AM
  5. bandityo's Avatar
    Also use a high quality usb cable not the one that came with it...doesnt provide enough current.... use a nice blackberry charger 2 for $5 on ebay and power it with that....will turn it into hyper mode qi charging!
    07-30-2014 08:14 AM

Similar Threads

  1. Extreme Power Saving Mode not working?
    By TJGEsq in forum HTC One M8
    Replies: 5
    Last Post: 10-14-2014, 12:59 PM
  2. like the g3 not love it
    By mikeyachi in forum LG G3
    Replies: 2
    Last Post: 07-24-2014, 02:08 AM
  3. Can not watch YouTube videos with stock browser
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 07-23-2014, 02:37 AM
  4. Chromecast will not connect
    By Grant Haswell in forum Google Chromecast
    Replies: 0
    Last Post: 07-22-2014, 11:30 PM
LINK TO POST COPIED TO CLIPBOARD