Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 9 of 9
  1. Thread Author  Thread Author    #1  

    Default Lost root after flashing Omni-rom!?

    Title says it all, just picked up a nexus 5, rooted, installed twrp, then flashed Omni. I try to go to reboot recovery and reboot device but I get no prompt to fix the root I lost through twrp, and I fixed permissions. Any suggestions?

    Posted via Android Central App
  2. #2  

    Default Re: Lost root after flashing Omni-rom!?

    Have you tired to flash SuperSU in recovery?
  3. #3  
    srkmagnus's Avatar

    Posts
    13,373 Posts
    Global Posts
    13,381 Global Posts
    Carrier
    Stock 4.4 (KitKat)

    Default Re: Lost root after flashing Omni-rom!?

    Yes, you may need to reflash SU or download it from the Play Store. Check the device to make sure SU is installed and everything is running correctly.
  4. #4  

    Default Re: Lost root after flashing Omni-rom!?

    no where do you get
  5. #5  
    srkmagnus's Avatar

    Posts
    13,373 Posts
    Global Posts
    13,381 Global Posts
    Carrier
    Stock 4.4 (KitKat)

    Default Re: Lost root after flashing Omni-rom!?

    Quote Originally Posted by zacsaturday View Post
    no where do you get
    SU is available in the Play Store.

    Sent from my Nexus 5 using AC Forums mobile app
  6. #6  

    Default Re: Lost root after flashing Omni-rom!?

    But why does it happen?
    It occurs each time I flash a new update...
    Is there a way to overcome this?
    Each time I flash a new update, I need to also install the app, let it do its job, and then restart the OS ...
    Not only that, but since I like using the Xposed framework, I need to install it too and restart again...
  7. #7  
    Golfdriver97's Avatar

    Posts
    31,112 Posts
    Global Posts
    31,610 Global Posts
    Carrier
    Pure Nexus/Franco Kernel

    Default Re: Lost root after flashing Omni-rom!?

    You might be able to enable root access in developer options in settings.

    Sent from my HTC One_M8 using AC Forums mobile app
  8. #8  
    srkmagnus's Avatar

    Posts
    13,373 Posts
    Global Posts
    13,381 Global Posts
    Carrier
    Stock 4.4 (KitKat)

    Default Re: Lost root after flashing Omni-rom!?

    Quote Originally Posted by LB LB View Post
    But why does it happen?
    It occurs each time I flash a new update...
    Is there a way to overcome this?
    Each time I flash a new update, I need to also install the app, let it do its job, and then restart the OS ...
    Not only that, but since I like using the Xposed framework, I need to install it too and restart again...
    Are you using Titanium Backup (there are others as well) to backup apps for quick restore? That will save you a great deal of time.


    Sent from my Nexus 5 using AC Forums mobile app
  9. #9  

    Default Re: Lost root after flashing Omni-rom!?

    https://www.dropbox.com/s/chijy5qqwf...SU-v1.99r3.zip

    Keep this in the root of your sdcard and flash it each time you flash a ROM just for good measures

    Posted via Android Central App

Similar Threads

  1. Nexus 4 from custom ROM to official rom
    By kamoteuz in forum Nexus 4 Rooting, ROMs, & Hacks
    Replies: 6
    Last Post: 12-17-2013, 05:33 PM
  2. Custom Rom 4.3 - Getting rid of knox?
    By Robert Youmans in forum Samsung SAFE and KNOX
    Replies: 5
    Last Post: 12-16-2013, 10:10 PM
  3. Nexus 4 crashing after KitKat Update
    By Ravish Agarwal in forum Google Nexus 4
    Replies: 2
    Last Post: 12-16-2013, 06:14 AM
  4. Won't Charge After Upgrade to 4.3
    By kylota in forum T-Mobile Samsung Galaxy S4
    Replies: 0
    Last Post: 12-16-2013, 01:17 AM
  5. s-on htc lte only rom i found to work on teamwin to actually install
    By mrguilty101 in forum HTC EVO 4G LTE Rooting, ROMs, and Hacks
    Replies: 0
    Last Post: 12-15-2013, 09:02 PM

Posting Permissions