1. Jay Panwar's Avatar
    Hello all - I have searched here and other places to see if someone else has similar problems and either I'm the only one, or my search skills are below zero. Either way, apologies if this has been already answered.

    It seems as if my Do Not Disturb doesn't understand what Do Not Disturb actually means. If I either set it manually via the pull down for x hours or have the automatic rule enabled [from 10:00 PM to 8:00 AM] for an Alarm only, after a while, it shuts off. I see the icon come up and for a while I get no audible notifications. However, after some time [it's hard to say how long later], DND shuts off. The icon is gone and audible notifications begin to come through. Within the DND settings, I have no apps listed in the 'Do Not Disturb Access' section either.

    I'm coming from a Note 3 where I used to do the same thing via Tasker. I still have tasker installed to do other things, but have removed the similar profile mentioned above. Tasker is now used exclusively for other unrelated daily settings while leaving home [wifi off] and then office settings [wifi off still, sounds at lower levels].

    Unrooted and only major customization done is Nova Launcher Pro.

    Would appreciate any help/insight in order to get a few more winks at night.

    Thank you in advance,

    JP
    11-19-2015 08:05 AM
  2. Wildo6882's Avatar
    I know this would be extreme, but my guess is there is some app messing with it - so I would recommend booting into safe mode and seeing if it still does it. If it functions properly while in safe mode, then you need to factory reset and put apps back in one at a time until you find the culprit.
    11-19-2015 09:24 AM
  3. Jay Panwar's Avatar
    I know this would be extreme, but my guess is there is some app messing with it - so I would recommend booting into safe mode and seeing if it still does it. If it functions properly while in safe mode, then you need to factory reset and put apps back in one at a time until you find the culprit.
    Yes - I was thinking of going that route but was hoping there was a less time consuming method.
    11-19-2015 09:33 AM
  4. RG129's Avatar
    Same thing happens to me. I keep my phone on silent indefinitely and usually get notified by LED or whenever I check it. I tried to set up 2 rules to where it switches to allow priority calls come through at night (in case of emergency) and then back to alarms only back in the day time. For some reason, the DND turns off for some reason and my phone starts making notification sounds, which I don't like.

    I've gone to keeping DND on indefinitely and switching it manually, and that seems to be working for now. I think it has something to do with the rules.
    11-19-2015 11:56 AM
  5. kwright817's Avatar
    ...For some reason, the DND turns off for some reason and my phone starts making notification sounds, which I don't like...
    I have the opposite issue. My rule is set for Priority Only over night, 10p-7a. DND starts promptly at 10, but never turns of at 7 (or any other time) requiring me to manually turn it off. I am looking at another app as the cause, but for now it is a minor bug that, while annoying, is very manageable.
    11-22-2015 05:13 PM
  6. Trigati's Avatar
    I use an app called "Silence Premium Do Not Disturb" to handle my DND. It's very customizable as far as the rules that can be set, turn it on for a set amount of time if you need, plus allows calls from allowed contacts to always ring through, or if the same person calls multiple times in a couple minutes, etc.

    https://play.google.com/store/apps/d...booze.buzzoff2
    11-22-2015 05:55 PM
  7. fatboy97's Avatar
    I have Nova Launcher Pro, and Tasker working on my 6P... no issues. I'm just wondering if you still have a Tasker task that is messing with your sound. If you really want you could back up all your current settings in Tasker, and then delete all the tasks that have anything to do with sound... maybe even all your tasks. Then check to see if this is still a problem... that might eliminate Tasker as an issue, or it might show that something in Tasker was messed up.
    11-22-2015 07:57 PM
  8. Jay Panwar's Avatar
    Update:

    So far, I have uninstalled only one app - Tasker. Since then, it has been working well and like Fatboy97 said, there might have been some thread messing with it. I plan on leaving Tasker for a few more days and will do a re-install to see what happens next.

    JP
    11-23-2015 06:18 AM
  9. fatboy97's Avatar
    Update:

    So far, I have uninstalled only one app - Tasker. Since then, it has been working well and like Fatboy97 said, there might have been some thread messing with it. I plan on leaving Tasker for a few more days and will do a re-install to see what happens next.

    JP
    Glad my suggestion is working so far... hope this is the one.

    Personally, the only thing I use Tasker for is to make my sounds go silent and put it on mainly Vibrate while I'm at work, and then change it back after I leave work... it's strictly on a time/day of the week basis. Silent Mode: Vibrate at 6am Mon-Fri and then Silent Mode: Off when I leave work at 3pm.
    11-23-2015 08:03 AM
  10. Mohammed Kanchwala's Avatar
    I have the opposite issue. My rule is set for Priority Only over night, 10p-7a. DND starts promptly at 10, but never turns of at 7 (or any other time) requiring me to manually turn it off. I am looking at another app as the cause, but for now it is a minor bug that, while annoying, is very manageable.
    Hi mate did you find out what's the issue? I too have a similar situation.
    11-11-2016 03:58 PM
  11. swohguy4u's Avatar
    It cant be Tasker because I have the same issue and do not have Tasker. To be honest, it should not be up to us to figure out if an app is causing it. I have 100 apps on my phone. There should be requirements for every app in the store so that Google operations are not harmed. It would seem that I get several updates a month for each and every app. Fix problems, dont make us do it for you.
    01-07-2017 09:04 PM
  12. palosanto's Avatar
    I have the same issue (and I don't have tasker). I've scheduled DND from 11pm to 7am to only let alarms in but I still get chimes and LED's all night.
    Any new clues since January ?

    I'll give Silence Premium Do Not Disturb a try.
    05-12-2017 03:21 PM

Similar Threads

  1. Replies: 7
    Last Post: 11-29-2015, 11:16 AM
  2. Replies: 4
    Last Post: 11-20-2015, 03:32 PM
  3. Why data service is not working on my smartphone?
    By AC Question in forum Xiaomi Android Phones
    Replies: 1
    Last Post: 11-19-2015, 09:14 AM
  4. Replies: 1
    Last Post: 11-19-2015, 08:45 AM
  5. How do I switch the H+ symbol off on my Samsung J5?
    By AC Question in forum General Help and How To
    Replies: 1
    Last Post: 11-19-2015, 06:59 AM
LINK TO POST COPIED TO CLIPBOARD