1. mrsmumbles's Avatar
    When I plugged in my OPO after receiving it, I noticed after an hour it hadn't charged at all. I unplugged, plugged into different outlet, nothing. I tried my Nexus 5 charger with it and luckily that worked. But is something wrong with my OPO charger? I'm pretty sure I connected it right. Please post if you've also had any problem with your OPO charger.
    09-04-2014 04:20 AM
  2. DoctorJay's Avatar
    Have you tried the OPO charger with another phone? Or using the OPO cable with another charger base? You could easily find out what's not working. The charger that came with my OPO works fine.
    mrsmumbles likes this.
    09-04-2014 08:51 AM
  3. mrsmumbles's Avatar
    Thanks, I'll try all that today.
    09-04-2014 09:36 AM
  4. booboolala2000's Avatar
    Mine had a difficult time connecting to the charger. But worked great after I made The connection

    Posted via the Android Central App
    mrsmumbles likes this.
    09-04-2014 11:23 AM
  5. mrsmumbles's Avatar
    You're both right, it was user error in my case and it's charging my Nexus 5 at the moment.
    09-04-2014 11:43 AM

Similar Threads

  1. Google Maps issues and questions
    By blackdogAC in forum LG G3
    Replies: 9
    Last Post: 09-10-2014, 08:03 PM
  2. Replies: 2
    Last Post: 09-05-2014, 10:03 AM
  3. lg g3 and my pc usb issues
    By AC Question in forum Ask a Question
    Replies: 3
    Last Post: 09-04-2014, 10:34 AM
  4. galaxy s5 computer connectivity issues
    By texassrocks in forum Samsung Galaxy S5
    Replies: 1
    Last Post: 09-03-2014, 09:23 PM
  5. s4 and s5 chargers.
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 09-03-2014, 05:51 PM
LINK TO POST COPIED TO CLIPBOARD