Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 18 of 18
  1. Thread Author  Thread Author    #1  

    Default SD Card won't mount

    Hi, i had removed my sd card to do make a partition using my PC, and i'm not sure what happened, but after I ejected it, my phone said "Blank SD Card". after completing the partition on my PC (everything seemed to go fine), i put the SD card back in and now my OV won't recognize it. when in the phone, the "mount sd card" in settings is grayed out, but if i remove it, the phone will say "blank SD card" again.

    any help? i made a back up of my sd card on my pc, so if i need to format it, it's not a huge deal.

    thanks in advance for any help.
  2. #2  
    fenrix's Avatar

    Posts
    210 Posts
    ROM
    In Progress

    Default Re: SD Card won't mount

    Did you try rebooting your phone?
    Sometimes but not always if I pull the SD it will not detect it without a reboot
    I tested my other sd cards to confirm.
    - how did you format your sd card?
    I found found my preferrable way to be using the terminal
    simply unmount sd in storage then open terminal
    $ su
    # fdisk -h
    the help should guideyou from there.
    basically you can specify partitions/types then
    write changes and exit.
    remount the sd card in storage.
    this worked for me.
    How wereyou trying to format it?
    What program used; platform used; and partition types?
  3. Thread Author  Thread Author    #3  

    Default Re: SD Card won't mount

    i tried rebooting and also mounting the SD card in recovery. what i did was create an ext4 using minitool partition home wizard.

    so should i try your terminal emulator trick now? FYI i don't have the option to unmount in storage. it just has "Mount" grayed out
  4. #4  
    CuriousNoob's Avatar
    Banned

    Posts
    1,592 Posts
    ROM
    Reflash Miui every2-3days

    Default Re: SD Card won't mount

    You could make sure all your partitions are gone on it. You could also try something like EASEUS Partition manager, meaning to delete all partitions to put it back to default.
  5. Thread Author  Thread Author    #5  

    Default Re: SD Card won't mount

    Quote Originally Posted by fenrix View Post
    Did you try rebooting your phone?
    Sometimes but not always if I pull the SD it will not detect it without a reboot
    I tested my other sd cards to confirm.
    - how did you format your sd card?
    I found found my preferrable way to be using the terminal
    simply unmount sd in storage then open terminal
    $ su
    # fdisk -h
    the help should guideyou from there.
    basically you can specify partitions/types then
    write changes and exit.
    remount the sd card in storage.
    this worked for me.
    How wereyou trying to format it?
    What program used; platform used; and partition types?
    i tried the Terminal route and i really have no idea what to do, so i didn't go any further.
  6. Thread Author  Thread Author    #6  

    Default Re: SD Card won't mount

    update:

    i think we're good. i inserted the SD card back in to the PC and i hadn't set the partition to "Primary". when i inserted it back in the phone, it originally said "format" in the status bar, but it doesn't seem like it's formatting.
  7. #7  
    fenrix's Avatar

    Posts
    210 Posts
    ROM
    In Progress

    Default Re: SD Card won't mount

    What Rom are you using? Does it have support for ext4?
    When you reinsert your SD card it will not need to REformat the sd card or it will format using its formatting settings not ext4
  8. Thread Author  Thread Author    #8  

    Default Re: SD Card won't mount

    i'm using IHO.
  9. Thread Author  Thread Author    #9  

    Default Re: SD Card won't mount

    weird....so since i fixed it (and also moved all of my apps to the ext4 successfully), on reboots, my status bar will still say "Format: USB Debugging Connected", but then disappear after a couple of seconds. otherwise, everything else seems to be working just fine.
  10. #10  
    fenrix's Avatar

    Posts
    210 Posts
    ROM
    In Progress

    Default Re: SD Card won't mount

    hmm, I dunno about that... I keep all my stuff on the phone, there's no need for moving them, the phone has plenty of space unless you have a lot of apps.
    Ya know if you burnt yourself a parted magic cd or usb like I recently have it would make partitioning a lot easier, great GUI with gparted.
    Someone else might know more about the Rom and your issue
  11. Thread Author  Thread Author    #11  

    Default Re: SD Card won't mount

    thanks again. i'm not too concerned because everything seems to be working really well, and the "format" notification only appears for about 2 seconds after a reboot.

    i'll check out gparted for the future though.
  12. #12  
    DizzmalDan420's Avatar

    Posts
    79 Posts
    ROM
    Joyful iOS 2.0

    Default Re: SD Card won't mount

    I find myself in a similar boat as the OP. Within recovery I created an ext partition to install apps2ext via this thread's tutorial: Data2ext CyanogenMOD - UPDATE 26/01/11 - xda-developers

    Something got botched along the way and it didn't end entirely successfully. Decided to just revert the SD card back to original setup and be done with it. I used to EASEUS partition manager to wipe and make the card 1 partition again. Then formatted it within my Windows 7 PC. Put the card back into the phone and it won't mount it. Doesn't read it in recovery mode either. Tried rebooting after putting the card in, inserting it while phone was powered off, and re-formatted a few times just in case. Nothing seems to be working. Have a couple of 2Gb cards laying around that the phone reads just fine. Would love to get my 4Gb back online so I can have enough space for my music too. Any ideas?
  13. #13  
    EarthnFire78's Avatar
    YAY!!! ME :)

    Posts
    964 Posts
    ROM
    Custom ROM & Kernel

    Default Re: SD Card won't mount

    Quote Originally Posted by DizzmalDan420 View Post
    I find myself in a similar boat as the OP. Within recovery I created an ext partition to install apps2ext via this thread's tutorial: Data2ext CyanogenMOD - UPDATE 26/01/11 - xda-developers

    Something got botched along the way and it didn't end entirely successfully. Decided to just revert the SD card back to original setup and be done with it. I used to EASEUS partition manager to wipe and make the card 1 partition again. Then formatted it within my Windows 7 PC. Put the card back into the phone and it won't mount it. Doesn't read it in recovery mode either. Tried rebooting after putting the card in, inserting it while phone was powered off, and re-formatted a few times just in case. Nothing seems to be working. Have a couple of 2Gb cards laying around that the phone reads just fine. Would love to get my 4Gb back online so I can have enough space for my music too. Any ideas?
    The sdcard must be set as Primary Type other wise the phone well not read it, the same goes for the ext partition.
    Thanked by:
  14. #14  
    DizzmalDan420's Avatar

    Posts
    79 Posts
    ROM
    Joyful iOS 2.0

    Default Re: SD Card won't mount

    Oh, man. I hate overlooking something simple. I noticed the OP stated that but I didn't see the option to do it within Windows where I assumed it'd be, so I thought maybe they were using a different OS and perhaps that didn't apply to me. Just found the option in EASUS. Thanks alot.
  15. #15  

    Default Re: SD Card won't mount

    is there any way i can remount my sd card to my phone???????????????
  16. #16  

    Default Re: SD Card won't mount

    I have the same issue as OP, but I have a Mac and no access to EASUS.
  17. #17  
    AndyOpie150's Avatar

    Posts
    1,256 Posts
    ROM
    Bean_Whiz-CM10v2.2.2CX

    Default Re: SD Card won't mount

    Try a utility for Windows called "Boot it" sorry I don't remember the link. Try Googling it. It's designed to fix partitioning and boot problems with flash drive's. Works on Micro SD cads as well.
    They might have a Mac version as well?
    Sent from my LG-VM670 using Android Central Forums
  18. #18  

    Default Re: SD Card won't mount

    Quote Originally Posted by nutmeg07 View Post
    I have the same issue as OP, but I have a Mac and no access to EASUS.
    Do you know how to use the terminal program on your Mac? If so, you might look at the man page for fdisk and see if it shows you how to set the partition(s) on the sdcard as primary partitions. Don't know if that utility program is avaialble on the Mac but almost all the common ones are. So it's worth a try. No msft required.

    There are GUI programs to format disks too but I haven't used my Mac for a couple years so I can't tell you how to navigate to it. Try a Spotlight search for the term 'partitioning'.

Posting Permissions