05-10-2012 03:01 PM
937 ... 1314151617 ...
tools
  1. krowley3's Avatar
    I went about it the same way thewraith420 did his except after I flashed the update.zip, I was in a bootloop. I pulled the battery and it rebooted into stock recovery where I did the factory reset from there. I then rebooted the system and it went right into the Stock OS. Turned the phone off and booted back into stock recovery and reflashed the update.zip and sure enough when I went to reboot, it said Flashing Radio. After that it booted into the Stock OS and I rerooted using Jerry's/jcase's root exploit and reinstalled IHO recovery and latest Backside. At one point yesterday, I put Xionia on and pulled the properties from QPST and sure enough, I have ZV9 now. I had previously had ZV4 in QPST even after flashing Leslie's Radio file. Whole process took maybe 20-25 minutes. Not hard to do at all in my opinion.
    Dannemand likes this.
    04-03-2012 09:42 AM
  2. brotherswing's Avatar
    Alright, you've convinced me. When my little monster goes down for his nap, I'll do it up.




    Sent from the BACKside of Tapatalk
    Dave Begue, mrg666 and Dannemand like this.
    04-03-2012 10:09 AM
  3. JerryScript's Avatar
    i thought mine had it too till i noticed when i was updating my prl that there was a section that said software info and listed zv4 and then zv5 on my freinds newer ov. thats when i started reading a bit in the OS section (they have more experience with radios) i dont remember the specific thread but it said in short if you flash the update.zip first from a custom recovery it'll get you stock unrooted rom + stock recovery. flash again from stock recovery to get the radio update. as for the about phone baseband info..... that hasent worked as long as i've been tinkering around but really havent had a need either since there were no radios to flash anyway. now... we have one but it would be convenient if jerry can get it to display the correct info. i dont know how much help it will be (probably none) but the SW Version in about phone on the new zv9 stock rom seemed to be able to read what version i had... it read zv4 untill i flashed again from stock recovery (same time qpst reported zv9). also the baseband section on it must be set by the rom because it said zv9 even when the SW Version said Zv4
    The reason it has never shown in custom ROMs is because Google by default only supports gsm phones, so the code has to be tweaked by manufacturers/carriers to show cdma. The code uses gsm, but I think I've found where the correct info is now.
    brotherswing and Dannemand like this.
    04-03-2012 10:35 AM
  4. pbailey212's Avatar
    Zv4 still for me. I saw that the optimus s is getting another gb update and possible radio update in the next few days. Must be nice to not be the red headed step child of sprint. Its a hard knock life for optimUS

    Sent from my LG-VM670 using Tapatalk
    04-03-2012 10:51 AM
  5. JerryScript's Avatar
    No, the installer is straight Edify coding, same as we use to install roms all the time, and there is nothing special in it. Besides, if it relied on a specific recovery in the way you are suggesting, we wouldn't have had the bricks as it simply would not have ran.

    For further evidence, Jerry simply replaced the recovery with Bobzhome and it flashes.
    On my phone, I used BobZhome recovery, and the file I mentioned still says ZV4. I will use gpst tomorrow to check and see if it worked or not.
    04-03-2012 11:01 AM
  6. cole2kb's Avatar
    On my phone, I used BobZhome recovery, and the file I mentioned still says ZV4. I will use gpst tomorrow to check and see if it worked or not.
    So, I flashed the update in IHO recovery when it was released and it said it flashed fine. Feel free to yell at me for not reading almost 40 pages to find out what's going on, but will you checking your phone with QPST confirm if the flash actually took for us or not? I really thought I was seeing better reception, being able to use my phone at work a little easier, but I guess it could be coincidental.
    04-03-2012 11:09 AM
  7. thewraith420's Avatar
    So, I flashed the update in IHO recovery when it was released and it said it flashed fine. Feel free to yell at me for not reading almost 40 pages to find out what's going on, but will you checking your phone with QPST confirm if the flash actually took for us or not? I really thought I was seeing better reception, being able to use my phone at work a little easier, but I guess it could be coincidental.
    Yes qpst will confirm it or as it seems jerry discovered a file with the info in it read back a few posts from him

    Sent from my LG-VM670 using Tapatalk
    04-03-2012 01:45 PM
  8. krowley3's Avatar
    Could some of you please check what it says in this file:

    /sys/devices/system/soc/soc0/build_id

    I have flashed LeslieAnn's radio zip file three times today, and it still says VM670ZV4
    (I know, I'm late to the party, I like to make an appearance )

    It's too late tonite for me to set up gpst, and I have a full day tomorrow (been told we are getting up early to clean the house, then I have to work till 9ish, god I hate early morning honey-do lists!!!) but I have time on wed to investigate more.

    If this turns out to be a reliable place to get the baseband info from, I can change the code in IHO based ROMs to show the baseband version under Settings>>About phone. It currently is setup to check for gsm basebands, since cdma isn't officially supported. I'm just not sure if that file is written by the ROM, or it's value is grabbed from the modem. Only those that can double check with gpst will know for sure.

    Note- the file exists on the stock donor phone, and it shows ZV9, so I'm hopeful this could work!

    When viewing this file on my phone it now reads VM670ZV9 and I have verified the same in QPST.
    JerryScript likes this.
    04-03-2012 02:08 PM
  9. JerryScript's Avatar
    When viewing this file on my phone it now reads VM670ZV9 and I have verified the same in QPST.
    Thanks, what ROM are you running when you read that file?
    04-03-2012 02:18 PM
  10. cole2kb's Avatar
    I am running Harmonia 2 and my file still says ZV4 even though I flashed the update.

    Sent from my LG-VM670 using Tapatalk
    JerryScript likes this.
    04-03-2012 02:26 PM
  11. economichitman's Avatar
    I checked that file and mine reads ZV4. I flashed from iho recovery. Running the 3/24 build of mirage iho
    JerryScript likes this.
    04-03-2012 02:27 PM
  12. 00_wrath_00's Avatar
    I also flashed with same recovery. Mines reading zv5. Using stock froyo.(for now lol)

    Sent from my VM670 using Tapatalk
    JerryScript likes this.
    04-03-2012 02:35 PM
  13. thewraith420's Avatar
    Looks like a lot of flashes that didn't really take

    Sent from my LG-VM670 using Tapatalk
    04-03-2012 03:10 PM
  14. krowley3's Avatar
    Thanks, what ROM are you running when you read that file?
    I am running the latest Backside(thanks by the way) that I downloaded yesterday and did a clean install. Currently have IHO Recovery installed but when I read in QPST I had to install Xionia Recovery for QPST to recognize my phone. I went through the same update as thewraith420 and the Radio flashed properly(even says that it is flashing the radio). I also checked in QPST before and it did read zv4 prior and that was after flashing LeslieAnn's flashable zip.
    04-03-2012 03:24 PM
  15. thewraith420's Avatar
    Anyone who still has zv4 or 5 if you still want to update. Do a backup then Flash the whole vm update.zip from a non-Touch recovery and let stock ROM boot. Then shut down, enter recovery manually (should be stock recovery now) and apply the update.zip once more. When you reboot system it will flash the radio update. From here you'll need to follow JerryScript and jcase's instructions to reroot. Once that's done you should have no trouble restoring your backup and will be on the latest zv9 radio.

    Sent from my LG-VM670 using Tapatalk
    krowley3 and JerryScript like this.
    04-03-2012 03:32 PM
  16. kirurus's Avatar
    Anyone who still has zv4 or 5 if you still want to update. Do a backup then Flash the whole vm update.zip from a non-Touch recovery and let stock ROM boot. Then shut down, enter recovery manually (should be stock recovery now) and apply the update.zip once more. When you reboot system it will flash the radio update. From here you'll need to follow JerryScript and jcase's instructions to reroot. Once that's done you should have no trouble restoring your backup and will be on the latest zv9 radio.

    Sent from my LG-VM670 using Tapatalk
    You mean the update from the VM website correct?
    04-03-2012 03:43 PM
  17. anthonycr's Avatar
    Well... I suppose I'll wait for people who have actually gotten it to flash to say whether they see much of a difference.

    Sent from my VM670 using Tapatalk
    04-03-2012 04:05 PM
  18. thewraith420's Avatar
    You mean the update from the VM website correct?
    Yes

    Sent from my LG-VM670 using Tapatalk
    kirurus likes this.
    04-03-2012 04:16 PM
  19. 00_wrath_00's Avatar
    Question... why flash the whole update zip and reroot? Why not download the zip, delete recovery folder and the check pre_req file and rezip? Then use the zip in jerrys thread to get su? I did that and worked fine being already rooted. And still had IHO recovery after. May have been a lucky break but it worked. Beats using adb. Any thoughts or constructive criticism is welcomed

    Sent from my VM670 using Tapatalk
    04-03-2012 05:05 PM
  20. thewraith420's Avatar
    Question... why flash the whole update zip and reroot? Why not download the zip, delete recovery folder and the check pre_req file and rezip? Then use the zip in jerrys thread to get su? I did that and worked fine being already rooted. And still had IHO recovery after. May have been a lucky break but it worked. Beats using adb. Any thoughts or constructive criticism is welcomed

    Sent from my VM670 using Tapatalk
    Because iho recovery isn't flashing the radio. Before I got the radio to stick I tried flashing the update.zip and then while still in IHO recovery tflashing jcase's rootme.Zip it worked as far as returning me to stock rooted and left my recovery intact but the radio wasn't updated either

    Sent from my LG-VM670 using Tapatalk
    00_wrath_00 likes this.
    04-03-2012 05:34 PM
  21. 00_wrath_00's Avatar
    Because iho recovery isn't flashing the radio. Before I got the radio to stick I tried flashing the update.zip and then while still in IHO recovery tflashing jcase's rootme.Zip it worked as far as returning me to stock rooted and left my recovery intact but the radio wasn't updated either

    Sent from my LG-VM670 using Tapatalk
    It was just a thought

    Sent from my VM670 using Tapatalk 2 Beta-5
    04-03-2012 05:35 PM
  22. thewraith420's Avatar
    It was just a thought

    Sent from my VM670 using Tapatalk 2 Beta-5
    It would've been nice if it did work that way :-) really tho I had a harder time setting up adb then following the reroot procedure

    Sent from my LG-VM670 using Tapatalk
    04-03-2012 05:44 PM
  23. 00_wrath_00's Avatar
    It would've been nice if it did work that way :-) really tho I had a harder time setting up adb then following the reroot procedure

    Sent from my LG-VM670 using Tapatalk
    I had no problems but my OV isn't the first optimus i rooted lol. But since the recovery folder and deleting the check preqeq and keeping radio in, wouldn't I it be like flashing a regular from zip?

    Sent from my VM670 using Tapatalk 2 Beta-5
    04-03-2012 05:51 PM
  24. thewraith420's Avatar
    I had no problems but my OV isn't the first optimus i rooted lol. But since the recovery folder and deleting the check preqeq and keeping radio in, wouldn't I it be like flashing a regular from zip?

    Sent from my VM670 using Tapatalk 2 Beta-5
    Yes it would but at least for now our custom recoveries just don't want to flash the radio correctly. I'd like to hear from one of the devs their thoughts on renaming leslies patch to update.zip and trying to apply it from stock recovery.

    Sent from my LG-VM670 using Tapatalk
    00_wrath_00 and Dannemand like this.
    04-03-2012 06:02 PM
  25. cole2kb's Avatar
    ADB has never worked right for me. I might try again tomorrow though just for kicks, no reason not to, really.
    04-03-2012 10:29 PM
937 ... 1314151617 ...
LINK TO POST COPIED TO CLIPBOARD