Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 9 of 9
  1. Thread Author  Thread Author    #1  

    Default sd-ext not mounting

    My sd-ext partition doesn't seem to be getting detected anymore. All the apps show up in the list of apps in settings but nothing shows up in the drawer and the shortcuts on the main screen tell me they're not installed. The main partition is fine. This is after I dropped my phone and the battery popped out so it didn't shut down properly and it was like this when I turned it back on. I've tried remounting and taking it out and putting it back in again and it still doesn't mount. Is there a way to get that partition back? I'm running Quattrimus ICS CM9
  2. #2  

    Default Re: sd-ext not mounting

    Have you tried clearing cache/dalvik cache? I think that your sd-ext will be rewritten once your dalvik is cleared.
  3. #3  
    clodfelterac's Avatar
    Samurai Dev

    Posts
    736 Posts
    ROM
    IllusionB / OM

    Default Re: sd-ext not mounting

    probably not the quick fix youre looking for, but
    -copy sd to pc
    -repartition sd in recovery
    -copy sd(copy) to sd(fresh)
    -full wipe
    -flash rom/gapps
    :-)
  4. Thread Author  Thread Author    #4  

    Default Re: sd-ext not mounting

    Yeah I was kind of hoping for a solution that didn't involve me having to reinstall/recover everything or reflashing anything.
  5. #5  

    Default Re: sd-ext not mounting

    I am having kind off the same issue, but my sd card just wont mount at all for anything. I have tried 3 different sd cards.

    I have also tried formating the sd cards no the pc and clearing all the date (doing it on the pc bc my phone wont my mount the sd card to doi it in there)
  6. Thread Author  Thread Author    #6  

    Default Re: sd-ext not mounting

    So I tried clearing only the sd-ext partition (using MiniTool Partition Wizard) and reformatting and reflashed and I don't think I did it properly since space seems to be running out quicker when I ran titanium backup and some apps won't install and they won't even update and when I try to get from the app store it keeps telling me that packages are invalid. So I guess I'll try reformatting in recovery. I should be able to get away with only reformatting the sd-ext partition right and leaving the main one alone?
  7. #7  
    clodfelterac's Avatar
    Samurai Dev

    Posts
    736 Posts
    ROM
    IllusionB / OM

    Default Re: sd-ext not mounting

    i always partition via recovery... 1g/0swap... ive used sandisk, but run a pny in my daily... repartitioning/full wipe/reflash has always solved the problem for me, granted ive only ran into the errors once or twice... :-)
    Last edited by clodfelterac; 10-06-2012 at 02:37 PM.
  8. #8  

    Default Re: sd-ext not mounting

    Depends on how the rom is written an what you made your partition
    I notice some will work with ext4
    Others need ext2 or fat32
    And I always use windows disk management or mini partition tool

    Sent from my VM670 using Android Central Forums
  9. Thread Author  Thread Author    #9  

    Default Re: sd-ext not mounting

    Well this happened again. Didn't even drop it this time. Started Endomondo, put it in my bag, took it out like 10 minutes later and yeah. Could this be a problem with the ROM and whatever script it uses to move the apps to the sd-ext partition? Should I ask on the thread for it?

Posting Permissions