I got my son a Visual Land Prestige Pro 7d tablet for Christmas. I love it. I recently got an 8gb sd card and put movies on it. Some were .avi files and others were .mp4 files. The ones I put on the internal storage work great. When I first mounted the sd card I noticed that some of the apps stored in the internal sd quit working. Restarted it, everything was fine. (any idea why that is?) Put movies on the sd card and noticed some I could fast forward and others I couldn't. Shortly after I realized those that wouldn't allow me to fast forward would only play 10 min of the movie then a msg would pop up "Unable to play Video". After playing with it for a while i re-converted some movies, wiped the sd card, mounted it, restarted the tablet (due to the apps stored on internal sd not reading), then added the movies. Viola! Everything worked great. All movies worked. I could fast forward. At the end of the day my son comes to me because his movie quit playing after 10 min. I messed with it for a bit and realized I was back at square 1. All videos quit playing the exact spot they did before. Any suggestions please. I've tried other video players and nothing works. Any feedback is appreciated.