Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 2 of 2
  1. Thread Author  Thread Author    #1  

    Default adspec tablet and Google play

    Please can someone help me I have purchased an adspec android tablet everything seems to be working on it apart from Google play it will not download apps keep getting 403 error message tried everything I can find online to fix but still not working please help me

    Posted via Android Central App
  2. #2  


    Looks like you are not the only one having this problem: http://www.androidcentral.com/gettin...oure-not-alone

Similar Threads

  1. Google services eating battery
    By cacciucco in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 3
    Last Post: 03-04-2014, 11:55 AM
  2. Not listed under google play music devices list
    By dzigner in forum Samsung Galaxy Note 10.1 (2014)
    Replies: 5
    Last Post: 02-12-2014, 09:34 PM
  3. Google services force closing.
    By dhawk1202 in forum Motorola Droid MAXX
    Replies: 3
    Last Post: 02-11-2014, 08:29 PM
  4. Play Store Error 403. Brand new Xperia Z Tablet.
    By Chris Lauder in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 11
    Last Post: 02-11-2014, 06:28 PM
  5. Turning off Currents and Google +
    By Lesgreen in forum Google Nexus 7 Tablet (2012)
    Replies: 2
    Last Post: 02-11-2014, 04:21 PM

Posting Permissions