1. Dreamliner330's Avatar
    I got my Atrix HD setup on Straight Talk using the Straight Talk provided APN settings. Internet speed was great showing ~5mbps in SpeetTest.

    I was having trouble sending MMS and I called Straight Talk. They took their time 'checking' my account and had me read through the APN settings. I mis-typed a word and MMS was fixed after correcting it.

    After I finished the phone call with Straight Talk, I noticed soon after my data speeds took a DUMP! I can't get the SpeedTest app to work, I cant send pictures in gmail & Facebook barely works. Google Navigation quit on me too!

    Web browsing however, works fine while the apps are not, sometimes its really slow.

    I called Straight Talk again and asked if they changed anything and they said no. I asked if they block applications and they said no. They did say I was only guaranteed 'web browsing' and suggested the mobile websites instead of the app...


    ...Thoughts?
    09-01-2012 10:33 PM
  2. cgardnervt's Avatar
    I think you can add another APN. I would start over and just re-add it.
    09-02-2012 09:19 AM
  3. Dreamliner330's Avatar
    I've deleted and re-added the apn multiple times. I've tried setting the PROXY setting as "proxy.mvno.tracfone.com" & "66.209.11.33" & leaving it blank. I've restarted countless times and the result is either as described above or zero data at all.

    Any specific suggestions. I did some searching on this issue and it actually seems like a relativly common thing with Straight Talk. Had I known, I would have never gone this route. Now I'm sure to lose money reselling this stuff.
    09-02-2012 12:56 PM
LINK TO POST COPIED TO CLIPBOARD