Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 5 of 5
  1. Thread Author  Thread Author    #1  

    Default google play not working

    My google play application is saying that it can't establish a reliable connection to the server. I have already tried to change the date, clear data, factory reset, etc. But its still not working. Does anyone know what the problem is? any ideas to help solve the issue?
  2. #2  

    Default Re: google play not working

    Odin the stock firmware

    Sent from my Nexus 5 using Tapatalk
  3. Thread Author  Thread Author    #3  

    Default Re: google play not working

    how do you do that?
  4. #4  

    Default Re: google play not working

    Quote Originally Posted by vance123455676 View Post
    My google play application is saying that it can't establish a reliable connection to the server. I have already tried to change the date, clear data, factory reset, etc. But its still not working. Does anyone know what the problem is? any ideas to help solve the issue?

    I had the same problem. Seems some app changed the time/date on my S-3. Went into settings, set the correct time/date, problem solved.

  5. #5  

    Default

    I have the same issue too but my date and time are correct, is there anyway to fix this?

    Posted via Android Central App

Similar Threads

  1. Replies: 2
    Last Post: 10-30-2014, 01:46 PM
  2. Replies: 80
    Last Post: 09-02-2014, 01:30 AM
  3. Stock Email app widget is not available
    By Michael Carson1 in forum Android 4.4 KitKat
    Replies: 1
    Last Post: 07-04-2014, 08:17 PM
  4. Moto G: Motorola Camera vs. Google Camera
    By Ry in forum Moto G (2013)
    Replies: 7
    Last Post: 05-04-2014, 06:17 PM
  5. 2 Issues: Notification light isnt working & Ongoing wont leave notifications
    By lazygregg in forum Verizon Samsung Galaxy Note 3
    Replies: 0
    Last Post: 04-16-2014, 03:42 PM

Posting Permissions