1. geopatr's Avatar
    Hey guys. I have received the international GT-N7100 Note II in the mail and I love it. All works great but I cant get data to work on the Telus network in Canada. It works fine over wi-fi but once that isn't available I have no data connection. Calling and messaging works fine. Are there any settings I need to change for it to work?
    Thanks in advance for any help.
    Cheers,
    George
    10-22-2012 12:05 AM
  2. badbrad17's Avatar
    Have you brought it in to a Telus store to see what they say?

    Sent from my SGH-T989D using Android Central Forums
    10-22-2012 01:09 AM
  3. geopatr's Avatar
    Have you brought it in to a Telus store to see what they say?

    Sent from my SGH-T989D using Android Central Forums
    No I have not. It just arrived. Everything works great except for data. I will call Telus and see what they say. I was hoping someone else had the same problem and figured it out.
    badbrad17 likes this.
    10-22-2012 01:46 AM
  4. katrose08's Avatar
    I have the exact same problem! Let me know what Telus says, I'm worried they're just going to say it won't work because its the international version.
    10-22-2012 04:38 PM
  5. badbrad17's Avatar
    I have the exact same problem! Let me know what Telus says, I'm worried they're just going to say it won't work because its the international version.
    I think Telus supports it. They want your money on data so they will let you know if it will work.

    Sent from my SGH-T989D using Android Central Forums
    10-22-2012 04:48 PM
  6. geopatr's Avatar
    I have the exact same problem! Let me know what Telus says, I'm worried they're just going to say it won't work because its the international version.
    For anyone with a similar issue, the fix involves creating or updating the telus APN.

    I was able to get mine to work by creating a new APN with the APN address "sp.telus.com" and leave everything default.
    That did the trick. Works like a charm. This fix came from ck_45 on XDA developers forum. Very simple and easy fix.
    10-22-2012 08:09 PM
  7. badbrad17's Avatar
    For anyone with a similar issue, the fix involves creating or updating the telus APN.

    I was able to get mine to work by creating a new APN with the APN address "sp.telus.com" and leave everything default.
    That did the trick. Works like a charm. This fix came from ck_45 on XDA developers forum. Very simple and easy fix.
    Those smart guys at XDA even help us Canadians.

    Sent from my SGH-T989D using Android Central Forums
    10-22-2012 08:46 PM

Similar Threads

  1. Any Info on Best Buy Carrying the Galaxy Note II?
    By popologuy in forum Sprint Galaxy Note 2
    Replies: 59
    Last Post: 11-02-2012, 07:21 PM
  2. Google Now on Note II
    By damo in forum Samsung Galaxy Note 2
    Replies: 1
    Last Post: 10-02-2012, 07:06 AM
  3. Samsung Galaxy Note II goes on sale in South Korea
    By rajsmbhansali in forum Samsung Galaxy Note 2
    Replies: 0
    Last Post: 09-26-2012, 05:55 AM
  4. Samsung Galaxy Note II hits UK on October 1st
    By maxburn in forum Samsung Galaxy Note 2
    Replies: 0
    Last Post: 09-25-2012, 09:00 AM
  5. Unlocked International Note won't turn on after freeze!
    By pnwAl in forum Samsung Galaxy Note
    Replies: 1
    Last Post: 07-31-2012, 12:15 AM
LINK TO POST COPIED TO CLIPBOARD