1. oenvoyage's Avatar
    Hello,
    My wife and I had this problem on the note 2 when sending SMS with chinese characters, all recievers got them scrambled with question marks ?????? ???? ???
    It took me a little time to understand the error message and fix it so I thought it would be fair to share it here :

    To solve it you need to go to messaging application-> Settings Menu -> Text Message (SMS) settings tab -> Input Mode
    set it to Automatic (it was set to GSM alphabet for me) ...

    voila its fixed!
    I dont know why its not automatic by default.

    Hope it can help someone.
    Maybe the same problem can happen with non-latin scripts like russian, arabic etc...
    krestik21 likes this.
    11-21-2012 12:48 AM
  2. siew cheechung's Avatar
    Thanks for your sharing. It's workable.
    12-15-2012 07:41 AM
  3. khuang81's Avatar
    Thanks OP, this solved my problem
    12-15-2012 09:40 PM
  4. npxmnpxm's Avatar
    Hi:

    I have the same problem. Do you mean there's a settings menu within the messaging application? How do I access it? I've found the messaging app icon but when I press it, it simply opens the app. When I press and hold, it slides over to my home screen.

    Thanks!

    Nick


    Hello,
    My wife and I had this problem on the note 2 when sending SMS with chinese characters, all recievers got them scrambled with question marks ?????? ???? ???
    It took me a little time to understand the error message and fix it so I thought it would be fair to share it here :

    To solve it you need to go to messaging application-> Settings Menu -> Text Message (SMS) settings tab -> Input Mode
    set it to Automatic (it was set to GSM alphabet for me) ...

    voila its fixed!
    I dont know why its not automatic by default.

    Hope it can help someone.
    Maybe the same problem can happen with non-latin scripts like russian, arabic etc...
    01-06-2013 02:56 AM
  5. Phung Van Nguyen's Avatar
    I have the same problem with Vietnamese fonts? I can type it but when the message sent it turns to ???
    What do you mean: message application and setting menu? please help us to fix the problems
    05-25-2014 12:02 AM
  6. Phung Van Nguyen's Avatar
    Can you help us how to fix the problem, I do not know where to go to messaging application???? and setting menu
    05-25-2014 12:05 AM
  7. krestik21's Avatar
    Can you help us how to fix the problem, I do not know where to go to messaging application???? and setting menu

    open ur message app. The app u go to to send regular SMS and u will see all of ur recipients ( what I mean is not just a specific person but all of ur messages) and then click the menu button. I have a note 3 and will tell u where to go on my phone. But all androids have similar menus and options. My menu button is on the left. Then u go to the settings. From the list of options it gives u. And once ur in the settings on my phone it's the tabs on top I have 3 I think. The one in the middle says sms/mms there
    Click on it and it will say input mode. There u select automatic vs whatever it's set to. Who ever has issues like this with the corrupted sms in different languages try it. So did the trick for me. I suffered 1 year until I came across this post biggest thank u of all times to the guy who wrote this trick. ( I really hope I don't sound stupid or make anyone sound stupid. Just tried to explain as much so u can fix it. Good luck!
    08-29-2014 12:44 AM

Similar Threads

  1. Galaxy S3 International Version Question
    By romieorock in forum Samsung Galaxy S3
    Replies: 2
    Last Post: 05-18-2012, 11:49 AM
  2. Getting a Galaxy Note in the States in November. How?
    By scribe4food in forum Sprint Galaxy S II Epic 4G Touch
    Replies: 3
    Last Post: 09-14-2011, 04:02 PM
  3. Replies: 3
    Last Post: 09-14-2011, 09:44 AM
  4. Replies: 4
    Last Post: 01-15-2011, 02:26 PM
  5. Replies: 4
    Last Post: 12-31-2010, 09:12 AM
LINK TO POST COPIED TO CLIPBOARD