1. terpdog's Avatar
    I was wondering if anyone else has noticed this "problem". I'm used to all my other phones setup so that when the headphone jack is plugged in all sound goes there.

    I was sitting in the office and noticed that the notification seemed loud and when I took off my headphones noticed that was because the notification came through the speakers.

    Yes my headphones were plugged in all the way.

    Thanks for any information about this.
    12-05-2012 05:21 PM
  2. miss aloha's Avatar
    Yes I experience that also worth my hands free device and want to know where the setting is to stop it.

    Sent from my SAMSUNG-SGH-I317 using Tapatalk 2
    terpdog and Sapna Aswal like this.
    12-05-2012 06:02 PM
  3. cyanogen-man's Avatar
    I don't think so??



    Sent from my HTC One X+ using Android Central Forums
    12-05-2012 06:04 PM
  4. terpdog's Avatar
    I don't think so??



    Sent from my HTC One X+ using Android Central Forums
    Do you know cyanogen-man??
    12-05-2012 07:39 PM
  5. terpdog's Avatar
    Do you know cyanogen-man??
    It was kinda annoying when sitting in the library listening to some music and not realizing that everyone around you also hears the damn whistle notification and you are the ***** that didn't turn down the sound, when I had my headphones on and didn't even realize it! :-)
    plakius and Megaframe like this.
    12-05-2012 07:41 PM
  6. karsdroid's Avatar
    I noticed this as well....its annoying, but you can go into settings and turn off the sound for notifications in the sound section...
    12-05-2012 08:15 PM
  7. terpdog's Avatar
    you can but it is unexpected behavior to me. usually when you have headphones or blue tooth all sound goes to that device by default. This is the first Samsung that I've had so they must just be different than everyone else!
    12-05-2012 08:33 PM
  8. pauldroidr2d2's Avatar
    I was wondering if anyone else has noticed this "problem". I'm used to all my other phones setup so that when the headphone jack is plugged in all sound goes there.

    I was sitting in the office and noticed that the notification seemed loud and when I took off my headphones noticed that was because the notification came through the speakers.

    Yes my headphones were plugged in all the way.

    Thanks for any information about this.
    That happens to me too. It happens on my S3 and Nexus too.

    Sent from my Galaxy Note 2.
    kittu2496 likes this.
    12-05-2012 09:06 PM
  9. crosshair's Avatar
    Press and hold the power\lock button to mute everything except the media sound after plugging in your headset. All of the sound settings will return to your previous settings when you unplug your headset.

    This appears to be an Android bug and others are also using "SoundAbout" from the play store to work around this issue of automatically muting the external speaker when you plug in your headset.

    Issue 16667 - android - Notifications are played through external speaker when headphones are plugged in - Android - An Open Handset Alliance Project - Google Project Hosting
    Attached Thumbnails Headphones in and Notification Sound still coming through speakers-screenshot_2012-12-05-20-40-40-copy.png  
    12-05-2012 09:16 PM
  10. pauldroidr2d2's Avatar
    Press and hold the power\lock button to mute everything except the media sound after plugging in your headset. All of the sound settings will return to your previous settings when you unplug your headset.

    This appears to be an Android bug and others are also using "SoundAbout" from the play store to work around this issue of automatically muting the external speaker when you plug in your headset.

    Issue 16667 - android - Notifications are played through external speaker when headphones are plugged in - Android - An Open Handset Alliance Project - Google Project Hosting
    I wonder if this will work for bluetooth devices.

    Sent from my Galaxy Note 2.
    12-05-2012 09:24 PM
  11. woodslink's Avatar
    If you want notification to go through the headset, but not speakers, try SoundAbout in Google Play. Just un-check the "Notification to speaker" option.
    01-24-2013 08:53 AM
  12. toolworker's Avatar
    Notification going through the speaker can be useful.

    I listen to a pillow speaker at night.

    But I want the alarm to sound in the morning through the phone speaker.

    My question (a bit OT) is how to turn off the beep when the charger is plugged in. (I'd settle for only turning it off when my wife is asleep. )
    06-15-2013 06:39 PM
  13. trive's Avatar
    Sound about caused my phone to have sound issues when calling people... had to uninstall
    08-10-2013 12:41 AM
  14. 1MariaS's Avatar
    Thank you so very much (crosshair) for mentioning SoundAbout in your response to someone else's dilemma.... You are awesome!! I just installed the app and restarted my phone then adjusted the settings to my preferences .... The app does Exactly what I wanted... All sounds come through my headset now! Thanks Again!
    08-29-2013 10:21 PM
  15. TheChaiShop's Avatar
    i hear constant clicking when i plug my headphones.. even if the volume is on "mute"? is that the same thing?
    its stops only when im on the main search screen. if i open the notification slide the ticking sound comes back.... any ideas of how to fix it?
    01-01-2014 12:12 PM
  16. glennsmooth1's Avatar
    I just had an online chat with Samsung Tech support. They say that all of their phones do this but couldn't give me a reason why. When you plug headphones into a phone ALL sounds should come through the headphones (you know, kind of like an iPhone). Android and Samsung, please, if you've read any of the 1,000,000 online complaints about this issue the past few years, please get this resolved. A 3rd party app shouldn't be needed to fix this.
    07-11-2015 04:31 PM
  17. glennsmooth1's Avatar
    SoundAbout has some issues. It is the only app ever to crash my Galaxy Note 4. Uninstalled.. Too bad headphone functionality isn't built in.
    07-13-2015 01:29 PM
  18. jimweda's Avatar
    Press and hold the power\lock button to mute everything except the media sound after plugging in your headset. All of the sound settings will return to your previous settings when you unplug your headset.

    This appears to be an Android bug and others are also using "SoundAbout" from the play store to work around this issue of automatically muting the external speaker when you plug in your headset.

    Issue 16667 - android - Notifications are played through external speaker when headphones are plugged in - Android - An Open Handset Alliance Project - Google Project Hosting
    I have no idea who in their right mind would have changed this. It used to work properly a long time ago. Sound About used to fix the problem but the last 4 or 5 updates the developer has messed things up and doesn't seem to know how to get it back. This is so irritating. Why would you want notifications and ringer to go to speaker when you have headphones on. And silencing those two sounds makes no sense. What if someone calls or you have an alarm set, how are you supposed to hear it. Don't say vibrate either because I never feel mine vibrate. Point is I have headphones on, I want all sounds through there, not some stranger telling me my phone is making loud sounds. Someone please make them change it back.
    06-03-2016 04:13 PM
  19. anon(9821555)'s Avatar
    Yes , I had the same issue on a sam. S5 . I found the case was getting in the way just enough to send notifications through the local speaker and music through the earbuds. I changed my headphones and eventually my case. If it persists , contact phone manufacturer since it's probably a hardware fault.
    08-08-2016 05:27 AM
  20. Bziggz's Avatar
    Might be a little late to help most out but this is for people in the future with this problem. Not sure if its a fix for everyone but this worked for me.
    Settings - > Advanced - > Accessibility - > Mono Audio -> Turn off
    Saw some stuff about a 3rd party app called SoundAbout. It will help fix the problem aswell but i kept looking for a solution because i didn't think that a 3rd party app was the only fix.
    03-18-2017 01:38 AM
  21. Mark Aled's Avatar
    Might be a little late to help most out but this is for people in the future with this problem. Not sure if its a fix for everyone but this worked for me.
    Settings - > Advanced - > Accessibility - > Mono Audio -> Turn off
    Saw some stuff about a 3rd party app called SoundAbout. It will help fix the problem aswell but i kept looking for a solution because i didn't think that a 3rd party app was the only fix.
    Sadly this wasn't a resolution for me and I'm on an S7, shocking how long this has had no confirmation of a fix on really.
    03-28-2017 01:16 PM

Similar Threads

  1. Headphones plugged in but some sounds still come out speaker
    By Timhatz in forum Verizon Galaxy S III
    Replies: 5
    Last Post: 01-24-2013, 08:55 AM
  2. Yahoo Messenger and notification sound
    By mshelf3 in forum HTC EVO 4G
    Replies: 0
    Last Post: 01-27-2011, 06:17 PM
  3. Replies: 0
    Last Post: 10-08-2010, 04:55 PM
  4. Replies: 3
    Last Post: 06-26-2010, 09:21 PM
  5. Replies: 9
    Last Post: 06-05-2010, 08:25 PM
LINK TO POST COPIED TO CLIPBOARD