1. tetaganda's Avatar
    Help!

    The worst nightmare has happened. I dropped my note 2 face down.

    First it wouldn't show anything on the screen when I press the home button or power button.

    Then after a while it worked.

    After a few hours it won't again. But the notification light is blinking blue.

    I pulled out the battery and put it back. It booted up but it says insert sim card.

    I did remove-reinsert battery again and now it's stuck on the Samsung logo.

    Whenever I remove-reinsert the battery, it would just go straight to turning on, without pressing the power button.

    I was able to enter twrp recovery and did a backup before it's too late. I don't know if I did the right thing backing up though.

    I'm on the twrp menu and I don't know what to do next.

    :-(

    Sent from my Nexus 4 (because my note 2 is being rescued) using Android Central Forums
    01-11-2013 05:11 AM
  2. Diordna11's Avatar
    Wow and sorry. Curious if you had a case on it? Hope you have insurance.

    Sent from my SGH-T889 using Android Central Forums
    01-11-2013 05:58 AM
  3. tetaganda's Avatar
    Wow and sorry. Curious if you had a case on it? Hope you have insurance.

    Sent from my SGH-T889 using Android Central Forums
    I have a folio case. I have insurance but I want to get all files first if I can. It's horrific.



    Sent from my Nexus 4 using Android Central Forums
    01-11-2013 06:11 AM
  4. PsYcHoNeWb's Avatar
    If you did a backup with TWRP then there nothing that you could have done wrong really. Once you hit go, you just let it run and when its done you are good to go with a backup on your device. Dropping your phone though makes me think that perfroming a restore might not directly solve you problem, could be something internal that needs to be repaired. However, at this point you should try the backup you have and see if it works. Just go into TWRP, wipe you data/factory reset, wipe cache, wipe dalvik and wipe system then perform your restore.
    tetaganda likes this.
    01-11-2013 07:37 AM
  5. ImmaGhost's Avatar
    have you been backing up your phone with the built in backup system? I believe it backs it up to google and you can restore everything you had from it.
    01-11-2013 04:55 PM
  6. tetaganda's Avatar
    If you did a backup with TWRP then there nothing that you could have done wrong really. Once you hit go, you just let it run and when its done you are good to go with a backup on your device. Dropping your phone though makes me think that perfroming a restore might not directly solve you problem, could be something internal that needs to be repaired. However, at this point you should try the backup you have and see if it works. Just go into TWRP, wipe you data/factory reset, wipe cache, wipe dalvik and wipe system then perform your restore.
    have you been backing up your phone with the built in backup system? I believe it backs it up to google and you can restore everything you had from it.
    Thanks! I just did what you said and it worked out! I have the scheduled backups with Google and Samsung and titanium, plus a nandroid and twrp backups before I clicked the *gasp* wipe button.

    Hopefully there's nothing hardware related. And if it is, I hope it shows up before the 30 day return Window.

    Thanks guys!

    Sent from my SAMSUNG-SGH-I317 using Tapatalk 2
    MatroxD and ImmaGhost like this.
    01-11-2013 05:34 PM

Similar Threads

  1. 4.1 Lock screen is black when music is playing
    By RTA1 in forum Google / Samsung Galaxy Nexus
    Replies: 4
    Last Post: 09-08-2012, 03:01 PM
  2. my home screen is better than your honor student
    By jrsharp70 in forum LG Viper 4G LTE
    Replies: 0
    Last Post: 09-04-2012, 11:59 AM
  3. Half my OLED Screen is Faded
    By alphanu22 in forum Verizon Galaxy Nexus
    Replies: 18
    Last Post: 03-26-2012, 02:47 PM
  4. My Nexus screen is faded/gray looking compared to my wife's
    By cirefly in forum Verizon Galaxy Nexus
    Replies: 9
    Last Post: 03-01-2012, 04:52 PM
  5. Replies: 4
    Last Post: 07-13-2010, 12:29 PM
LINK TO POST COPIED TO CLIPBOARD