1. deep_s3's Avatar
    Sometimes when i turn off my wifi it is turning ON automatically. Tried checking all the settings. I have noticed that it only happens when i am in range of a trusted and saved network. I have unchecked both options under advanced menu to check for open network and look for wifi when connected to AP. Please suggest how can we fix this.
    05-01-2013 12:23 PM
  2. Jaguarr40's Avatar
    Sorry you are having trouble with your Note II. Go here and I am sure you will find your answers:

    Samsung Galaxy Note II User Manual
    05-01-2013 01:52 PM
  3. SpookDroid's Avatar
    I'd check newly installed apps... I once installed an app that kept turning WiFi on for location services (the dev was notified and quickly fixed the bug, but in the meantime that was the culprit).

    If in doubt, 'freeze' the newest installed apps and see if that helps. (Settings--App Manager--ALL--Select App--Deactivate).

    You could also check your location settings, maybe that's what's turning the WiFi on and off.
    05-01-2013 02:42 PM
  4. deep_s3's Avatar
    Is there a smart way to understand which application is turning it ON? Any logging that i can enable to isolate this issue?
    05-02-2013 02:22 AM
  5. SpookDroid's Avatar
    You might try an app/battery monitor, but I'm not sure they can actually tell you which one triggers the WiFi toggle... I do, however, believe that under developer settings there was an option to ask you before an app attempts to do something (however, I may be wrong and this was only to request your permission to access the SD Card).
    05-02-2013 11:26 AM
  6. Borarjti's Avatar
    also look in you recent apps immediately after your wifi turns on and if you did not open an app that is open that will be your culprit. I had the same issue with pop up ads after I downloaded a n64 emulator
    05-02-2013 11:48 AM
  7. necorbin's Avatar
    Are you by any chance on Sprint? That sounds like what their Connection Optimizer does.... If so, look for it in the settings, and uncheck it.
    05-02-2013 02:21 PM
  8. lostchild's Avatar
    It is most likely a carrier customization. Some carriers won't even let you turn off WiFi at all. They want you to get off their 4G network as much as possible to preserve bandwidth. If you are able to turn off WiFi, then I would look for any carrier installed app (look under application manger ALL tab) and start disabling app with names like Smart Wifi or Smart Connect or anything that looks suspicious.
    05-02-2013 02:47 PM
  9. deep_s3's Avatar
    Nope. I am not on sprint... I am using a unlocked international model.

    Are you by any chance on Sprint? That sounds like what their Connection Optimizer does.... If so, look for it in the settings, and uncheck it.
    05-02-2013 03:34 PM
  10. deep_s3's Avatar
    Cant find any such application.. And not using any carrier specific phone...

    It is most likely a carrier customization. Some carriers won't even let you turn off WiFi at all. They want you to get off their 4G network as much as possible to preserve bandwidth. If you are able to turn off WiFi, then I would look for any carrier installed app (look under application manger ALL tab) and start disabling app with names like Smart Wifi or Smart Connect or anything that looks suspicious.
    05-02-2013 03:36 PM
  11. Vineeth Mohan's Avatar
    Hi, I am also facing this problem now. And yes, I also feel this might be because of some newly installed app. I am uninstalling some of them and check if thats the reason as I have not had this problem till now.
    07-07-2013 11:48 PM
  12. Vineeth Mohan's Avatar
    Btw, I figured out the problem with my phone, it was the Snapdragon BatteryGuru. Just change the appropriate settings and you are good to go.
    07-12-2013 10:20 AM
  13. sonyjohn's Avatar
    I have a sony xperia that also preferentially switches it's own wifi on. It gets tedious as this drops the hotspot & I have an unlimited data plan with 3 which works great, whereas the university's wifi does not. It's a handy feature if you have limited data usage but not in this case.

    Setting -> Power management -> Location based Wifi (Wi-Fi activated automatically when in range of a saved Wi-Fi network) -> [Off]
    12-19-2013 05:24 AM
  14. Jeanalyn's Avatar
    Sometimes when i turn off my wifi it is turning ON automatically. Tried checking all the settings. I have noticed that it only happens when i am in range of a trusted and saved network. I have unchecked both options under advanced menu to check for open network and look for wifi when connected to AP. Please suggest how can we fix this.
    08-26-2015 05:17 PM
  15. Eko Fristiawanto's Avatar
    Hey guys, I am happy to share my happiness, I found the solution from Wi-Fi automatically turn on. I've tried changing settings under (Location settings - improve accuracy - uncheck both of Bluetooth and Wi-Fi scanning). It seems that works for me.
    02-17-2017 12:58 AM
  16. Eko Fristiawanto's Avatar
    Hey guys, I am happy to share my happiness, I found the solution from Wi-Fi automatically turn on. I've tried changing settings under (Location settings - improve accuracy - uncheck both of Bluetooth and Wi-Fi scanning). It seems that works for me.
    02-17-2017 12:59 AM

Similar Threads

  1. WiFi Turns On Automatically When Charger Plugged In
    By fuzmeister in forum HTC Droid Eris
    Replies: 22
    Last Post: 02-19-2015, 10:30 AM
  2. Wifi turns on automatically
    By barmace in forum Samsung Galaxy S II
    Replies: 4
    Last Post: 02-07-2013, 02:19 AM
  3. Phone possessed, WiFi turns on automatically
    By jddroid in forum Verizon Droid Charge
    Replies: 2
    Last Post: 10-28-2011, 10:02 PM
  4. Replies: 7
    Last Post: 09-28-2010, 07:22 PM
  5. Replies: 9
    Last Post: 09-19-2010, 12:20 PM
LINK TO POST COPIED TO CLIPBOARD