1. 1812dave's Avatar
    this card has been in the phone since launch day which is 2? years ago. A few weeks ago I started putting a few apps on the SD card because I was getting a message about space on the internal memory when I'd install apps ( I think it was that it was down to about 3GB free on internal mem). I had no problem with the apps I moved to SD, but 2 days ago I got a message that the card was being unmounted, so I remounted and it seemed fine.

    It's the red over gray, Ultra 32GB HC I

    Another bit of info: about 10 days ago I accidently deleted all my photos so I used an app on a PC to recover them. The recovered files I placed on my PC, but not back on the card. Perhaps those deleted files which were recovered, somehow are the root cause of the problem, but geez, a week later??

    This morning, on boot up, it wouldn't mount, so I tried to manually mount, for a while it showed "checking for errors" and that process didn't complete. I pulled the card, reinserted, and the system thinks there is no card. My computer has no issues reading the card.

    I popped in a spare 16GB card I had laying around; it works. It mounted automatically and I saved a photo to it.

    Is there a solution other than buying another card or formatting it? I'm wondering if a factory reset might fix this.
    04-07-2014 08:06 AM
  2. 1812dave's Avatar
    Hmmm....I put the card in my old Bionic. It mounted and I can play music files from it.

    deleted apps from phone that had been set to run from SD card.
    Scandisk on PC showed no errors and it is about 1/2 full of files.

    put it back in phone. it is working normally.

    now i just have to reinstall the apps that had been on the SD card and this time I'll skip the larger apps and keep all apps on internal memory.

    the second thing I will do is keep my fingers crossed...
    04-07-2014 09:16 AM
  3. tube517's Avatar
    Non-Samsung SD cards do not play well with the Note 2. Get a Samsung Sd card if this one doesn't work out.
    04-07-2014 11:56 PM
  4. 1812dave's Avatar
    I've had that card for over 2 years. it has worked fine. apparently a glitch with either of the two issues I noted above; apps-to-SD, or more likely a free Windows app that recovered a few hundred deleted photos. After 2 years of use, I can't agree that the card is an issue.
    04-08-2014 03:48 PM
  5. tube517's Avatar
    I've had that card for over 2 years. it has worked fine. apparently a glitch with either of the two issues I noted above; apps-to-SD, or more likely a free Windows app that recovered a few hundred deleted photos. After 2 years of use, I can't agree that the card is an issue.
    It's a known issue with the Note 2, especially non Samsung sd cards. Even Sandisk issued replacements because they knew about the issue. Is it just Sandisk? I am not sure. But googling the issue, you see alot of people reporting problems. I bought a Samsung card because it didn't like my Sandisk card. And I reformatted that numerous times (Fat 32). I hope it works out for you but don't be surprised if it is the card being incompatible with the Note 2 if you still have problems. I would unlock my Note 2 and see it unmounting and mounting by itself every time. I got ticked off seeing it happen. Now, I have no issues at all w/the new Samsung sd card.
    04-08-2014 04:21 PM
  6. 1812dave's Avatar
    Yes I have seen the reports but my card has worked fine for years
    04-08-2014 07:16 PM
LINK TO POST COPIED TO CLIPBOARD