Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 2 of 2
  1. Thread Author  Thread Author    #1  

    Default Lookout has a Heartbleed detector app.

    All it says though is the version of OpenSSL on my device is affected (meaning the bug uses this SSL elsewhere I guess) - but the 'vulnerable behaviour is not enabled', and 'everything is OK'.
    There is then a longer page under more info. It also encourages you to agree to send info back. They have 'yet to see any attacks targeting a mobile device'.
    The app won't detect anything and is only meant to 'detect vulnerabilities in Android'. Also says its best to update to the newest version of Android if available.

    Just Lookout showing it's standing guard?

    Oh! - and the sun will come up again tomorrow.

    Sent from my SM-N9005 using Tapatalk Pro
  2. Thread Author  Thread Author    #2  

    Default Re: Lookout has a Heartbleed detector app.

    Reported from BBC.co.uk/News/Technology
    Devices with 4.1.1 and below are currently more vulnerable. - -

    "Android devices await Heartbleed fix
    14 April 2014 15:24
    By Leo Kelion

    Technology desk editor

    <Android logo>

    Version 4.1.1 of Android Jelly Bean was released in 2012
    Millions of Android devices remain vulnerable to the Heartbleed bug a week after the flaw was made public.

    Google announced last week that handsets and tablets running version 4.1.1 of its mobile operating system were at risk.

    The search giant has since created a fix, but it has yet to be pushed out to many of the devices that cannot run higher versions of the OS.

    It potentially places owners at risk of having sensitive data stolen.

    In addition security firms warn that hundreds of apps available across multiple platforms still need to be fixed.

    These include Blackberry's popular BBM instant messaging software for iOS and Android.

    The Canadian firm has said that it will not issue a fix until Friday, but said there was only an "extremely small" risk of hackers exploiting the bug to steal its customers' data.

    In the meantime the program remains available for download from Apple's App Store and Google Play.

    Data theft

    News of the vulnerability with recent versions of the OpenSSL cryptographic software library was made public last Monday after researchers from Google and Codenomicon, a Finnish security firm, independently discovered the problem.

    OpenSSL is used to digitally scramble data as it passes between a user's device and an online service in order to prevent others eavesdropping on the information.

    It is used by many, but not all, sites that show a little padlock and use a web address beginning "https".

    The researchers discovered that because of a coding mishap hackers could theoretically access 64 kilobytes of unencrypted data from the working memory of systems using vulnerable versions of OpenSSL.

    Although that is a relatively small amount, the attackers can repeat the process to increase their haul.

    HTC One S
    UK versions of the HTC One S handset cannot currently be upgraded beyond Android 4.1.1
    Futhermore, 64K is enough to steal passwords and server certificate private keys - information that can be used to let malicious services masquerade as genuine ones.

    Press reports initially focused on the risk of users visiting vulnerable websites, but attention is now switching to mobile.

    At-risk handsets

    Google's own statistics suggest that fewer than 10% of Android devices currently run version 4.1.1.

    However, since close to one billion people currently use the OS that is still a significant number.

    Some of those device owners can protect themselves by upgrading Android to a more recent version.

    But several machines are unable to be upgraded higher than 4.1.1.

    Customer websites indicate these include Sony's Xperia E handsets, HTC's One S, Huawei's Ascend Y300 and Asus's PadFone 2.

    "Privacy and security are important to HTC and we are committed to helping safeguard our customers' devices and data," said the Taiwanese firm.

    "We're currently working to implement the security patch issued by Google this week to the small number of older devices that are on Android 4.1.1."

    Asus said its device was "expecting an update imminently". Sony and Huawei were unable to comment.

    Tab grab

    Google has now created a fix to address the problem. However, manufacturers still need to adapt it for their devices and this software will need to be tested by the various operators before they release it.

    Sony Xperia E and Huawei Ascend Y300
    Sony and Huawei were not able to say when they planned to patch vulnerable devices
    Users can check which edition of Android they are running by going to the "about phone" or "about tablet" option in their Settings app.

    Alternatively several free apps have been released that can scan phones and tablets to say if they are vulnerable.

    Lookout - a security firm behind one of the products - explained how hackers might take advantage of a vulnerable handset.

    "Someone could build a malicious website or advert designed to steal data from your memory," Thomas Labarthe, the firm's European managing director, told the BBC.

    "If you happen to be browsing it and have other tabs open in your browser, it could take data from a banking site - for example.

    "No-one could steal a whole document - they can only take 64K of data - but that's still enough to steal your credentials."

    'Forgotten about'

    Another security firm, Trend Micro, has focused on the issue of vulnerable apps.

    Blackberry aims to offer safe versions of its BBM app on Friday
    These can affect any mobile operating system because the problem is caused by the servers that send data to the apps not having been updated to the latest version of OpenSSL.

    Trend Micro said it was currently aware of 6,000 such risky apps, including shopping and bank-related services. That is 1,000 fewer than its figure for Friday - suggesting some server operators are addressing the problem.

    But it acknowledged that it was hard for members of the public to know which of the hundreds of thousands on offer were safe to use.

    "Some of these are services that were set up and then forgotten about," said senior malware researcher David Sancho.

    "There's no way from using an app you can know if it's good or bad.

    "So, for the moment, the best thing to do is use the ones from the major vendors that we know have been patched... but for the minor ones that have said nothing, be wary."

    BBC 2014 "

    Sent from my SM-N9005 using Tapatalk Pro

Similar Threads

  1. Phone app keeps opening on its own
    By melillobm in forum Samsung Galaxy S5
    Replies: 23
    Last Post: 02-23-2016, 01:15 PM
  2. Gear 2 not installing any apps... any ideas?
    By fliplovin in forum Samsung Gear 2 & Gear 2 Neo
    Replies: 6
    Last Post: 09-09-2015, 02:21 AM
  3. How to display images automatically in email app
    By ZacD22 in forum HTC One M8
    Replies: 9
    Last Post: 04-16-2014, 11:14 AM

Posting Permissions