Hey guys, I have a problem with my wifi connection.

I'm going to explain everything.

I've had Sweet ROM, for many many weeks. I decided a week ago (or was that 2 weeks ago?) to try COH's kernel. I full wiped my phone. Flashed COH then Sweet. Worked perfectly fine until yesterday. I don't know what happened but the wifi just stopped working. I can see that the wifi is on but I get no connection. I wiped cache and dalvik but nothing changed. I then tried to flash JellyBeer, the wifi was perfectly working though I didn't try it for very long, I was just testing it. Then seeing as the wifi worked on JellyBeer, I reflashed Sweet again and this time with Speedmod. I didn't get pass the Signing in at the very beginning of the set up (because the wifi was bonkers again) so I went back to recovery clean installed ChaOS, wifi worked. Because I like Sweet that much, I tried to reflash it again with PhilZ this time. I didn't get pass the signing in so I gave up. Flashed Slim Bean and now, the wifi is going at it again!

After I flashed Slim Bean, I went to sleep and when I looked at my phone, the wifi was on but there was no connection. I restarted my phone, nothing happened. I turned the wifi off and on a couple of times, nothing happened. I "forget" the network, typed in my password then it's fine again. I'm tempted to flash another ROM but I'm getting tired of customising everything.

My wifi settings is ALWAYS on. So, I really don't know what's the problem here