Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 17 of 17
  1. Thread Author  Thread Author    #1  
    Dexter0380's Avatar

    Posts
    4 Posts
    ROM
    Stock

    Default No vibration with SMS in silent/vibrate mode??

    This is my first Android phone, just switched from the iPhone, and this is the first feature that I seem to be missing about my iPhone. Is there really no way to have the phone vibrate on incoming SMS using the stock messaging app?? I have looked through all of the settings and I can't figure it out. When I turn my volume down all the way, my phone vibrates as confirmation. It does vibrate on incoming calls, but that seems to be about it. I do have Haptic Feedback turned on. My Vibration setting is set to "Only in silent mode"

    Please tell me that I am missing something here. I can't believe this phone would be missing what seems like such a basic feature that virtually every cell phone I've ever owned had. If it is not an option, is this an Android thing in general or something to do with TouchWiz and the Skyrocket specifically?

    Thanks
  2. #2  

    Default Re: No vibration with SMS in silent/vibrate mode??

    You don't have the phone lying face down do you? I think that stifles all notifications. Just spitballin here - I've never noticed whether I get vibrations on sms notification
  3. Thread Author  Thread Author    #3  
    Dexter0380's Avatar

    Posts
    4 Posts
    ROM
    Stock

    Default Re: No vibration with SMS in silent/vibrate mode??

    Nope... it's either in my pocket or else laying down with the screen up. I've been doing some more research and it is appearing that the only way to have it vibrate on SMS is if you have the vibration setting set to "Always". Doesn't really make sense to me. This must also be the only way to make it vibrate on incoming emails as well.

    I have to give it to BlackBerry for having very customizable alerts. I can customize just about any alert, including settings for "in holster" and "out of holster". Wish Android would pick up on some of these options which would make it even more powerful.
  4. #4  

    Default Re: No vibration with SMS in silent/vibrate mode??

    I dont know if you have already found a fix about this but I figure it out because i was facing the same problem.
    Basically you need to go to SMS and GMAIL settings (three dots) and find the notifications section and set it to vibrate when on silent.
    Take care!
    Thanked by:
  5. #5  
    blweldon2's Avatar

    Posts
    166 Posts
    Global Posts
    167 Global Posts
    ROM
    Stock

    Default

    I had this problem before. First make sure that notifications are on in the messaging app by going to messages, pressing the menu button, and pressing settings. Scroll to the bottom and check that notifications are enabled. If it is then download Sound Manager v2 from the market. When you go in the app, press menu and tap vibrate settings. Tap the option for whenever possible under notification settings. You can then delete the app if you want.
    Wow that was long!

    Sent from my battery draining Skyrocket.
    Thanked by:
  6. #6  

    Default Re: No vibration with SMS in silent/vibrate mode??

    Quote Originally Posted by Dexter0380 View Post
    I have to give it to BlackBerry for having very customizable alerts. I can customize just about any alert, including settings for "in holster" and "out of holster". Wish Android would pick up on some of these options which would make it even more powerful.
    Have you taken a look at audio manager pro.

    I really missed the profiles settings in the bberry and I discovered this lil app. You can set ringer volumes, notification volumes, speaker volumes, etc as well as (back to your original concern) when you get vibration. You can set times of day that you want a certain profile to turn on/off.

    Also, while I'm here, I also missed the led notifications from the bberry (and my atrix). I was turned on to NoLed. This gives a little pop-up on your screen to let you know you have a missed call/text/email/facebook/etc.
  7. #7  
    NativeTxn's Avatar

    Posts
    92 Posts
    Global Posts
    96 Global Posts

    Default Re: No vibration with SMS in silent/vibrate mode??

    You can also download a SMS program like Handcent or Go SMS from the market - both of which are HIGHLY customizable.
  8. #8  

    Default Re: No vibration with SMS in silent/vibrate mode??

    Maybe there will be some Galaxy S II customers that will need an answer. I tried (emphasis on tried) the Galaxy S II with T-Mobile. Not sure if all of the variants had this problem, but it wouldn't surprise me if it did since the international version had it. There were several quirks with this phone that made me ultimately return it. One of which was the lack of my phone vibrating when I receive a text, even though Go SMS was set to vibrate and my profile under sounds was set to vibrate. I finally got it to vibrate once I went under sounds and then went under vibrate intensity, then increased the haptic feedback. That makes absolutely NO sense. At that point, the phone would vibrate based on the intensity. As a consequence, however, my haptic feedback was on whenever I was typing (even though I had not turned on haptic feedback under sounds). I am used to an HTC device. I can easily switch from Silent, Vibrate, and Ring by moving the volume rocker up or down. With the Galaxy S II, I had to download an app just to switch it to Silent (no sounds). Silent to Samsung means Vibrate. I could go into the sounds menu and tell it to never vibrate, but that also means it'll only move from silent to ring and my phone is never set to ring during normal activities. This is something that Samsung could easily fix; let the consumer control the sounds via the volume rocker, but include vibrate as an option. One last frustration was that the phone would buzz once the battery was fully charged even if I had the phone set to silent. It woke me and my wife up one night and we didn't know what the noise was until I figured it out while it was charging at work one day. I switched it to ring, and played around with all kinds of settings to no avail; it would ring or vibrate, depending on the setting. For those who want to deal with this, maybe this will help; someone put a video on youtube to show you how to use an app called Tasker that supposedly will fix the 'battery full' notification. Custom ROMs may help as well. I loved the screen, the size, and the slimness of my T-Mobile Galaxy S II. Loved that the charger was at the bottom near the microphone as well vs on the side like HTC. However, I don't feel that I should have to do all these different things to move my phone from silent to vibrate or vice versa. Audio managers are good, but it makes me wonder if they were created because of how Samsung handles sounds. Developers make apps to customize your phone, but controlling my sounds should be a basic feature and until Samsung addresses this, I will stick with HTC. I may try LG, but the G2X was not a great start for them on T-Mobile... hope this helps someone.
  9. #9  

    Default Re: No vibration with SMS in silent/vibrate mode??

    I've wondered why my text was not notifying.
  10. #10  
    Tronyx's Avatar

    Posts
    46 Posts
    Global Posts
    3,131 Global Posts
    ROM
    CyanogenMod 9

    Default Re: No vibration with SMS in silent/vibrate mode??

    This is a bug with the SkyRocket/OS. You need to have Haptic Feedback enabled in order for SMS Notifications to cause the phone to vibrate. Took me a good month to figure this out. Can't remember where I found this solution at though, but I can tell you that it does work.

    Haptic Feedback is enabled by going to Settings -> Sound and checking the box for Haptic Feedback.

    Chris
  11. #11  

    Default Re: No vibration with SMS in silent/vibrate mode??

    When your on the app thing or what ever it is hit the button were it shows you the settings for the app I just had the same problem
  12. #12  

    Default Re: No vibration with SMS in silent/vibrate mode??

    thanks blweldon2! this fixed my no-vibrate SMS problem!
  13. #13  

    Default Re: No vibration with SMS in silent/vibrate mode??

    i cant seem to find sound manager v2 and i dont have notifications are enabled either and i have the htc8x and how can i activate vibration for sms,facebook notification and email
  14. #14  

    Default Re: No vibration with SMS in silent/vibrate mode??

    i cant seem to find sound manager v2 and i dont have notifications are enabled either and i have the htc8x and how can i activate vibration for sms,facebook notification and email
  15. #15  

    Default Re: No vibration with SMS in silent/vibrate mode??

    -go to settings, hIt sound, choose vibrate only in silent, turn phone silent.
    -Go to messages, open menu, scroll down and hit notification ringtone and choose silent.
    It worked for me
  16. #16  

    Default Re: No vibration with SMS in silent/vibrate mode??

    I have my android tablet phone and I am using go sms pro..But then when someone will text me,it vibrates and I dont like it.. I have check all the setting but its the same.In the SMS,the setting that I put to vibrate is NEVER,but then it vibrates..Please,can somebody help me here to off the vibrates of my phone? Because I think its also one of the reason why it automatically comes into battery low..

    Thanks
  17. #17  

    Lightbulb Re: No vibration with SMS in silent/vibrate mode??

    Hay... I was able to fix this. I actually had inverse issue. I was unable to turn OFF vibration in Go SMS notification. It must vibrate no matter what phone status is.
    It is being set here in Go SMS settings > Advanced (tab) > Notification Settings > Default Notification Settings > and look for Vibrate. Check or uncheck it according to your desire.

Posting Permissions