Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Page 1 of 2 12 LastLast
Results 1 to 25 of 50
Like Tree10Likes
  1. Thread Author  Thread Author    #1  

    Default APN Settings for Internet and MMS for Straight Talk for At&T Samsung Galaxy SII Skyrocket

    I had the problem going through forums trying to find the settings that work for my phone but to no success but I finally figured it out and I'm posting it on here just in case some one else has my same problem.

    I had to create two separate APN's one for internet and one for MMS. Settings are as follows:

    Internet:
    Name: Straight Talk Internet
    APN: att.mvno
    Proxy: proxy.mvno.tracfone.com
    Port: 80
    User Name: Not Set
    Password: Not Set
    Server: Not Set
    MMSC: Not Set
    MMS Proxy: Not Set
    MMS Port: Not Set
    MCC: 310
    MNC: 410
    Authentication Type: PAP or CHAP
    APN Type: Internet
    APN Protocol: IPv4
    Bearer: Unspecified


    MMS
    Name: Straight Talk MMS
    APN: att.mvno
    Proxy: Not Set
    Port: Not Set
    User Name: Not Set
    Password: Not Set
    Server: Not Set
    MMSC: http://mmsc.cingular.com
    MMS Proxy: 66.209.11.33
    MMS Port: 80
    MCC: 310
    MNC: 410
    Authentication Type: PAP or CHAP
    APN Type: Internet+MMS
    APN Protocol: IPv4
    Bearer: Unspecified


    Do not forget to create two separate APN's!!!!!

    Good Luck!!!
  2. #2  

    Default Re: APN Settings for Internet and MMS for Straight Talk for At&T Samsung Galaxy SII Skyrocket

    This may sound like a dumb question but I have a samsung galaxy 2 and only one apn works I cant seem 2 have both working at the same time. I have internet but no picture messaging.
  3. #3  

    Default Re: APN Settings for Internet and MMS for Straight Talk for At&T Samsung Galaxy SII Skyrocket

    I'm having the same problem lol
  4. #4  

    Default Re: APN Settings for Internet and MMS for Straight Talk for At&T Samsung Galaxy SII Skyrocket

    I was having the problem too, having tried the settings from Straight Talk on the SIM card kit (1 APN only) AND the settings on the Straight Talk website (1 APN only).

    When I changed to your setup, things started working better.

    Thanks
  5. #5  

    Default Re: APN Settings for Internet and MMS for Straight Talk for At&T Samsung Galaxy SII Skyrocket

    I am only able to get 2G speeds on my skyrocket on straight talk even though my iphone is able to get 3g. did you have the same problem?
  6. #6  
    jedah's Avatar

    Posts
    217 Posts
    Global Posts
    228 Global Posts

    Default Re: APN Settings for Internet and MMS for Straight Talk for At&T Samsung Galaxy SII Skyrocket

    Quote Originally Posted by Jeffrey Chang View Post
    I am only able to get 2G speeds on my skyrocket on straight talk even though my iphone is able to get 3g. did you have the same problem?
    You're sure you have an ATT StraightTalk sim, and not the T-Mobile one? Supposedly, ATT StraightTalk sims have been harder to come by lately
  7. #7  

    Default Re: APN Settings for Internet and MMS for Straight Talk for At&T Samsung Galaxy SII Skyrocket

    Quote Originally Posted by tyrone_allison View Post
    I had the problem going through forums trying to find the settings that work for my phone but to no success but I finally figured it out and I'm posting it on here just in case some one else has my same problem.

    I had to create two separate APN's one for internet and one for MMS. Settings are as follows:

    Internet:
    Name: Straight Talk Internet
    APN: att.mvno
    Proxy: proxy.mvno.tracfone.com
    Port: 80
    User Name: Not Set
    Password: Not Set
    Server: Not Set
    MMSC: Not Set
    MMS Proxy: Not Set
    MMS Port: Not Set
    MCC: 310
    MNC: 410
    Authentication Type: PAP or CHAP
    APN Type: Internet
    APN Protocol: IPv4
    Bearer: Unspecified


    MMS
    Name: Straight Talk MMS
    APN: att.mvno
    Proxy: Not Set
    Port: Not Set
    User Name: Not Set
    Password: Not Set
    Server: Not Set
    MMSC: http://mmsc.cingular.com
    MMS Proxy: 66.209.11.33
    MMS Port: 80
    MCC: 310
    MNC: 410
    Authentication Type: PAP or CHAP
    APN Type: Internet+MMS
    APN Protocol: IPv4
    Bearer: Unspecified


    Do not forget to create two separate APN's!!!!!

    Good Luck!!!
    I tried your settings and now have two apn's but neither mms or internet work and as they are two seperate apn's then i csn only enable one or the other.I think i'm about fed up with Straight Talk.
    Thanked by:
  8. #8  

    Default Re: APN Settings for Internet and MMS for Straight Talk for At&T Samsung Galaxy SII Skyrocket

    Thanks! I can only select one APN so I have to choose between internet and MMS messages. What can I do?
  9. #9  

    Default Re: APN Settings for Internet and MMS for Straight Talk for At&T Samsung Galaxy SII Skyrocket

    cant get or send pic messaging. and now it wont let me send text messages
  10. #10  

    Default Re: APN Settings for Internet and MMS for Straight Talk for At&T Samsung Galaxy SII Skyrocket

    I got extras and know where to get them
  11. #11  

    Default Re: APN Settings for Internet and MMS for Straight Talk for At&T Samsung Galaxy SII Skyrocket

    I am using an At&t Samsung Skyrocket on Straight Talk, running Jellybean. Calls, internet, & mms are all working GREAT!

    My APN settings are:

    Name: straight talk
    APN: att.mvno
    Proxy: proxy.mvno.tracfone.com
    Port: 80
    Server: not set
    MMSC: http://mmsc.cingular.com
    MMS proxy: mms2.tracfone.com
    MMS port: 80
    MCC:310
    MNC: 410
    Authentication type: none
    APN type: not set

    I hope this helps....
  12. #12  

    Default Re: APN Settings for Internet and MMS for Straight Talk for At&T Samsung Galaxy SII Skyrocket

    Quote Originally Posted by MJ_33 View Post
    I am using an At&t Samsung Skyrocket on Straight Talk, running Jellybean. Calls, internet, & mms are all working GREAT!

    My APN settings are:

    Name: straight talk
    APN: att.mvno
    Proxy: proxy.mvno.tracfone.com
    Port: 80
    Server: not set
    MMSC: http://mmsc.cingular.com
    MMS proxy: mms2.tracfone.com
    MMS port: 80
    MCC:310
    MNC: 410
    Authentication type: none
    APN type: not set

    I hope this helps....
    After trying all the apn settings above my phone still wouldnt let me use internet or send and receive mms. I tried yours and they work now thank you very much!!!!
    Thanked by:
  13. #13  

    Default Re: APN Settings for Internet and MMS for Straight Talk for At&T Samsung Galaxy SII Skyrocket

    Quote Originally Posted by MJ_33 View Post
    I am using an At&t Samsung Skyrocket on Straight Talk, running Jellybean. Calls, internet, & mms are all working GREAT!

    My APN settings are:

    Name: straight talk
    APN: att.mvno
    Proxy: proxy.mvno.tracfone.com
    Port: 80
    Server: not set
    MMSC: http://mmsc.cingular.com
    MMS proxy: mms2.tracfone.com
    MMS port: 80
    MCC:310
    MNC: 410
    Authentication type: none
    APN type: not set

    I hope this helps....
    This did not work for me. I am using the SGH-S959G in Mobile, Alabama. I have rooted and upgraded to Jellybean. With the settings I got from XDA Developer Forums, I have SMS and internet working, but MMS seems to be the remaining problem. I have yet to find a configuration that allows MMS, with or without internet.
  14. #14  

    Default Re: APN Settings for Internet and MMS for Straight Talk for At&T Samsung Galaxy SII Skyrocket

    Where can you get the Straight Talk mico sims cards? Thank you.
  15. #15  

    Default Re: APN Settings for Internet and MMS for Straight Talk for At&T Samsung Galaxy SII Skyrocket

    I have a galaxy S3 AT&T. I bought a Straight Talk micro sim card.. My service is terrible and I am unable to connect to 3G service or the internet, unless using wi-fi.. I cannot change the APN settings from AT&T to Straight Talk due to the screen staying grey and not allowing for changes. Any suggestions?
  16. #16  

    Default Re: APN Settings for Internet and MMS for Straight Talk for At&T Samsung Galaxy SII Skyrocket

    Would i need to set the mms proxy to mms3.tracfone.com if im using a at&t galaxy s3?
  17. #17  

    Default Re: APN Settings for Internet and MMS for Straight Talk for At&T Samsung Galaxy SII Skyrocket

    Quote Originally Posted by elynne14 View Post
    I have a galaxy S3 AT&T. I bought a Straight Talk micro sim card.. My service is terrible and I am unable to connect to 3G service or the internet, unless using wi-fi.. I cannot change the APN settings from AT&T to Straight Talk due to the screen staying grey and not allowing for changes. Any suggestions?
    if you have no AT&T contract, then take it to an AT&T store and tell them you want it unlocked. they should be able to do it no problems. For best results, take it to a Corporate store, not an Authorized Reseller
  18. #18  

    Default Re: APN Settings for Internet and MMS for Straight Talk for At&T Samsung Galaxy SII Skyrocket

    im having same issue ony sony xperia ion and its bc i have tmobile sim. make sure u have blue att sim not pink tmobile sim
  19. #19  

    Default Re: APN Settings for Internet and MMS for Straight Talk for At&T Samsung Galaxy SII Skyrocket

    I have a Net10 Samsung S2 Skyrocket running Jellybean 4.1.2 and these are various settings to try on Straight Talk/Net10 phones. The 3rd Method is the one that worked for me all Internet and sending and receiving MMS is working:

    NET10 BYOP APN Settings
    I have two phones currently sharing one NET10 AT&T BYOP SIM card and wanted to share the APN settings, as they vary from one device to the next, even using the same SIM card.

    Setup 1: (Samsung Captivate Glide)

    Name: NET10
    APN: wap.tracfone
    Proxy: Not set
    Port: Not set
    User Name: Not set
    Password: Not set
    Server: Not set
    MMSC: http://mmsc.cingular.com
    MMS proxy: 66.209.11.32
    MMS Port: 80
    MCC: 310
    MNC: 410
    Authentication type: Not Set
    APN type: Internet+mms+supl

    Setup 2: (Motorola Atrix 2) - Initial settings & instructions as provided by NET10 CSR at NET10 Forums:

    From the home screen, press Menu
    Select "Settings"
    Select "Wireless and networks"
    (make sure that "Flight Mode" is unchecked)
    Select "Mobile Networks"
    (make sure that "Use packet data" is checked)
    Select "Access Point Names"
    Press Menu
    Select "New APN"
    The following fields appear:
    Name: Straight Talk (or NET10)
    APN: att.mvno
    Proxy: proxy.mvno.tracfone.com
    Port: 80
    User name: leave this field blank
    Password: leave this field blank
    Server: leave this field blank
    MMSC: http://mmsc.cingular.com
    MMS proxy: mms2.tracfone.com
    MMS port: 80
    MCC: 310
    MNC: 410
    Authentication type: None
    APN type: Not Set
    Press Menu
    Select Save
    Power the phone off and back on.

    Setup 3:

    Name: NET10-Tracfone-Proxy
    APN: wap.tracfone
    Proxy: proxy.mvno.tracfone.com
    Port: 80
    User name: leave this field blank
    Password: leave this field blank
    Server: leave this field blank
    MMSC: http://mmsc.cingular.com
    MMS proxy: mms2.tracfone.com
    MMS port: 80
    MCC: 310
    MNC: 410
    Authentication type: None
    APN type: Not Set

    Setup 4:

    Name: NET10-ATT-No Proxy
    APN: att.mvno
    Proxy: Not Set
    Port: Not Set
    User name: leave this field blank
    Password: leave this field blank
    Server: leave this field blank
    MMSC: http://mmsc.cingular.com
    MMS proxy: mms3.tracfone.com
    MMS port: 80
    MCC: 310
    MNC: 410
    Authentication type: None
    APN type: Not Set

    Setup 5:

    Name: NET10-Tracfone-No Proxy
    APN: wap.tracfone
    Proxy:
    Port:
    User name: leave this field blank
    Password: leave this field blank
    Server: leave this field blank
    MMSC: http://mmsc.cingular.com
    MMS proxy: mms3.tracfone.com
    MMS port: 80
    MCC: 310
    MNC: 410
    Authentication type: None
    APN type: Not Set


    Notes: Based on setting up these two phones recently, I believe it's most likely that the initial phone provisioning is best done using one of the proxy setups, and that having a strong signal helps. Once the phone is activated and fully functioning, it's usually possible to switch away from the proxy servers that seem to give a lot of people trouble, based on what I see in the NET10 forums.

    It is not required to unlock an AT&T based phone to use a NET10 (or Straight Talk) AT&T network SIM, although unlocking the phone will allow its use on other GSM networks, as long as the network supports 1900mhz for 3G/4G data.

    Quoted from "TVCCS" on androidforums.com
  20. #20  

    Default Re: APN Settings for Internet and MMS for Straight Talk for At&T Samsung Galaxy SII Skyrocket

    did you figure anything out cuz im havn the same problem
  21. #21  

    Default Re: APN Settings for Internet and MMS for Straight Talk for At&T Samsung Galaxy SII Skyrocket

    After what seemed like YEARS of talking to Straight Talk (with them arguing that my Samsung Galaxy Appeal isn't compatible with their system, EVEN though it's a no contract AT&T phone to WHICH I have a compatible sim card), I FINALLY was able to get it working through these settings, ONLY to have them shut it off for three wks. APPARENTLY I went over my UNLIMITED data, so got suspended. Put it their APN after my suspension was up and NOTHING. Came back here, and it STILL works! Thanks, my man!
  22. #22  

    Default Re: APN Settings for Internet and MMS for Straight Talk Huawei Ascend W1

    PLEASE DON'T GIVE UP!!!

    After many days, I managed to setup my MMS APN using the wap.tracfone extension. This APN setup also allows browsing to be smoother. It does not take long as long as you follow these steps:

    1. Access this website for the latest list off MMS APN and data codes:
    Updated: How to Setup Straight Talk & NET10 Data and MMS on Android, iPhone & Windows Phone | Prepaid Phone News

    2. From your phone's Homepage, go to Settings > Celluar > Data Connection. Set as off.

    3. Scroll down to the two (2) buttons labeled "edit internet apn" and "edit mms apn."
    -- If these buttons read "add internet apn" and "add mms apn," proceed to step 5.

    4. Under each, select the Trash Can icon, deleting any existing internet apn or mms apn.

    5. Back (<-) out of your Cellular settings and scroll down to network settings.
    -- Under "Current Internet APN" drop-box you may have a default APN listed. This can not be deleted.

    6. Proceed to tap the Add icon and setup a new Connection Name: "Straight Talk."

    7. Use the "T-Mobile SIM" setup to complete the necessary APN, Username (re-enter APN) & Port, leaving the Authentication type as NONE.

    8. THIS IS VERY IMPORTANT - Under proxy server use 216.155.165.40 specified in annotation number 5 (beneath the chart).
    -- I'd tried 66.209.11.33 over and over to no avail before using the above proxy and sequence of steps.

    9. Save this setting, and under the Current Internet APN drop-box make sure the new "Straight Talk" APN is listed.
    -- If you get a message that "The connection or sequence contains no elements." Press OK and disregard.

    10. Back (<-) out to your Settings list and scroll back up to Cellular > Data Connection.

    11. Under each the "add internet apn" and "add mms apn" setup the same information listed under "T-Mobile SIM."
    But, FYI:
    -- Under internet apn, enter the APN, Username (re-enter APN) proxy server (216.155.165.40) & port.
    -- Under mms apn, enter the APN, Username (re-enter APN), MMSC (URL), and MMSC port.

    12. Save your settings by pressing the disk icon after entering each the "add internet apn" and "add mms apn" information.

    13. Once saved, remain under the "cellular settings" screen. Scroll back up to Data Connection and set as ON.

    14. Return to the Homescreen, and power off your phone.

    15. Once you've rebooted, ensure that your Data Connection is set as ON and test by:
    -- Opening your web browser.
    -- MMS yourself a picture or video.

    FYI - To avoid having to download MMS messages, under Settings > applications (swipe left or right) > messaging. Set "Automatically download MMS" to ON.
    Thanked by 2:
    Michael Amick and franczhesca like this.
  23. #23  

    Default Re: APN Settings for Internet and MMS for Straight Talk for At&T Samsung Galaxy SII Skyrocket

    thanks for the post. Got my hubby a Samsung Rugby Smart, finally got it set up and phones switched,, except,, the messages wasnt working, used your post and it works now.. thanks again. i signed up to thank you..
  24. #24  

    Default Re: APN Settings for Internet and MMS for Straight Talk for At&T Samsung Galaxy SII Skyrocket

    o.k after days of playing with settings, getting some stuff to work but slow or no on others. Here is whats working for me now...key word now..LOL!
    Samsung galaxy s2 captivate

    Internet:
    Name: Straight talk
    APN: tfdata
    Proxy: 216.155.165.40
    Port:80
    User Name: Not Set
    Password: Not Set
    Server: Not Set
    MMSC:http://mms-tf.net
    MMS Proxy:66.209.11.33
    MMS Port:80
    MCC: 310
    MNC: 410
    apn type internet+mms

    had the same settings for days the only thing i just changed was
    Authentication Type:Authentication Type: PAP or CHAP
    had it at Authentication Type: PAP
    changed to Authentication Type: PAP or CHAP
    my internet is now working
    but had to download duckduckgo ap from play store
    the phone browser still doesnt work...but with duckduckgo i got reasonably fast internet, my aps work and mms works
    ??????... this works for me. good luck
    and att sim cards are hard to find had to pay $45 on ebay ...LOL!
    can you re-use sim cards? i've done it before, It worked fine.TRY to do it now....no dice.
    Last edited by Michael Burkenbine; 07-29-2013 at 08:51 PM.
    Thanked by:
    Jess M 
  25. #25  
    Bad1's Avatar

    Posts
    1 Posts

    Default Re: APN Settings for Internet and MMS for Straight Talk for At&T Samsung Galaxy SII Skyrocket

    I only have one APN setting and everything works fine. Had problems sending MMS but where eveyone says to leave out the // in MMSC I put them in mine is MMSC http://mmsc.cingular.com and everything works fine. Everything I read said to leave out the // but couldn't receive pictures just put them in and everything worked good. Just thought this might help because on my phone you can have only one APN active at a time. I use a Samsung Galaxy Captivate SHG-I897.
Page 1 of 2 12 LastLast

Similar Threads

  1. Replies: 5
    Last Post: 01-01-2013, 12:16 AM
  2. Setting the "root and tether" record straight.
    By Murph5150 in forum Verizon Galaxy Nexus Rooting, ROMs, and Hacks
    Replies: 9
    Last Post: 09-11-2012, 10:26 PM
  3. Replies: 2
    Last Post: 06-21-2012, 10:24 PM
  4. Samsung Galaxy SII Skyrocket for AT&T
    By nicholasdejohn in forum Marketplace Archive
    Replies: 1
    Last Post: 05-23-2012, 09:40 PM
  5. A noobs review of the Samsung Galaxy SII Skyrocket and Android
    By DFWPhotoguy in forum Samsung Galaxy S II Skyrocket
    Replies: 12
    Last Post: 11-25-2011, 03:56 PM

Posting Permissions