1. mitchd13's Avatar
    Hello all. I have the Samsung Galaxy S2 with Virgin Mobile as my provider (both of which I've been very pleased with up until this point) that out of nowhere has lost all signal. I can still get wifi and it works, but mobile data is "searching for service" everywhere I go. I've taken the battery out, put it back in, nothing. Restarted the phone, nothing. Tried airplane mode, nothing. I've seen removing the SIM card and putting it back in as an option, but this model does not have a SIM card or is embedded into the phone, one or the other. Any suggestions? Thanks
    04-15-2014 11:24 PM
  2. mrsmumbles's Avatar
    Try the website and see if there's an outage in your area (if they'll tell the truth, or if they even know). If you're in the US, on the Sprint towers, they do have outages every now and then.

    Sent from my Nexus 5 using Tapatalk 2
    04-16-2014 01:14 AM
  3. mitchd13's Avatar
    Thanks for responding. That seemed to be the problem, my service is now back on after leaving it overnight. Thanks again.
    04-16-2014 10:37 AM
  4. mrsmumbles's Avatar
    That's good. I hate when service is interrupted. Last summer it happened in my area, and also in Hawaii.

    Sent from my Nexus 5 using Tapatalk 2
    04-16-2014 01:23 PM

Similar Threads

  1. Replies: 23
    Last Post: 04-17-2014, 06:30 PM
  2. Bluetooth not working right with Galaxy S5
    By greenVW9 in forum Samsung Galaxy S5
    Replies: 1
    Last Post: 04-16-2014, 05:50 PM
  3. New to Android / Samsung / Galaxy s5
    By vlstewart56 in forum Samsung Galaxy S5
    Replies: 4
    Last Post: 04-16-2014, 12:13 AM
  4. Galaxy S5 lockscreen notifications
    By Shabab Huq in forum Samsung Galaxy S5
    Replies: 0
    Last Post: 04-15-2014, 09:12 PM
LINK TO POST COPIED TO CLIPBOARD