Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Page 1 of 4 1234 LastLast
Results 1 to 25 of 80
Like Tree8Likes
  1. Thread Author  Thread Author    #1  

    Default Fix for AT&T User's Slow Data Speed's! (Correct APN settings)

    This is a Fix it guide I wrote for AT&T user's. These are the correct settings for your AT&T Samsung Galaxy S II

    I hope this helps everyone who has been possibly experiencing slower speed's on AT&T Mobility.

    1'st, make sure you are on the CORRECT data plan.

    1. HSPA+ 4G 2GB plan OR for Unlimited Customer's

    2. Smartphone Personal Data plan with 4G SOC code : HSDPPB

    Then under your APN settings, I have found personally that WAP.CINGULAR is not the right APN. When your tethering you can tell what the correct gateway you should be connected to by visiting speedtest.net tethered to a PC and seeing when you run the test by your IP, it should show SERVICE PROVIDER and NOT AT&T GLOBAL NETWORK SERVICES.

    Wap.Cingular connects you to the older gateway made for 7.2 phone's. I found in real world AT&T testing it caps/throttles you at around 7.5Mbit/s or slower.

    FIX:

    Under you Access Point Settings create a new APN.

    Menu Key, New APN.

    Name : AT&T HSPA+

    Important step: tap APN and enter exactly : phone

    That's it! It's literally just "phone", not kidding. Leave everything else blank including Username and Password!

    Scroll down to APN Type, Select Internet only

    Hit the Menu Key, and hit SAVE
    Your will return to APN settings, go to the APN you just created called AT&T HSPA+, tap the dot next to the APN and make sure it turns green!

    Now for the MMS settings

    Step 2 : MMS Settings

    At the APN settings hit the menu key again and create a new APN, call it MMS

    Under APN again just type : phone


    go down to MMSC and fill the fields as follows

    MMSC: http://mmsc.cingular.com
    MMS Proxy: wireless.cingular.com
    MMS Port: 80
    MCC: 310
    MNC: 410

    APN type: MMS only

    Now again hit the menu key and save. This will be your default MMS setting and you will not need to select it.

    Once your back at the APN menu with the fields you just created, make sure AT&T HSPA+ still has a green got by it.

    Now hit the home key, then turn your phone off and back on.

    You should have full internet access if you have the correct data plan. While you may not experience faster data speed's in every area. This APN will allow you to have more consistent and through speed's, especially in an AT&T "4G" HSPA+ enhanced backhaul area.


    Here show's the difference in the two APN's. The first SpeedTest is the Wap.cingular, the second is the one we just created.

    Old APN:



    New APN: Better ping and better speed, Notice Service Provider vs. AT&T Gobal





    If you guys have any questions feel free to ask me in the forum or PM me.

    I really hope this help all of you Galaxy S 2 users on AT&T!!
    Thanked by 12:
    + Show/Hide list of the thanked
    D_L337, ch23k, Lusfre and 2 others like this.
  2. #2  

    Default

    Can anyone with a GS2 confirm this works? If so I'll make it a sticky.
    Thanked by 2:
    ch23k likes this.
  3. #3  
    chestvrg's Avatar

    Posts
    370 Posts
    Global Posts
    1,096 Global Posts
    ROM
    ICS

    Default

    Wao those are great speeds or 11.57Mbps down. Did u do this speedtest from your PC while tethered?
    my Nexus 5 32GB
  4. #4  

    Default

    Tried these changes and approximately the same as before (multiple tests). Interesting concept, but see no real change.
    Thanked by:
  5. #5  
    geekaren's Avatar

    Posts
    85 Posts
    Global Posts
    179 Global Posts

    Thumbs up

    I have an SGS2 that I'm using on AT&T, and can confirm these settings make a huge difference. Significantly reduced ping times, significantly increased data speeds.

    Quote Originally Posted by ragnarokx View Post
    Can anyone with a GS2 confirm this works? If so I'll make it a sticky.
    Thanked by 2:
  6. #6  

    Default

    Since this has worked for at least one person, I'll make it a sticky. Hopefully it will work for others as well.
  7. Thread Author  Thread Author    #7  

    Default

    Quote Originally Posted by chestvrg View Post
    Wao those are great speeds or 11.57Mbps down. Did u do this speedtest from your PC while tethered?
    Yep, USB tethered to my MacBook Pro. These speed's are in the Birmingham, AL metro area.

    Here is my fastest speed

  8. Thread Author  Thread Author    #8  

    Default

    Quote Originally Posted by stevehsteveh View Post
    Tried these changes and approximately the same as before (multiple tests). Interesting concept, but see no real change.
    It really depends on your market. What are your speed's now? If they are really low you likely wont see a change until they have enabled "enhanced backhaul" in your area.
  9. Thread Author  Thread Author    #9  

    Default

    Quote Originally Posted by geekaren View Post
    I have an SGS2 that I'm using on AT&T, and can confirm these settings make a huge difference. Significantly reduced ping times, significantly increased data speeds.
    Really glad it helped!
  10. #10  

    Default

    Wish it would work for T-Mobile.
  11. #11  

    Default

    Quote Originally Posted by locust43 View Post
    It really depends on your market. What are your speed's now? If they are really low you likely wont see a change until they have enabled "enhanced backhaul" in your area.
    2760/1500 to 3059/1550 with pings 122-150 both before and after the change to your suggested settings. I am in NJ and the speeds are constant with either APN.

    This is with the Android app speedtest (OOkla).
  12. #12  

    Default

    Darn. My Smartphone unlimited plan doesn't seem to work with those APN settings. Oh well will just have to deal with the 3-5mbps peak download and the frequent 100-200kbps speeds that plague Chicago.
  13. #13  

    Default

    Doesn't work on my s2. And I'm on a 4g 4gig plan

    Sent from my GT-I9100 using Tapatalk
  14. #14  
    geekaren's Avatar

    Posts
    85 Posts
    Global Posts
    179 Global Posts

    Default APN settings from my Infuse

    I copied these APN settings from my Infuse, posting here in case they're helping to folks having problems.

    Note: These settings are copied *exactly*... same capitalization (or not), etc.

    1st APN (all fields not listed should be left at default setting)
    Name: ATT PHONE
    APN: Phone
    MCC: 310
    MNC: 410
    APN Type: internet

    2nd APN (all fields not listed should be left at default setting)
    Name: ATT WAP
    APN: wap.cingular (note: does not include .com)
    PROXY: wireless.cingular.com
    PORT: 80
    MMSC: http://mmsc.cingular.com
    MMS PORT: 80
    MCC: 310
    MNC: 410
    APN TYPE: mms,supl
    (I realize our SGS2s only have internet or mms available to select for APN type, so I selected mms -- I'm able to send mms successfully)
  15. #15  

    Default

    hey thanks for sharing, i really do appreciate that

    i changed my iPhone 4 to the Galaxy S ii, so do I need to call AT&T and change the plan ? cuz I have the unlimited, and i did called to register the IME # but it couldn't be accepted my Galaxy S II IME in the system!! (couldn't find it or register it)

    the reason why i did this, it because of the terrible speed i get ( around 500kb ) even though i have H+, H (a lot), and 3G all the time, rarely Edge.

    I did the setting you mention, shutdown my phone and started it again, but still bad download speed!

    btw, do i call AT&T again and tell them i want "2. Smartphone Personal Data plan with 4G SOC code : HSDPPB" ?? cuz i did mentioned i wanted the Infuse 4G plan, but they couldn't do it for some reason!

    any solution ???

    Please help me
  16. #16  

    Default

    Quote Originally Posted by geekaren View Post
    I copied these APN settings from my Infuse, posting here in case they're helping to folks having problems.

    Note: These settings are copied *exactly*... same capitalization (or not), etc.

    1st APN (all fields not listed should be left at default setting)
    Name: ATT PHONE
    APN: Phone
    MCC: 310
    MNC: 410
    APN Type: internet

    2nd APN (all fields not listed should be left at default setting)
    Name: ATT WAP
    APN: wap.cingular (note: does not include .com)
    PROXY: wireless.cingular.com
    PORT: 80
    MMSC: http://mmsc.cingular.com
    MMS PORT: 80
    MCC: 310
    MNC: 410
    APN TYPE: mms,supl
    (I realize our SGS2s only have internet or mms available to select for APN type, so I selected mms -- I'm able to send mms successfully)
    @geekaren

    thanks for the help

    after I add the configuration from the ur Infuse, PING dropped from ~190-250 to 89-110 !!

    and now after about 5 test on Speedtest.net on , GS2 i got some improvement from 500kb to 1.7MB BUT it still sucks as a 3G phone and worst as H+
  17. #17  
    chestvrg's Avatar

    Posts
    370 Posts
    Global Posts
    1,096 Global Posts
    ROM
    ICS

    Default

    I'm supposed to get my GSII tomorrow and plan to add these same settings (the infuse 4G) b/c I saw that many other GSII users were having problems with the APN settings the OP posted.
    my Nexus 5 32GB
  18. #18  
    chestvrg's Avatar

    Posts
    370 Posts
    Global Posts
    1,096 Global Posts
    ROM
    ICS

    Default

    I just finished putting the infuse 4G wap. Cingular settings and it seems to work knew and Internet.

    Sent from my GT-I9100
    my Nexus 5 32GB
  19. #19  
    chestvrg's Avatar

    Posts
    370 Posts
    Global Posts
    1,096 Global Posts
    ROM
    ICS

    Default

    I need help, I just put the APN settings the OP posted, and now I'm getting very slow speeds.

    Sent from my GT-I9100
    my Nexus 5 32GB
  20. #20  
    robsw's Avatar

    Posts
    43 Posts
    Global Posts
    53 Global Posts

    Default Re: Fix for AT&T User's Slow Data Speed's! (Correct APN settings)

    SO, if I'm on an old AT&T unlimited plan, will these new settings work or do I need them to change the plan to a "4G" plan? Also, I assume I have to delete the "Cingular 410/wap.cingular" APN. If I do and need to go back b/c these don't work for me, how do I do so, not knowing the password to re-enter? Thanks in advance?
  21. #21  
    chestvrg's Avatar

    Posts
    370 Posts
    Global Posts
    1,096 Global Posts
    ROM
    ICS

    Default

    If you change the APN settings, and for some reason do not work fine, you can always reset to default and the GSII will puy back and restore the Cingular 410 apn settings.

    I personally have been going back and forth trying to find a faster APN setting, but decided to stay with the cingular 410 b/c for some reason with the Infuse setting I can't send MMS.

    The data plan, you dont need to change it and the GSII still picks up H+ signal. Remember HSPA+ Is not really 4G, it is just an enhanced HSDPA network or treated as 3.5G. True 4G is LTE and only Verizon has 4G LTE now, our GSII don't support LTE yet.

    Sent from my GT-I9100
    my Nexus 5 32GB
  22. #22  
    robsw's Avatar

    Posts
    43 Posts
    Global Posts
    53 Global Posts

    Default Re: Fix for AT&T User's Slow Data Speed's! (Correct APN settings)

    Thanks for the help. Oddly, I inputted the Infuse settings and was unable to get any data connection at all. Checked that they were saved and the ATT PHONE was selected. Could it be the sim card? Mine's a couple years old.
  23. #23  
    chestvrg's Avatar

    Posts
    370 Posts
    Global Posts
    1,096 Global Posts
    ROM
    ICS

    Default

    Quote Originally Posted by robsw View Post
    Thanks for the help. Oddly, I inputted the Infuse settings and was unable to get any data connection at all. Checked that they were saved and the ATT PHONE was selected. Could it be the sim card? Mine's a couple years old.
    Try picking up a SIM at a local at&t store. See if that fixes it. Did you delete the cingular 410 setting after adding the infuse's? I noticed that in my case it came changing back to the cingular 410 setting after having put the infuse's.

    Sent from my GT-I9100
    my Nexus 5 32GB
  24. #24  
    mrdale's Avatar

    Posts
    5 Posts
    Global Posts
    6 Global Posts

    Default Re: Fix for AT&T User's Slow Data Speed's! (Correct APN settings)

    i used the settings from the OP but unfortunately it didn't change the speed at all...
  25. #25  
    pdconner's Avatar

    Posts
    1 Posts
    Global Posts
    3 Global Posts

    Default Re: Fix for AT&T User's Slow Data Speed's! (Correct APN settings)

    07/09/2011 at 00:07
    I also bought the Samsung Galaxy S2 (unlocked) to replace my iphone 4.. Well sorta.. I had replaced the iphone 4 with a Samsung Infuse from ATT and it was 600.00 total since I paid full price (Saving my upgrade for posible iphone 5) and I had issues with the Infuse just crapping out and so I took it back and paid 200 more to a vendor to get the Samsung Galaxy S2 The first one didnt work right sent it b ack (800.00) and got another one for the same price and it worked great and looks OMG Great but the speeds in my town (area of Indianapolis) suck.. they are all over the place and sometimes I dont even get signal like I did with the iPhone 4.. I called and they are willing to take it back also but I dont understand why the speeds suck.. I go to the ATT store and test an Infuse (in Anderons Indiana) and the speeds are about 5meg down and 1 meg up.. I test my phone in the same location and they are about 2 meg down and 1 up.. I walk out of the store or drive down the road and they are sometimes 1 down and 1 up or 3 down and 1 up but always below 2. I am sick of this.. I am about to send it back and just go back to the iPhone 4 and I hate that thought.. I wanted a BIG screen.. I would go with the infuse but I live Gingerbread and the touch wiz 4.. What should I do .. please let me know what you think please.. Email me or reply here..

    By the way I did the settings above and nothing changed... This SUCKS lol any thoughts
Page 1 of 4 1234 LastLast

Tags for this Thread

Posting Permissions