1. zargon#AC's Avatar
    I am new to Samsung and am a stick in the mud mac user - trying to mount my Samsung through the usb results in nothing. On or off is no use. Preferences are set to "Mount as Volume" when connected to computer.
    Am I doing something wrong?
    I have also tried to mount it using VMwareFusion XP Professional.
    Won't mount there either.
    I know I could take the SD card out and mount but how do I access the actual phone.

    TIA for all good advice.
    09-23-2010 01:59 AM
  2. rltripp's Avatar
    I am new to Samsung and am a stick in the mud mac user - trying to mount my Samsung through the usb results in nothing. On or off is no use. Preferences are set to "Mount as Volume" when connected to computer.
    Am I doing something wrong?
    I have also tried to mount it using VMwareFusion XP Professional.
    Won't mount there either.
    I know I could take the SD card out and mount but how do I access the actual phone.

    TIA for all good advice.
    After connecting your phone to your mac with the USB cable, pull down on the notification bar at the top of the screen on your phone. Click on it where it says "USB connected" and then select "Mount"


    Hope that helps.
    09-24-2010 12:12 PM
  3. zirkwander's Avatar
    Plug your Android to Mac then from your Android go to:

    Settings>Applications>Development>USB Debug

    Make sure to check USB Debug.

    Or better yet, install Salling Media Sync
    10-01-2010 04:17 PM
  4. MANdroid5000's Avatar
    This worked for me, thanks.

    Don't just turn USB debugging on, also go into USB settings and say to mount it as media player in mass storage. Paradoxically this proceeded to mount it in mass storage on my MacBook (running 10.6.4)
    10-06-2010 02:21 AM
  5. cpuking2009#AC's Avatar
    Get a real computer and you wouldn't have petty problems like this.

    Sent from my crippled with Bing, Galaxy S phone.
    10-10-2010 04:02 AM
  6. natew's Avatar
    Get a real computer and you wouldn't have petty problems like this.

    Sent from my crippled with Bing, Galaxy S phone.
    Why even make a comment like that? I have a Mac and a Win comp and I didn't have a single problem mounting the phone on my Mac, but I did have to go to Samsung's site to get the driver for my Win computer. So I would have to say that the real comp would have to be the Mac comp in this case and I've had a Win comp since Win95 replaced Win 3.1 on PC's. This is the only Mac I've ever owned. I like them both equally. One is good for some things while the other is good for other things.
    10-19-2010 03:39 PM
  7. musorok123@yahoo.com's Avatar
    Worked for me.
    For PC - plug in, notifications, tap, mount
    For MAC - enable usb debug, plug in, notifications, tap, mount
    12-25-2010 02:51 PM
  8. TechPepsi's Avatar
    ok, I did an update to 10.6.7, last night.

    Ok, I did the menu>applications>development>USB debugging

    It will mount as a CD, with information and a few exe's and I am on a mac.
    When I got this phone I can do this with no problem!

    now, it brings up the network pan. being "detected" I do not want to network it
    It will say "this device is not readable to this computer" then will say to eject it but it ejects itself, so in the eject pan says to initialize it. Will I lose all my apps if I do this?

    Do I have reformat and downgrade to 10.6.6?

    I had no problem, before now its giving me this? Something I am doing wrong?
    I have a samsung fascinate in white
    03-22-2011 11:47 PM
  9. jon-e-o's Avatar
    I have had the same problem nd was going to post a thread asking for help! I agree it was after an OTA update. All my music and photos are on my MAC. Will keep trying. I spent over an hour on VZW tech support -- they were clueless.
    04-02-2011 06:08 PM
  10. ThinkMattClark's Avatar
    Same thing for me.

    I bought the Samsung Fascinate in December 2010... and I've managed files to and from my iMac seamlessly. Yesterday, I went to pull some photos/videos off my phone and it said...

    "The disk you inserted was not readable by this computer"
    (initialize, ignore or eject)

    Huh? What gives? Why the change? Where's the love?

    I don't want to lose my media/files on my phone — so I'm afraid to Initialize.

    Anyone with any answers... please send to me telepathically!
    (or below... whichever works best)
    04-07-2011 02:03 PM
  11. ashley167's Avatar
    ThinkMattClark-

    Same exact thing happened with me. I purchased my phone in November 2010 and no problems until recently. The exact messages pop on my screen. Have you tried settings > applications > (checking) unknown sources...? I tried that, then mounted, then nothing...

    ...Guess I will start a countdown to get the iphone, maybe that will be better with a Mac...
    04-07-2011 06:53 PM
LINK TO POST COPIED TO CLIPBOARD