Results 1 to 16 of 16
Like Tree1Likes
  • 1 Post By Rev2010
  1. Thread Author  Thread Author    #1  

    Default Galaxy III doesn't show up on my Desktop??

    I just upgraded from a GSI to a GSIII. With my old handset, I could transfer files between phone and computer (iMac) just by plugging the phone into my computer. I had the phone set as a storage device in settings. Now with the new handset, after plugging it into the computer, nothing happens. The phone does not show up on my desktop at all. The handset is set to Media device (MTP); there is a check mark next to this option. But still my iMac does not recognize the phone. I tried using Kies but I have NEVER had any luck with Kies. That is one CRAP piece of software! Any suggestions anyone?
  2. #2  
    jeffreii's Avatar
    CrackBerry Convert

    Posts
    793 Posts
    Global Posts
    3,236 Global Posts
    ROM
    Goldeneye 4.0 + CWM OUDHS

    Default Re: Galaxy III doesn't show up on my Desktop??

    While this is not exactly the plugged-in method you're looking for - I will mention that I haven't even bothered plugging my device into the computer (woohoo!)

    I have ES File Explorer and can access any of my shared drives from the phone using the wireless lan connection (new server, enter user/pass, see all the files!)

    ALSO you can use ES File Explorer in FTP mode and it will allow you to browse the files on your phone using your computer (works for my PC hopefully works for your mac). Simply enable it in ES and then open a browser (I prefer to use the windows/file explorer over the internet browsers, but both work) and enter your IP address/port (shown in ES).

    Both methods allow me to copy files to/from the phones internal storage and MicroSD with no wires needed. It took a few minutes to figure it out and now that I know what I'm doing it's a breeze.
    Thanked by:
  3. #3  
    djdosage's Avatar

    Posts
    41 Posts
    Global Posts
    101 Global Posts

    Default Re: Galaxy III doesn't show up on my Desktop??

    If you read online its pretty simple. You need to download the app that allows you to connect it to a mac. Just google and download the application. Once its installed- you plug your phone in and run it off of the photo mode, not MTP.

    from here on out- every time you plug into the comp it automatically pops up

    Thanked by:
  4. #4  

    Default Re: Galaxy III doesn't show up on my Desktop??

    Quote Originally Posted by djdosage View Post
    If you read online its pretty simple. You need to download the app that allows you to connect it to a mac. Just google and download the application. Once its installed- you plug your phone in and run it off of the photo mode, not MTP.

    from here on out- every time you plug into the comp it automatically pops up

    Actually tried this and it didn't work for me.
    Thanked by:
  5. Thread Author  Thread Author    #5  

    Default Re: Galaxy III doesn't show up on my Desktop??

    Thanks for your response mate. Which app are we talking about?
  6. #6  
    Cyber Warrior's Avatar
    Robots Will Kill

    Posts
    8,565 Posts
    Global Posts
    11,964 Global Posts

    Default Re: Galaxy III doesn't show up on my Desktop??

    Quote Originally Posted by neoflasher View Post
    Actually tried this and it didn't work for me.
    Put the phone in "camera PTP" mode... not MTP when using the android file transfer.

  7. #7  

    Default Re: Galaxy III doesn't show up on my Desktop??

    It's funny because I came on here for the same reason. I saw a pop up that said to use Samsung Kies for the PC to sync data but would rather do it like my previous phone by just plugging in and opening a folder.
  8. #8  
    djdosage's Avatar

    Posts
    41 Posts
    Global Posts
    101 Global Posts

    Default Re: Galaxy III doesn't show up on my Desktop??

    Quote Originally Posted by Cyber Warrior View Post
    Put the phone in "camera PTP" mode... not MTP when using the android file transfer.

    exactly what i told him to do
  9. Thread Author  Thread Author    #9  

    Default Re: Galaxy III doesn't show up on my Desktop??

    Thanks for the reply. Mate, I am a total newbie when it comes to android tech. Is there any way you could walk me through the process? I've already downloaded and installed ES File Explorer. I've gone into the program, and in the upper left of the menu I've clicked on LAN. What now?
  10. #10  

    Default Re: Galaxy III doesn't show up on my Desktop??

    Did you try going into "developer options" and enabling USB debugging before connecting your phone to the computer?
    Thanked by:
  11. #11  
    beh
    beh is offline
    beh's Avatar

    Posts
    350 Posts
    Global Posts
    385 Global Posts

    Default Re: Galaxy III doesn't show up on my Desktop??

    I believe your problem with a cabled connection may be that you don't have the necessary Samsung device drivers installed. Check on the Samsung website for Mac drivers and install. Then you should see your phone and be able to drag and drop files either direction. Also, Kies used with a USB cable is more straight forward as to finding devices and has much more sync functionality than when used with WiFi or Bluetooth which may be why you are having trouble moving some types of files.
  12. #12  
    jeffreii's Avatar
    CrackBerry Convert

    Posts
    793 Posts
    Global Posts
    3,236 Global Posts
    ROM
    Goldeneye 4.0 + CWM OUDHS

    Default Re: Galaxy III doesn't show up on my Desktop??

    Quote Originally Posted by RajaPee View Post
    Thanks for the reply. Mate, I am a total newbie when it comes to android tech. Is there any way you could walk me through the process? I've already downloaded and installed ES File Explorer. I've gone into the program, and in the upper left of the menu I've clicked on LAN. What now?
    You click new and then choose server. It will pop up a box for your info. You really only need to enter a username and password (in a typical scenario...). That will be your computer's username/password. I'm not sure how difficult this will be if you're not familiar with network shares...and I am of no help if you're doing it on a mac.

    It's definitely easier, I think, to do it the other way and go into ES settings, remote settings, enable remote manage. Then open up your file explorer on the computer and enter the address listed under the "remote manage" box you clicked in ES. It should allow you to access your phone from the computer and add/remove files.
  13. #13  

    Default Re: Galaxy III doesn't show up on my Desktop??

    or airdroid app in google play, you can text, browse pictures and files, contacts ect
  14. #14  

    Default Re: Galaxy III doesn't show up on my Desktop??

    Quote Originally Posted by jeffreii View Post
    ALSO you can use ES File Explorer in FTP mode and it will allow you to browse the files on your phone using your computer
    Didn't even know this and I've had ES File Explorer for a while now. Just tried this last night and it works totally awesome! I use Ubuntu Linux so I have the free gFTP installed. I think this is how I will transfer from now on.


    Rev.
    Galaxy S3
    Ubuntu Linux 10.04
    IT Tech
    jeffreii likes this.
  15. Thread Author  Thread Author    #15  

    Default Re: Galaxy III doesn't show up on my Desktop??

    Quote Originally Posted by calvin35 View Post
    Did you try going into "developer options" and enabling USB debugging before connecting your phone to the computer?
    Hey Calvin35,

    That was the problem. I went into developer options and clicked on the debugging option. Then I had to connect as as Camera (PTP), and then it was all good! Thanks dude!
  16. #16  
    jeffreii's Avatar
    CrackBerry Convert

    Posts
    793 Posts
    Global Posts
    3,236 Global Posts
    ROM
    Goldeneye 4.0 + CWM OUDHS

    Default Re: Galaxy III doesn't show up on my Desktop??

    When you connect via USB you can go to the USB notification and click on it - it will give you an option to choose between MTP and PTP.

Posting Permissions

B