1. digitalfreaknyc's Avatar
    So I was charging my galaxy S3 today in the car and the entire time that it was charging, it was making a beeping noise OR (if it went into silent mode), a vibration. It wasn't constant. It would happen every 45 seconds to 90 seconds or so. If I shut the screen off, it would go away. Any idea why that was happening? Has it happened to anyone else?
    07-07-2012 07:22 PM
  2. jcp007's Avatar
    Were you using an OEM charger? You may have a defective unit.
    07-07-2012 07:28 PM
  3. digitalfreaknyc's Avatar
    Were you using an OEM charger? You may have a defective unit.
    No but it was the same charger that I always used with my last phone. I wasn't aware of any issues with chargers.
    07-07-2012 07:36 PM
  4. jcp007's Avatar
    I never use anything but OEM chargers with each new device. I was told by a rep that BB Torch and 9900 chargers could be used but I did not feel right about it. Look at what happened in the UK when the wrong charger was used. The wrong charger could allow too much current to pass through causing damage. All chargers are not equal even if the micro USB fits.
    07-07-2012 07:44 PM
  5. ansextra's Avatar
    I never use anything but OEM chargers with each new device. I was told by a rep that BB Torch and 9900 chargers could be used but I did not feel right about it. Look at what happened in the UK when the wrong charger was used. The wrong charger could allow too much current to pass through causing damage. All chargers are not equal even if the micro USB fits.
    Are you talking about the phone that supposedly blew up? If so, they found out that someone put it in a microwave. It had nothing to do with the charger.
    07-07-2012 08:02 PM
  6. jcp007's Avatar
    Are you talking about the phone that supposedly blew up? If so, they found out that someone put it in a microwave. It had nothing to do with the charger.
    Point taken. I am mistaken but I am correct about making the wrong choice in chargers.
    07-07-2012 08:07 PM
  7. digitalfreaknyc's Avatar
    Point taken. I am mistaken but I am correct about making the wrong choice in chargers.
    Regardless, I haven't ever had a problem with other non-OEM chargers, be they car or wall. Obviously this is a new phone so there are bound to be oddities but...this was VERY odd to me.
    07-07-2012 08:08 PM
  8. jfitts75's Avatar
    maybe a bad cord, it happened to me and i found that it was charging one second then not charging the next. that beep or vibration is probably the notification that it's charging.
    07-07-2012 09:46 PM
  9. JimBen73's Avatar
    maybe a bad cord, it happened to me and i found that it was charging one second then not charging the next. that beep or vibration is probably the notification that it's charging.
    This
    07-07-2012 10:06 PM
LINK TO POST COPIED TO CLIPBOARD