1. Dave4321's Avatar
    Not sure if this has been posted, but doing this will make windows recognize both the internal memory and the sd card as a hard drive.

    Download Anycut.


    Install and run
    -New Shortcut
    -Activity
    -USB Setting
    -OK
    Return to homescreen and find the icon
    Click
    Select "Mass Storage"
    Click OK

    Kies is now turned off and your phone will be recognized as a hard drive (even though Windows 7 says it is a Portable Media player). Just double click on it and you have access to both the internal memory and the sd card.

    For verizon users, make a shortcut to "HiddenMenuWifiOffload" to disable those annoying wifi popups.
    Forgetful and persheyn like this.
    07-15-2012 10:39 AM
  2. jeffreii's Avatar
    Does this actually make a difference?

    I have Nova launcher installed so I don't need the Anycut app - you can long press on the homescreen / shortcut / activities / usb setting / usb settings - that shortcut does bring up a choice between Mass Storage and Samsung Kies.

    I changed to mass storage and plugged my phone into the computer and the result seems exactly the same as before? Also note I do not have Samsung Kies installed on my computer.

    Kies is now turned off and your phone will be recognized as a hard drive (even though Windows 7 says it is a Portable Media player). Just double click on it and you have access to both the internal memory and the sd card.
    This is how it was for me before toggling this USB setting (in Windows 7). The main gripes I have are the slower transfer rates and the fact that it seems if I MOVE a folder to another directory on the same storage, it actually COPIES it then deletes it. This can be a much slower process than simply changing the location of the folder/files on the disk without any actual copying. I moved my music folder from extsdcard/home/users/music to extsdcard/music and it took like 20 minutes!

    Also there's a little bit of a compatibility problem with older computers than can recognize UMS but not MTP/PTP.
    07-15-2012 11:55 AM
  3. blade22222's Avatar
    Mine dose this by default, just plug and play. Both card and internal.

    Sent from my SCH-I535 using Android Central Forums
    07-15-2012 03:48 PM
  4. sunlifexxx's Avatar
    For Mac users: I had to use android transfer, the application that was needed to connect my Xoom to my PC. Android.com start up android transfer on your Mac 1st before you connect your phone or will not work . Make sure on the G S III you have it set to Camera mode or MTP application. if you can't find it it's okay as when you 1st connect your phone to the USB you need to pull the notifications down, and you will see the USB symbol. You are given a choice to change it. Go ahead and change it. If the app doesn't work unplug it from the USB . go ahead and restart the transfer program and reconnect her phone.
    07-24-2012 04:18 PM
  5. Srambo217's Avatar
    Wifi File Explorer FTW!

    Sent from my SCH-I535 using Android Central Forums
    07-24-2012 07:48 PM
  6. dmmattix's Avatar
    Wifi File Explorer FTW!

    Sent from my SCH-I535 using Android Central Forums
    +1

    Plus similar performance to the USB File Copies. Additionally, don't try to delete a large file on you phone via the USB connection because at least for me it takes forever and over WiFi Explorer Pro it happens almost instantaneously.

    Mike
    07-24-2012 08:39 PM
  7. jeffreii's Avatar
    Wifi is great for my home network - I always use that over USB. However if I'm at a remote PC somewhere it's usually not quite as easy to be on their wifi and establish a LAN connection with their computer. That's when UMS would be nice!
    07-24-2012 10:36 PM
  8. funkylogik's Avatar
    Not sure if this has been posted, but doing this will make windows recognize both the internal memory and the sd card as a hard drive.

    Download Anycut.


    Install and run
    -New Shortcut
    -Activity
    -USB Setting
    -OK
    Return to homescreen and find the icon
    Click
    Select "Mass Storage"
    Click OK

    Kies is now turned off and your phone will be recognized as a hard drive (even though Windows 7 says it is a Portable Media player). Just double click on it and you have access to both the internal memory and the sd card.

    For verizon users, make a shortcut to "HiddenMenuWifiOffload" to disable those annoying wifi popups.
    nice one man. a few people have asked me how to do this how do u reverse it?
    07-25-2012 12:57 AM
  9. avhokie's Avatar
    Not sure if this has been posted, but doing this will make windows recognize both the internal memory and the sd card as a hard drive.

    Download Anycut.


    Install and run
    -New Shortcut
    -Activity
    -USB Setting
    -OK
    Return to homescreen and find the icon
    Click
    Select "Mass Storage"
    Click OK

    Kies is now turned off and your phone will be recognized as a hard drive (even though Windows 7 says it is a Portable Media player). Just double click on it and you have access to both the internal memory and the sd card.

    For verizon users, make a shortcut to "HiddenMenuWifiOffload" to disable those annoying wifi popups.
    This doesn't seem to do anything for me. It still connects as MTP, which both fails to transfer files greater than about 1.5MB and also locks up my screen with the MTP app until I unplug from USB!

    Any thoughts on what I could be doing wrong? BTW, I tried freezing the MTP app (with Titanium Backup) and after that my PC doesn't show the phone at all (even though the phone says that it is connected).
    07-27-2012 12:00 PM
  10. Roffles's Avatar
    i've tried all the usb mass storage tricks and nothing has worked for me. maybe it's the way i'm rooted, the versions of SU and busy box i'm using? i've sort of given up on it. this is my major complaint for this phone because MTP sucks! the closest i've come to making MTP half functional is to put the phone in airplane mode and then do my file transfers. for whatever reason...getting a text, e-mail or any other sort of wireless activity causes MTP to freeze and fails the transfer. so airplane mode makes it work.
    09-27-2012 03:22 PM
  11. trivor's Avatar
    Agree with the comment about hooking up to others computers BUT for your home Airdroid is the best for transferring in either direction.
    09-27-2012 04:07 PM
  12. Rev2010's Avatar
    I got so tired of the MTP mode crap (under Linux) I now just use the FTP server built into ES File Explorer. Really like it too as now I don't have to get and plug in a cable. Just doesn't transfer as fast as a cable though.


    Rev.
    09-27-2012 04:27 PM
  13. erice242's Avatar
    CryptX2: an Open Source Hardware Encrypted Storage Device | Indiegogo

    Please visit over Product Home Page and the Largest selling brand rush now just ONE click away.
    We need your support for promoting our brand.
    http://www.cryptx2.com/wp-content/up...yptX2.nfo_.txt
    11-18-2012 06:29 AM
  14. sdssix's Avatar
    Is this still working? I read this post and tried but it doesn't work with MTP or PTP.... I tried all combination of restarting, reconnecting (usb), and MTP/PTP.... I read some thread on google that the latest ICS update might have caused this.. do you know anything about this? please let me know...
    12-16-2012 10:17 PM
  15. chirschm's Avatar
    Doesn't work for me either.
    Nitin Gupta likes this.
    01-22-2013 07:40 PM
  16. Nitin Gupta's Avatar
    Same issue persists, Windows 7 does not detect the phone
    02-01-2013 05:54 PM
  17. manitmehra's Avatar
    fake
    07-07-2013 11:52 PM
  18. Sarfaraz Shaikh2's Avatar
    Also you can use this app play.google.com/store/apps/details?id=com.mohammadag.samsungusbmassstorageenabler&hl=en but you need to be rooted
    12-07-2013 08:44 AM
  19. Anup Biswas1's Avatar
    not working in galaxy core gt i8262.
    error '' unfortunately stopped ''
    02-17-2014 10:45 AM
  20. GSDer's Avatar
    not working in galaxy core gt i8262.
    error '' unfortunately stopped ''
    You are referring to USB Mass Storage Enabler: http://market.android.com/details?id...storageenabler - yes?

    And your phone is rooted?

    Since only specific models are listed as being supported, and your model is not one of them, you may want to contact the developer directly mohammad7410@gmail.com to see if you can get an answer.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk Pro
    02-17-2014 11:14 AM
  21. bricks1800's Avatar
    Im trying two get my sprint s3 too connect too my laptop" but it wont recognize it" and when I try too access mass storage through the any cut app" knox security is blocking any attempt too get too it" this is aggravating! !!!!!!!!!
    02-20-2014 11:30 AM
  22. GSDer's Avatar
    Im trying two get my sprint s3 too connect too my laptop" but it wont recognize it
    If you're having connection issues why don't you just skip the micro-USB cable and try something like WiFi File Explorer PRO: http://market.android.com/details?id...ileExplorerPRO (there's also a free version)?

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk Pro
    02-23-2014 12:23 AM
  23. aman afridi's Avatar
    how i activate mass to pc gs3?
    04-02-2014 09:57 PM
  24. GSDer's Avatar
    how i activate mass to pc gs3?
    Welcome to the forums!

    As has been noted several times, Google removed Mass Storage support in Jelly Bean - all you get now are PTP (for pictures) and MTP (for files).

    You can use any number of Wi-Fi file transfer apps along with a Web browser on your PC to avoid the USB cable if you so choose.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk
    04-03-2014 05:16 PM
  25. Don Pence's Avatar
    thats great but I dont have a USB settings option - that is my problem - samsung MEGA - no option for USB setting
    05-02-2015 07:45 PM
LINK TO POST COPIED TO CLIPBOARD