Results 1 to 12 of 12
  1. Thread Author  Thread Author    #1  

    Default Why is Gallery sucking my battery dry?

    I have a Verizon Galaxy S3, and while I love it, I've been getting some pretty bad battery life (< 2h screen time, ~8 hours total use). I noticed that Gallery kept ending up near the top of the list of things using battery. I only have about 4 pictures I've taken on this, and I did initially allow it to sync pictures with Google Images, but have since turned off any syncing of pictures. Nonetheless, Gallery keeps using up battery. Yesterday it used up 25% of the battery life, and kept the system awake for 9.5 hours. What can I do to stop this vampire?
  2. #2  
    funkylogik's Avatar

    Posts
    9,694 Posts
    Global Posts
    9,696 Global Posts
    ROM
    touchejiz

    Default Re: Why is Gallery sucking my battery dry?

    first time ive heard of that. has battery life always been so bad? maybe disable the gallery + download a different one but that really shouldnt be happening..
  3. #3  
    OWybPPgO's Avatar
    Geek Mom

    Posts
    205 Posts

    Default Re: Why is Gallery sucking my battery dry?

    I had it use a lot of battery once. I stopped it from the task manager and it stopped.
  4. #4  
    funkylogik's Avatar

    Posts
    9,694 Posts
    Global Posts
    9,696 Global Posts
    ROM
    touchejiz

    Default Re: Why is Gallery sucking my battery dry?

    QuickPic is a good gallery app. have u tried usin a different one? then u could disable the default gallery in app manager
  5. #5  

    Default Re: Why is Gallery sucking my battery dry?

    Quote Originally Posted by OWybPPgO View Post
    I had it use a lot of battery once. I stopped it from the task manager and it stopped.
    OP, Try this.
  6. #6  

    Default Re: Why is Gallery sucking my battery dry?

    This happened to me. In my case it was because Gallery was trying to continuously Sync with Picasa. Go into settings/accounts and sync and select your google account. Scroll to the bottom and uncheck Sync with Picasa Web Albums. That should fix it, it did for me. I don't use Picasa and I figure it just hung on continuous sync as a result.

    If you just stop it in task manager it will come back in a few days.

    I'd bet this is the culprit for you. Let me know if this is it or no.
  7. Thread Author  Thread Author    #7  

    Default Re: Why is Gallery sucking my battery dry?

    Thanks! I had turned off "Sync to Google Photos" but not "Sync to Picasa Web Albums", and since one of my googleapps accounts didn't have a Picasa set associated with it, I guess it just kept trying and trying to upload with no success. Turning that off seems to have fixed the problem. Thanks everyone.
  8. #8  

    Default Re: Why is Gallery sucking my battery dry?

    FYI, unless the sync on/off is set to on, you won't see the checkboxes to uncheck particular types like picassa.
  9. #9  
    kmf1's Avatar

    Posts
    159 Posts
    Global Posts
    163 Global Posts

    Default

    After reading this post I checked my phone. I unchecked Google sync for everything except Gmail and calendar. We'll see what happens.

    Sent from my GSIII using Tapatalk.
  10. #10  
    niknag's Avatar

    Posts
    29 Posts
    Global Posts
    31 Global Posts

    Default Re: Why is Gallery sucking my battery dry?

    turning Google sync for photos and Picasa Web albums off...gained nearly 20 to 30% of my battery back.. thank you so much for this tip
  11. #11  

    Default Re: Why is Gallery sucking my battery dry?

    I don
    t have any accounts synced and gallery seems to be using 53% of battery life. I even went as far as deleting every album in there and it's still sucking the life out of it
  12. #12  

    Default Re: Why is Gallery sucking my battery dry?

    Quote Originally Posted by Jennyfer0011 View Post
    I don
    t have any accounts synced and gallery seems to be using 53% of battery life. I even went as far as deleting every album in there and it's still sucking the life out of it
    Do you say you don't any account synced because you know you turned sync off, or because you think you never turned it on? Unfortunately, the default seems to be to have everything on, so you'll need to manually turn them off.
    PLEASE, when asking for help provide as much information as possible. We can't help unless we know what the symptoms are and what you did before they began.

    If I've helped you, please click the "Thanks" button.

    Have a Galaxy S3? Click here ==> Everything you wanted to know about your Galaxy S3

Posting Permissions

B