Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 19 of 19
Like Tree2Likes
  • 1 Post By jeffreii
  • 1 Post By Dhendy91
  1. Thread Author  Thread Author    #1  
    jeffreii's Avatar
    CrackBerry Convert

    Posts
    793 Posts
    Global Posts
    3,236 Global Posts
    ROM
    Goldeneye 4.0 + CWM OUDHS

    Exclamation Can't get ADB to recognize the S3

    I haven't been able to get my S3 to connect to ADB. I'm running Windows 7 Ultimate 64 Bit.

    I had this driver already installed:
    ATT_I747_GSIII_Samsung_USB_Driver_v1_4_6_0

    I enabled USB debugging and it wouldn't connect. I installed Kies, still wouldn't connect. I uninstalled the driver and Kies and rebooted. Reinstalled "ATT_I747_GSIII_Samsung_USB_Driver_v1_4_6_0", installed the Google USB driver, still won't connect.

    I'm still not sure if I'm supposed to see any sort of notification in my bar showing that USB debugging mode has been executed but I'm definitely not getting anything like that.

    Code:
    D:\APPS\ANDROID\android-sdk-windows\platform-tools>adb devices
    * daemon not running. starting it now on port 5037 *
    * daemon started successfully *
    List of devices attached
    891b0876        offline
    
    
    D:\APPS\ANDROID\android-sdk-windows\platform-tools>adb devices
    List of devices attached
  2. #2  

    Default Re: Can't get ADB to recognize the S3

    If debugging mode was enabled you would see the icon in the notification bar, do you see this if not, can you screen shot your developer option screen for me and I will try to help
  3. Thread Author  Thread Author    #3  
    jeffreii's Avatar
    CrackBerry Convert

    Posts
    793 Posts
    Global Posts
    3,236 Global Posts
    ROM
    Goldeneye 4.0 + CWM OUDHS

    Default Re: Can't get ADB to recognize the S3

    Quote Originally Posted by Dhendy91 View Post
    If debugging mode was enabled you would see the icon in the notification bar, do you see this if not, can you screen shot your developer option screen for me and I will try to help
    Thanks for the help. I have USB debugging enabled and I plugged it in for you then took a screenshot. You can see USB is connected and the dev options screen.
    Attached Thumbnails Attached Thumbnails Can't get ADB to recognize the S3-2012-09-03-11.28.06.jpg  
  4. #4  

    Default Re: Can't get ADB to recognize the S3

    Ok before we look into other things can you try these steps for me and see if any of them work

    1.Unplug the usb and plug it back again.

    2.Go to the Settings -> Applications -> Development of your device and uncheck the USB debugging mode and then check it again back!

    3.Restart the adb on your PC. adb kill-server and then adb start-server

    4.Restart your device and try again.
  5. Thread Author  Thread Author    #5  
    jeffreii's Avatar
    CrackBerry Convert

    Posts
    793 Posts
    Global Posts
    3,236 Global Posts
    ROM
    Goldeneye 4.0 + CWM OUDHS

    Default Re: Can't get ADB to recognize the S3

    Quote Originally Posted by Dhendy91 View Post
    Ok before we look into other things can you try these steps for me and see if any of them work

    1.Unplug the usb and plug it back again.

    2.Go to the Settings -> Applications -> Development of your device and uncheck the USB debugging mode and then check it again back!

    3.Restart the adb on your PC. adb kill-server and then adb start-server

    4.Restart your device and try again.
    I am not able to change the USB debugging mode setting while USB is plugged in. I disconnected it, unchecked then rechecked, then plugged back in again. I then did 3/4 and my results are in the code box below.

    Still no icon in the notification bar. All my drivers on my PC seem to be working/correct...so I am thinking it's something on the device preventing debugging mode? There must be a reason I'm not seeing the icon and it's hard to expect ADB to recognize it if the phone is not showing the icon...

    Thanks again.

    Code:
    D:\APPS\ANDROID\android-sdk-windows\platform-tools>adb kill-server
    
    D:\APPS\ANDROID\android-sdk-windows\platform-tools>adb start-server
    * daemon not running. starting it now on port 5037 *
    * daemon started successfully *
    
    D:\APPS\ANDROID\android-sdk-windows\platform-tools>adb devices
    List of devices attached
    
    
    D:\APPS\ANDROID\android-sdk-windows\platform-tools>adb devices
    List of devices attached
  6. #6  

    Default Re: Can't get ADB to recognize the S3

    Quote Originally Posted by jeffreii View Post
    I am not able to change the USB debugging mode setting while USB is plugged in. I disconnected it, unchecked then rechecked, then plugged back in again. I then did 3/4 and my results are in the code box below.

    Still no icon in the notification bar. All my drivers on my PC seem to be working/correct...so I am thinking it's something on the device preventing debugging mode? There must be a reason I'm not seeing the icon and it's hard to expect ADB to recognize it if the phone is not showing the icon...

    Thanks again.

    Code:
    D:\APPS\ANDROID\android-sdk-windows\platform-tools>adb kill-server
    
    D:\APPS\ANDROID\android-sdk-windows\platform-tools>adb start-server
    * daemon not running. starting it now on port 5037 *
    * daemon started successfully *
    
    D:\APPS\ANDROID\android-sdk-windows\platform-tools>adb devices
    List of devices attached
    
    
    D:\APPS\ANDROID\android-sdk-windows\platform-tools>adb devices
    List of devices attached
    Ok just pluged my s3 to have a play and for some reason on the s3 there is no debug notification which is annoying! I also had the same issue as you but a simple unplug of the USB cable and then toggling debuging worked for me. Let me have a think and a play and get back to you. I'm guessing that your s3 actually shows up on your computer as connected and works in kies ect so we can assume its not the drivers?

    EDIT: NVM
    Last edited by Dhendy91; 09-03-2012 at 11:30 AM.
  7. Thread Author  Thread Author    #7  
    jeffreii's Avatar
    CrackBerry Convert

    Posts
    793 Posts
    Global Posts
    3,236 Global Posts
    ROM
    Goldeneye 4.0 + CWM OUDHS

    Default Re: Can't get ADB to recognize the S3

    Quote Originally Posted by Dhendy91 View Post
    Ok just pluged my s3 to have a play and for some reason on the s3 there is no debug notification which is annoying! I also had the same issue as you but a simple unplug of the USB cable and then toggling debuging worked for me. Let me have a think and a play and get back to you. I'm guessing that your s3 actually shows up on your computer as connected and works in kies ect so we can assume its not the drivers?
    Yes it's connected in MTP mode. I can transfer files. I used ODIN last night to root it successfully.

    I installed Kies to troubleshoot but have since uninstalled it...

    I assume I am using the correct USB drivers?
    ATT_I747_GSIII_Samsung_USB_Driver_v1_4_6_0

    I got that EXE from XDA and have seen it linked in a few places...
  8. Thread Author  Thread Author    #8  
    jeffreii's Avatar
    CrackBerry Convert

    Posts
    793 Posts
    Global Posts
    3,236 Global Posts
    ROM
    Goldeneye 4.0 + CWM OUDHS

    Default Re: Can't get ADB to recognize the S3

    Maybe these screenshots will help. These are the drivers I see installed when I plug the S3 into my computer. I also included a screenshot of the drivers in my device manager.
    Attached Thumbnails Attached Thumbnails Can't get ADB to recognize the S3-usb-drivers-2.png   Can't get ADB to recognize the S3-usb-drivers.png  
  9. Thread Author  Thread Author    #9  
    jeffreii's Avatar
    CrackBerry Convert

    Posts
    793 Posts
    Global Posts
    3,236 Global Posts
    ROM
    Goldeneye 4.0 + CWM OUDHS

    Default Re: Can't get ADB to recognize the S3

    Wow. NEVERMIND?

    I was just booting up my HTPC to give it a try on there since I've never done anything with the phone on it...

    I decided to change the USB port I was using on this PC just for kicks. It works now! I now realize the port I had been trying to use was a USB 3.0 port...which should be backwards compatible...and did work fine for ODIN rooting...but not for ADB apparently.

    How annoying.

    Thanks again for your help.
    Thanked by:
    GSDer 
    Dhendy91 likes this.
  10. #10  

    Default Re: Can't get ADB to recognize the S3

    Quote Originally Posted by jeffreii View Post
    Maybe these screenshots will help. These are the drivers I see installed when I plug the S3 into my computer. I also included a screenshot of the drivers in my device manager.
    Yea ok now I am really stumped I was going to suggest checking device manager (even made a nice picture for you). If it is showing as connected as an adb device then I have no idea what it could be , I'm really sorry.
    Attached Thumbnails Attached Thumbnails Can't get ADB to recognize the S3-adb.jpg  
    Thanked by:
    jeffreii likes this.
  11. #11  

    Default Re: Can't get ADB to recognize the S3

    Quote Originally Posted by jeffreii View Post
    Wow. NEVERMIND?

    I was just booting up my HTPC to give it a try on there since I've never done anything with the phone on it...

    I decided to change the USB port I was using on this PC just for kicks. It works now! I now realize the port I had been trying to use was a USB 3.0 port...which should be backwards compatible...and did work fine for ODIN rooting...but not for ADB apparently.

    How annoying.

    Thanks again for your help.
    Haha no worries glad you got it working! Kept me procrastinating for a while.
  12. Thread Author  Thread Author    #12  
    jeffreii's Avatar
    CrackBerry Convert

    Posts
    793 Posts
    Global Posts
    3,236 Global Posts
    ROM
    Goldeneye 4.0 + CWM OUDHS

    Default Re: Can't get ADB to recognize the S3

    Quote Originally Posted by Dhendy91 View Post
    Yea ok now I am really stumped I was going to suggest checking device manager (even made a nice picture for you). If it is showing as connected as an adb device then I have no idea what it could be , I'm really sorry.
    It's all good. You couldn't have known it didn't like my USB 3.0 port!
  13. #13  

    Default Re: Can't get ADB to recognize the S3

    Quote Originally Posted by jeffreii View Post
    It's all good. You couldn't have known it didn't like my USB 3.0 port!
    Hello. I'm actually having similar issues with trying to get adb to recognize my s3. I don't have USB 3.0 so I know that's not the issue. Can anyone give some tips or advice on what I should do? I'm trying to root using noxious ninjas root tool, but s3 is not recognized.
  14. #14  

    Default Re: Can't get ADB to recognize the S3

    Well, without recreating the wheel - have you looked at all of the previous posts/screenshots? There's a wealth of information there. If so, which step are you on where your results differ from what's shown?
    1. USB debugging enabled
    2. Phone shows the USB icon in the Notification bar
    3. Computer shows the phone connected in Device Manager
    4. Device Manager shows ADB device
    5. Running adb in a Command window that was started with Administrator privilege

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk 2
  15. #15  

    Default Re: Can't get ADB to recognize the S3

    Quote Originally Posted by GSDer View Post
    Well, without recreating the wheel - have you looked at all of the previous posts/screenshots? There's a wealth of information there. If so, which step are you on where your results differ from what's shown?
    1. USB debugging enabled
    2. Phone shows the USB icon in the Notification bar
    3. Computer shows the phone connected in Device Manager
    4. Device Manager shows ADB device
    5. Running adb in a Command window that was started with Administrator privilege

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk 2
    I have USB debugging enabled. phones does show usb icon in notification bar. computer shows phone connected in device manager. not sure if device manager shows adb device. here is what I have. also i'm running on windows xp, so do i need to set something as administrator mode for that os?

    Can't get ADB to recognize the S3-untitled.jpg
  16. #16  

    Default Re: Can't get ADB to recognize the S3

    Hi Dhendy,

    I had the same issue, I tried the adb kill-server and adb start-server. It worked after that! thanks!
  17. #17  

    Default Re: Can't get ADB to recognize the S3

    What worked for me: connect phone, deinstall the USB driver (select phone in Windows device manager, select Uninstall), disconnect phone, reconnect phone, let Windows reinstall drivers...
  18. #18  

    Default Re: Can't get ADB to recognize the S3

    Hi,
    I faced this problem before. If you are using latest android version like 4.2, you need to use latest adb binary to connect to phone.
    This ADB will send a RSA key to phone from PC which is unique for every PC, which you should accept connection just like you do for a bluetooth connection.
    Then it is done. You can see your phone online.
  19. #19  

    Default Re: Can't get ADB to recognize the S3

    Been having the same probelm with an S3 Mini, and changing from the USB3 port worked for me. Thanks!

Posting Permissions