1. Giorgos Vegiris's Avatar
    Hey guys can someone give a solution to this not so big but annoying problem?!

    While on the messaging ''enviroment'' and only there, my keyboard is stuck on capital letters and there is no way to turn it back to lowercase!!
    I've tried reseting back to the manufacturer's settings, but this won't work either.

    Any ideas? Thank you !!
    01-11-2013 06:26 AM
  2. junglejunkie's Avatar
    You could try settings>application manager>all>samsung keyboard>clear data. Not sure, but worth a try.
    funkylogik likes this.
    01-11-2013 07:49 AM
  3. crester's Avatar
    What keyboard are you using?
    01-11-2013 08:36 AM
  4. Giorgos Vegiris's Avatar
    Well that didn't seem to work out... But thank you very much for the help anyway!
    01-12-2013 01:35 PM
  5. Giorgos Vegiris's Avatar
    I am using the Samsung keyboard, the one that was installed in the first place!
    01-12-2013 01:37 PM
  6. funkylogik's Avatar
    what is "environment" mate?
    a messaging app or something?
    id have said what Jungle said.
    have u tried app manager, all, keyboard, uninstall updates?


    Unbranded international rooted s3 with Official 4.1.2 JB. Paisley, Scotland, Western Europe :beer:
    01-12-2013 07:27 PM
  7. cewhitsr's Avatar
    Could it be the font that you are using?

    Sent from my SPH-L710 using Android Central Forums
    funkylogik likes this.
    01-13-2013 01:16 AM
  8. nevadah's Avatar
    in search of this very same answer, ive come across what this user is looking for.

    settings > Language and input > (device model) keyboard> *click the gear*>Advanced> Auto Capitalization
    11-13-2013 11:44 AM
  9. ARNIEN's Avatar
    I have a problem with the shift button on my galaxy S advanced, when texting I usually do so in english but I also use french spanish and greek. Today I noticed while trying to compose a msg in greek that the shift button was locked on caps (blue button with white arrow) and it only appeared when I put the keypad in greek, in all the other languages no problem!! What is even more peculiar is that when in greek it only locks when I try to enter the msg not when I try to enter the recipient, then it's normal!!!
    Help!!! how can I fix it?
    08-29-2014 05:52 AM
  10. Jenniemathers's Avatar
    I had the exact same problem. My keyboard used to work just fine, typing English, Greek and french 'naturally' auto capitalisation of the first letter of the sentence only, and with lower-case letters for the rest of the word. Yesterday when I switched to Greek language, the shift button was locked on caps (blue button with white arrow) and it only appeared when I put the keypad in Greek, in all the other languages no problem.
    I tried the settings > Language and input > (device model) keyboard> *click the gear*>Advanced> Auto Capitalization suggested by one of the respondents, but as expected, this changed only the auto-capitalisation of the first letter of the sentence in other languages (which i didn't want) but had no effect on the stuck caps lock in Greek.
    It's still well and truly stuck.
    Bizarrely. when putting in a few words of english into my sms, I noticed that the predictive text had 'remembered' and was able to insert some previously-used Greek words, spelt perfectly in alower-case letters, or a mixture of upper and lower, depending on how I'd entered them last time.
    This is new problem. It only started recently. before then, i had no problem at all when typing Greek in SMS
    It's very frustrating as nothing else has changed or been changed since it was working perfectly.
    Please reply if you really know how to solve this, but not if you're only guessing!
    09-18-2014 02:07 PM
  11. juliabulia245's Avatar
    I am having the exact same issue. The Greek keyboard input functions normally, except while using the Samsung built-in keyboard app. Pressing the shift key to turn off caps has no effect. How strange!

    Has anyone resolved this? Are there other keyboard app alternatives with a Greek input opton that functions correctly?
    09-30-2014 09:16 AM
  12. AxlMyk's Avatar
    Three people with the same problem. I'd say it was a problem with the language files. Google would have to fix it.

    AC App on SGS3
    10-01-2014 06:38 AM
  13. juliabulia245's Avatar
    Resolved!

    The text input mode of the messaging program needs to be changed to 'Automatic.'

    To do this, open up your Messaging app, click on the menu, select 'Settings,' then 'Text messages,' then 'Input mode.' From the options provided, select 'Automatic.' Your Greek keyboard should now function properly (it shouldn't be stuck on all caps anymore!).

    My input mode had previously been set to 'GSM alphabet' - this is why the keyboard only functions incorrectly on the messaging app, while working properly on your other apps.

    These instructions resolved the issue on my Samsung Galaxy S5. The steps may be a bit different for different phone models, but the core solution should be the same.

    Did that resolve the issue for anybody else?
    10-02-2014 03:02 PM
  14. Alexandros43's Avatar
    Resolved too!!

    I had exactly the same problem described above when using the Greek alphabet, keyboard was always stuck on Capitals, very anoying. Folloed Juliabulia245 instructions and worked like a charm!! Thanks very much! I also hve a Samsung 5.
    Just to improve on the instructions, you need to follow this:
    Settings
    Messages
    Text messages
    Input Mode
    Select Automatic option

    Thanks again
    10-09-2014 04:24 AM
  15. gman1980's Avatar
    I have the same problem but with SMS messages.
    Can't find a way to fix it (s5 mini device).
    10-30-2014 08:00 AM
  16. javafire13's Avatar
    Solve also for note 2.
    Thanks to juliabulia245 and Alexandros43

    Just to improve on the instructions, you need to follow this:
    Settings
    Messages
    Text messages or Input Mode
    Select Automatic option

    Thanks again
    12-16-2014 01:12 AM
  17. Loukia Maligoura's Avatar
    Tryied the automatic instead of GSM works just fine! But now instead of 160 chars it has a limit of 70.....grrrrrr
    01-06-2015 10:45 AM
  18. YiorgosAndreas's Avatar
    Thanks a lot, juliabulia245!
    Unfortunately, on the down side and similar to what the previous user said, after I type the first or second letter of the text message in Greek, my remaining character count goes from 159 down to 68. When I go back from Automatic to GSM, the character count works normally again.
    (Samsung Note 3 on AT&T)
    04-06-2015 01:54 AM
  19. Deppy Depson's Avatar
    Thank you juliabulia245. Problem solved!

    These instructions resolved the issue on my Samsung Galaxy S3 neo.
    04-07-2015 09:54 AM
  20. nvarras7's Avatar
    juliabulia245 I truly love you for finding the answer to this!!!!!! I've been writing in greeklish for a year to avoid writing in all caps.....
    12-22-2015 02:20 AM
  21. juliabulia245's Avatar
    I'm glad the solution is working for people!

    gman1980, were you able to get it working on your mini?

    As for the character limit, my guess is that, for some reason, each lowercase letters must be considered as two characters from the phone's perspective... because in both cases (Loukia and Yiorgos), the new limit is approximately half of the old limit. It's probably not something we will be able to adjust ourselves unless international character encoding goes through some change in the future.

    Maybe this is why the default setting was all caps in the first place? Perhaps the Android programmers figured more people would prefer a higher character limit than the ability to type lowercase letters... who knows!
    12-22-2015 07:56 AM
  22. tabtab40's Avatar
    Resolved!

    The text input mode of the messaging program needs to be changed to 'Automatic.'

    To do this, open up your Messaging app, click on the menu, select 'Settings,' then 'Text messages,' then 'Input mode.' From the options provided, select 'Automatic.' Your Greek keyboard should now function properly (it shouldn't be stuck on all caps anymore!).

    My input mode had previously been set to 'GSM alphabet' - this is why the keyboard only functions incorrectly on the messaging app, while working properly on your other apps.

    These instructions resolved the issue on my Samsung Galaxy S5. The steps may be a bit different for different phone models, but the core solution should be the same.

    Did that resolve the issue for anybody else?
    04-10-2016 05:46 AM
  23. tabtab40's Avatar
    Resolved the problem for me. Samsung gakaxy s2.
    Thank you
    04-10-2016 05:47 AM
  24. lionheart1962's Avatar
    Hi all,

    I had the same issue with my Samsung Galaxy note 3 & 4, running Android 5.

    Changing the text input mode of the messaging program to 'Automatic' resolved the issue for me.

    To do this, open up your Messaging app, click on the menu, select 'Settings,' then 'Text messages,' then 'Input mode.' From the options provided, select 'Automatic.' Your Greek keyboard should now function properly (it shouldn't be stuck on all caps anymore!).

    My input mode had previously been set to 'GSM alphabet' - this is why the keyboard only functions incorrectly on the messaging app, while it may work properly on other apps.

    The steps may be a bit different for different phone models, but the core solution should be the same.
    05-16-2016 10:52 AM

Similar Threads

  1. Enabling Caps Lock...
    By Tex_Norseman in forum Acer Iconia A500
    Replies: 8
    Last Post: 11-21-2015, 01:46 PM
  2. View Stuck in Locked-Security Warning
    By rsvrfactory in forum HTC EVO View 4G
    Replies: 10
    Last Post: 06-22-2014, 02:44 PM
  3. Caps Lock on 3.1?
    By mhogan in forum Motorola Xoom
    Replies: 8
    Last Post: 08-10-2012, 09:00 AM
  4. Stuck on lock screen
    By JayBurry2011 in forum Motorola Droid 2
    Replies: 5
    Last Post: 02-11-2012, 02:15 PM
  5. caps lock stuck
    By bionicmastablasta in forum Verizon HTC Thunderbolt
    Replies: 4
    Last Post: 09-24-2011, 09:31 PM
LINK TO POST COPIED TO CLIPBOARD