Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 11 of 11
  1. Thread Author  Thread Author    #1  
    raino's Avatar

    Posts
    204 Posts
    Global Posts
    6,827 Global Posts

    Default Blocking mode doesn't disable Whatsapp notifications?

    Or did I not set it up properly?
    Attached Thumbnails Attached Thumbnails Blocking mode doesn't disable Whatsapp notifications?-screenshot_2013-03-13-10-59-21.png  
    SGH-T999v running stock 4.3
  2. #2  

    Default Re: Blocking mode doesn't disable Whatsapp notifications?

    I don't know what Whatsapp does, but if it doesn't use the standard Android notification service Blocking mode won't work.for it.
    PLEASE, when asking for help provide as much information as possible. We can't help unless we know what the symptoms are and what you did before they began.
  3. Thread Author  Thread Author    #3  
    raino's Avatar

    Posts
    204 Posts
    Global Posts
    6,827 Global Posts

    Default Re: Blocking mode doesn't disable Whatsapp notifications?

    Yeah. I guess so. Oh well. Back to turning sounds off every night.
    SGH-T999v running stock 4.3
  4. #4  

    Default Re: Blocking mode doesn't disable Whatsapp notifications?

    WhatsApp has its own blocking mode, so even though that may not be the ideal solution, it's one way to handle the issue.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk 2
  5. Thread Author  Thread Author    #5  
    raino's Avatar

    Posts
    204 Posts
    Global Posts
    6,827 Global Posts

    Default Re: Blocking mode doesn't disable Whatsapp notifications?

    I see a toggle for conversation tones under settings>notifications, but that's just manual off and manual on. I was trying to recreate the "phone calls only" profile on my BlackBerry, but I guess Whatsapp doesn't play nice with the S3's notifications service.
    SGH-T999v running stock 4.3
  6. #6  

    Default Re: Blocking mode doesn't disable Whatsapp notifications?

    When you have a conversation open in WhatsApp, if you select Menu -> More you'll see a dialog that includes "Block". I haven't used it, so I don't know that it does the same thing you're looking for, but it's worth a shot.
    Or, you could contact the WhatsApp folks (Menu -> Help -> Contact Us) or android-support@whatsapp.com and see if they can include support for system-level notification blocking.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk 2
  7. Thread Author  Thread Author    #7  
    raino's Avatar

    Posts
    204 Posts
    Global Posts
    6,827 Global Posts

    Default Re: Blocking mode doesn't disable Whatsapp notifications?

    Quote Originally Posted by GSDer View Post
    When you have a conversation open in WhatsApp, if you select Menu -> More you'll see a dialog that includes "Block". I haven't used it, so I don't know that it does the same thing you're looking for, but it's worth a shot.
    Or, you could contact the WhatsApp folks (Menu -> Help -> Contact Us) or android-support@whatsapp.com and see if they can include support for system-level notification blocking.
    That block is for blocking a contact, actually. I have emailed support, let's see what they say.
    SGH-T999v running stock 4.3
  8. #8  

    Default Re: Blocking mode doesn't disable Whatsapp notifications?

    I have found a way to do it.

    You will need the LightFlow app, which i believe is a must have app for the S3 anyways.
    after you got light flow:

    1: In What's app:
    - disable notification sounds for incoming messages(not in light flow, in whats app). set it to silent or disable at all

    2: The go to light flow and:
    - enable sound notifications for whats app
    - set what ever notification sound you would like to have for whats app when blocking mode is NOT enabled
    - under Sounds-->Volume control method-->tick "Android standard notification volume"

    Now it you enable blocking mode, it also blocks what's app sounds and if blocking mode is disabled, everything is normal.

    hope that helps....took me quite a while to figure it out.

    edit: oh and i do not have any affiliation with the light flow app or their developers!!! i just used it for changing lights and came across the sound feature by chance!!!
    Last edited by Tyler_D; 04-11-2013 at 05:35 AM.
  9. Thread Author  Thread Author    #9  
    raino's Avatar

    Posts
    204 Posts
    Global Posts
    6,827 Global Posts

    Default Re: Blocking mode doesn't disable Whatsapp notifications?

    Quote Originally Posted by Tyler_D View Post
    I have found a way to do it.

    You will need the LightFlow app, which i believe is a must have app for the S3 anyways.
    No thanks. Light flow pushes out audible alerts, like "workscreen x of y." I'll pass.
    SGH-T999v running stock 4.3
  10. #10  

    Default Re: Blocking mode doesn't disable Whatsapp notifications?

    This is a pain really, looks like a poorly designed app. On the iPhone you set 'Don Not Disturb' and it works. No problem. But with the Galaxy phone and Blocking Mode, surprise surprise, there's a glitch because of the way app developers design their notifications to work. Yes you can use 'Mute' but some people need urgent calls to get through and also find it useful to have Whats App. Overall I prefer Android but it's crap like this that make iPhones an attractive proposition. Esp if they got a bigger screen.
  11. Thread Author  Thread Author    #11  
    raino's Avatar

    Posts
    204 Posts
    Global Posts
    6,827 Global Posts

    Default Re: Blocking mode doesn't disable Whatsapp notifications?

    The problem can be easily fixed by the OS retaining control of notifications, and not relying on apps to adhere to blocking mode guidelines of some sort. Anyway, I use Llama now, and that's worked.
    SGH-T999v running stock 4.3

Similar Threads

  1. Replies: 2
    Last Post: 12-05-2013, 05:03 PM
  2. how do you disable Audible Notifications during phone call
    By kwyatt318 in forum AT&T Captivate
    Replies: 4
    Last Post: 11-20-2013, 11:19 AM
  3. Replies: 10
    Last Post: 06-21-2012, 08:23 AM
  4. Replies: 3
    Last Post: 06-28-2011, 05:17 PM
  5. Where is a setting to disabled the notification light?
    By greydarrah in forum Motorola Droid X
    Replies: 0
    Last Post: 08-04-2010, 07:52 AM

Posting Permissions